Recent Topics

[3.3.3] .htaccess alterations result in 404 not found

Started by on Apr 04, 2013 – Contents updated: Apr 07, 2013

Apr 04, 2013 12:47    

I was trying to fiddle about with my .htaccess this morning and I have broken my blog.

My .htaccess is:

# Apache configuration for the blog folder
# Lines starting with # are considered as comments.

# PHP SECURITY:
# this will make register globals off in the evo directory
<IfModule mod_php4.c>
php_flag register_globals off
</IfModule>
<IfModule mod_php5.c>
php_flag register_globals off
</IfModule>

# PHP5
# This may need to be in each folder:
# AddHandler application/x-httpd-php5 .php

# CLEAN URLS:
# If you're using Apache 2, you may wish to try this if clean URLs don't work:
# AcceptPathInfo On

# DEFAULT DOCUMENT TO DISPLAY:
# this will select the default blog template to be displayed
# if the URL is just .../blogs/
<IfModule mod_dir.c>
DirectoryIndex index.php index.html
</IfModule>

# CATCH EVERYTHING INTO B2EVO:
# The following will allow you to have URL right off the site root,
# using index.php as a stub but not showing it.
# This will add support for URLs like: http://example.com/2006/08/29/post-title

#RewriteEngine On

# This line may be needed:
#RewriteBase /

# Redirect anything that's not an existing directory or file to index.php:
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteRule ^ index.php

----------------
Which I gather is the default htaccess for 3.3.3

This results in: The requested URL /home/user/public_html/ was not found on this server.

My .htaccess is is in the root.

It should be simple but I can't see what I'm done wrong. Could anyone help?

Thanks

Cliff

Apr 04, 2013 13:34

Sorry, ignore that everyone--I've got it working as far as adding the /index.php ending. I don't seem to be able to remove that (despite following the clean URL instructions on this forum) but I'll keep trying.

Apr 05, 2013 11:50

Thanks tilqicom -- I'd love to send a link but my blog's just a private one.

I've got it working by

1) deleting the htaccess altogether
2) downloading the sample htaccess for 3.3.3 as listed in the archive of old .htaccess files and placing it in root
3) Adding Yabba's code tidy URL redirect snippets in sam2kb's thread at http://forums.b2evolution.net/topic-18121
4) Then admin > blog settings > URLs > absolute URL = http://myblog.com/

Memo to self: ALWAYS back up your .htaccess every time you change a comma!


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.