Recent Topics

Back office access without seeing admin settings

started by on Feb 21, 2017 – Last touched: Feb 27, 2017

Feb 21, 2017 01:13    

Hi,

I am not sure where to post this. I recently set up a test user for my site in order to get a feel of what the user sees when they activate their account. I am not sure this question will make sense. So here goes... How can I set up user permissions so that the user can have access to the back office in order to post in the blogs (either their own blog or the community blog) plus start their own collections but, not be able to see the Administrator setting? When I use the test user account I notice I can see all of the administrator functions and change them at some point.

Any help for a very confused admin would be greatly appreciated. Thanks.

Feb 22, 2017 01:07

It all depends on which User Group your test user belongs to.

b2evolution has some default groups with different permissions: http://b2evolution.net/man/default-user-group-settings

For each group you can customize exactly what the members of the group are allowed yo do. If needed you can also create additional groups.

Feb 22, 2017 11:59

Thanks for responding.

I have the test user under the default user group "normal Users". When I set up the blog permissions for this group, with no back office access they could not see their blog. There was no option to post. There was no link in their profile that allowed them to set up their blog. Mind you the blog permissions were set to have full access and automatically get a blog upon sign up.

Hopefully, I'm not confusing in my explanation.

Thanks

Feb 26, 2017 15:13

Hopefully, I'm not confusing in my explanation.

I'm not sure. Were you able to fix the permissions in a way that works for you?

Feb 26, 2017 21:10

Hi,

I finally got it. Thanks.

Feb 26, 2017 21:19

This script is awesome. I forgot to mention. :)


Form is loading...

powered by b2evolution – This forum is powered by b2evolution CMS, a complete engine for your website.