Recent Topics

Category List widget with hidden category in submenu container

started by on Apr 08, 2015 – Last touched: Apr 14, 2015

Apr 08, 2015 04:09    

I've found what appears to be an html recursion bug in the Category List widget. Steps to reproduce:

1. Set up a list of categories in your blog
2. Apply the Category List widget to the Submenu Container
3. In the Category List widget, set one category as "excluded"

In the rendered page's source, the excluded category appears to leave behind a closing 'list tag' with no opening tag.

OR:
1. Set up a list of categories in your blog
2. Set one category as a subcategory of another (i.e. MainCat, MainCat\SubCat)
3. Apply the Category List widget to the Submenu Container
4. In the Category List widget, set MainCat as "excluded"

This scenario causes the same extra tag, so it appears to be the hidden category that causes it.

Interestingly, this doesn't seem to happen when the category list widget is used in the sidebar container.

Apr 10, 2015 05:00

Hi @jibberjab,

I can't reproduce this issue as you described. Can you please send us a screenshot and tell us what version of b2evo and browser are you using and also the rest of parameters in your Category List widget?

Thanks.

Apr 10, 2015 22:32

I hope the arrangement isn't confusing. I didn't have a lot of time to plan it out :) You can see the orphaned closing list item, as highlighted by firefox's source viewer (FF37). This is on b2evo 5.2.2 stable.

Apr 14, 2015 00:16

All right @jibberjab, I'll keep an eye on this and let you know.

Thanks.


Form is loading...

powered by b2evolution CMS – This forum is powered by b2evolution CMS, a complete engine for your website.