Recent Topics

Draft Preview in 6.7.3 is not working

Started by on Jun 11, 2016 – Contents updated: Feb 09, 2018

Jun 11, 2016 22:35    

After Upgrading to 6.7.3 the preview of a draft fails. It does not show up. (to post a screenshot does not really make sense, because by clicking preview the draft is not previewed)
To check my editing I have to save the draft as "privat", "community" etc. fist, But this shows the cached version. So this does not really work instead of a draft preview.

Jun 14, 2016 01:47

This has been answered several times already and is fixed in b2evolution 6.7.4.

Jun 20, 2016 23:50

I have 6.7.4 and have issues. Firstly it is not displaying the content, only the title.

it also produce warnings

Jun 20, 2016 23:58

I notice that it also does not show the full post in single view? I am using Bootstrap Blog

Jun 21, 2016 03:12

Please double check that your 6.7.4 upgrade worked correctly and that your browsing isn't serving you a cached page for some reason.

Jun 21, 2016 07:05

I did follow those on install and NEVER enable page caching.
I checked for page caching at:
/admin.php?ctrl=collections&tab=blog_settings&blog=2
/admin.php?ctrl=collections&tab=site_settings
I also cleared all caches

the post content is not showing in _single.disp.php
and not even when changing the skin

Jun 21, 2016 18:32

Solved: /admin.php?ctrl=widgets&blog=2

I needed to enable "Item Content" in single container.

Also, Item Preview is also fixed, in fact it never had a bug (6.7.4) I accidentally mixed 6.7.3 files with 6.7.4 files

Feb 09, 2018 19:42

@achillis @fplanque

Preview worked pretty fine until I switched from http to https
Now, preview dos not work.

How to fix this?

Regards, Will

Feb 09, 2018 20:59

I figured it out.
I intended to switch only few of my collections from http: to https: (as matter of costs). Therefore, I supposed, I should keep the base_url in basic_config to http.
I tried some interventions and at least I changed also the base_url to https:
Now preview works pretty fine again.

And those subdomains I kept http do work without any problems, too.

I hope to find some time slots to make a how to post for those who intend to switch to https, too (because of GDPR). The procedure is not really difficult, but it needed time to deal with some obstacles, especially for me, who is not familiar with SSL and how things are linked on b2e. I suppose there may be more guys out there who find themselves in a similar situation.


Form is loading...

powered by b2evolution – This forum is powered by b2evolution CMS, a complete engine for your website.