Recent Topics

Swithing between one "Region" to another after ins

started by on Oct 13, 2008 – Last touched: Apr 20, 2013

Oct 13, 2008 21:08    

I am trying to help someone else to install b2e 2.45 for a new translation. But what I am running is a strange situation, that is, I can't get out of the "region" setting provided at the installation time.

Say I am installing the software in zh-CN. It works fine. Later, I would like to switch back to "en-US" for example. So I changed it under the admin/global setting/regions. And I also change the setting for my first blog under admin/blog setting/general. While I am doing those changes, the admin interface remains the same as I originally set. But if I log off, then the English interface starts to kick in. That's ok. Right?

But when I log in back again, the first time the admin toolbar shows in English. Then, immediately after, it goes back to my original interface setting again. If I check the setting for global and for the first blog. The display does show "English(US)" regardless the inferface actually is not.

Did I miss something here? Thanks in advance of your help!

Oct 13, 2008 21:25

You forgot to change user locale to English(US) from user profile

Oct 13, 2008 21:53

Bingo! That's resolved my mystery. Thanks, Sam.

Now, question #2. How I can provide some setting for "anonymous" users? I think this has been brought up. But I don't remember if I saw some solution.

In my testing to this region, zh_TW, which actually has been defined in the /conf/_locales.php, the region setting works only when users login. If user log out, then the display becomes a mess. All Chinese text and menus turn into ? characters.

I assume that the b2e checks the user profile before sending out the text stream with charset or other header information. But in the situation of anymous visiting, the program is taking some default information and sending out this header which messes up the display. Any thought where I can force some setting? Thanks again.

Oct 13, 2008 21:59

First choose the locale you want to use for both users and visitors by default, then set it everywhere (Blog settings, Global settings, User settings, conf/locales.php)

If somebody registered in blog he/she can select another locale to use.

Oct 13, 2008 22:31

Thanks Sam. I forgot those. It is working now.


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.