Recent Topics

I cannot write in Czech language, please help me, anyone????

started by on Apr 06, 2010 – Last touched: Feb 14, 2015

Apr 06, 2010 00:06    

Hello, I am writing my blog in Czech language, I tried to change the setttings and localize the blog for Czech language, without any success. Certain characters of the Czech alphabet are not displaying properly. Can anyone help me with this??? I know it is possible, I just do not know how :(
Thank you very much in advance...

Apr 17, 2010 22:42

I will make a video and image tutorial to a perfect international install, and will post back here once i do if i can remember...so follow this topic in case i do..

Untill then, keep in mind

Before Install..

1.) Create DB first, with utf8_general_ci or utf8_unicode_ci collation
-If you have created your db already;
Take a look at your PhpMyAdmin tables, you will probably see their collation is latin_swedish_1 or sth which is the default mysql collation, which is not right in your case, So;
Edit: so go ahead and convert "[u]all[/u]" of your sql tables, !and sub_tables collation to utf8(general or unicode to be safe again)

After Install..
2.) Proceed with the install, Go to Regional Settings and make sure your Language matches your page encoding.. (i recommend using utf8 language with utf8 encoding just to be safe)

The above tips applies to all languages, there are a few more tweaks you could do just to be safe but nvm, the above should do the trick

Apr 19, 2010 08:40

I did not install it myself, I did it through Fantastico, however, your tip led me to something else..
even though the installation was in Uft8, the PHP was in uft8 , the collation remained in swedish latin 1, so I ordered the SQL to respect the uft8, by commanding
alter table b2_comments convert to character set utf8; that did the trick, after several failures, including trying to change a locale etc. So the answer did lay in collation..

Apr 19, 2010 09:21

wendy wrote:

your tip led me to something else..
the answer did lay in collation..

that's what i ve said, it's not sth else ;) btw, make sure "all" of your tables collation is utf8 not only b2_comments.

Feb 14, 2015 01:20

Use version 6 (available on GitHub) and 100% UTF-8.


Form is loading...

powered by b2evolution – This forum is powered by b2evolution CMS, a complete engine for your website.