Recent Topics

[New_Skin 3.x + 4x] Chita

Started by on Nov 29, 2010 – Contents updated: Nov 29, 2010

Nov 29, 2010 08:11    

My b2evolution Version: Not Entered

[url=http://skins.b2evolution.net/two.php/2010/12/01/chita]DOWNLOAD || DEMO[/url]

http://www.tilqi.com/assets/ss1.jpg

Advanced Color Picker & Custom Colors
http://www.tilqi.com/assets/t6.jpg
Customizable Image Slider
http://www.tilqi.com/assets/t4.jpg
Google Web Fonts
http://www.tilqi.com/assets/t5.jpg
Adjustable cross-browser skin width
http://www.tilqi.com/assets/t2.jpg
Further Settings
http://www.tilqi.com/assets/t3.jpg

Nov 30, 2010 23:14

Code

Fixed:
3.x evo toolbar disappearance.
3.x help_link

TODO:
Code & files clean-up.
Custom colors does not override presets.
2.x compatible version.
Further optimization. (compress and minified js and css options)

More preferences:
More presets and backgrounds.
More social sharing options, and "add your own".
Detailed color choosing for each div(header content footer), each element(links, text, background etc).
New blog icon sets, social icon sets.

Even more:
More slider choices.
Lightbox option.
More widget containers.
Widgetized slider.
Front-end editing.

Dec 06, 2010 04:45

The skin has been updated to 0.2.
There is a lot of work to get to what i pictured in mind for this skin.But it will be better if i can get more user feedback.

Code

Fixed/Added in 0.2:
*Fixed Validation Errors.
*Advanced Custom colors.
*Custom colors now overrides presets.
*Infinite scroll (endless page) post loading -twitter style- with settings.
*Partial code/image clean up, partial semantic markup correction.

http://www.tilqi.com/assets/chit7.jpg
http://www.tilqi.com/assets/chita6.jpg

TODO:
Code & files clean-up.
2.x compatible version.
Further optimization. (compress and minified js and css options)

More preferences:
More presets and backgrounds.
More social sharing options, and "add your own".
New blog icon sets, social icon sets.

Even more:
More slider choices.
Lightbox option.
More widget containers.
Widgetized slider.
Front-end editing.

[/quote]

Dec 29, 2010 00:07

My b2evolution Version: 4

I can't seem to get the advanced parameters for the slider to work - specifically I have it set to "fade" but it's still sliding, not fading. Suggestions?

http://wccoa.org/index.php/Home/

Dec 29, 2010 00:16

Awesome skin! I've posting issues in the support section as I find them... I REALLY like this concept though - really nice work!

Dec 29, 2010 00:21

Ethan5150 wrote:

Awesome skin! I've posting issues in the support section as I find them... I REALLY like this concept though - really nice work!

Thank you.It's nothing like i imagined yet.It's full of bugs and nowhere ready.But i just wanted to let it out there and get a few responses and proceed accordingly.However it didnt attract enough attention.So i doubted if it would worth the time to complete it.Because it literally needs hours/days of work and thought to put in before it can be used on production sites.

Dec 29, 2010 00:24

Well count me in for bug testing - I'd love to go live with this skin in a month or so if you're up to it... This skin really takes a huge leap forward in simplifying styling options - I hope you decide to keep at it!

Dec 29, 2010 00:30

Ethan5150 wrote:

My b2evolution Version: 4

I can't seem to get the advanced parameters for the slider to work - specifically I have it set to "fade" but it's still sliding, not fading. Suggestions?

http://wccoa.org/index.php/Home/

Have you checked the very unnecessary "use advanced parameters" on ?
It may still be buggy though.the code needs to be restructured.

Ethan5150 wrote:

My b2evolution Version: 4

I have the option set to off for displaying the permalink but it is still there - suggestions?

That's also a bug, i forgot to add the conditional there.

Ethan5150 wrote:

Well count me in for bug testing - I'd love to go live with this skin in a month or so if you're up to it... This skin really takes a huge leap forward in simplifying styling options - I hope you decide to keep at it!
Awesome skin! I've posting issues in the support section as I find them... I REALLY like this concept though - really nice work!

Thank you for your words of praise, and for your support.
What i had in mind was to build a framework for future rather than a skin, but as i said, it's nothing near what i have in mind, but i need a lot of time to get there.
The code was quickly written without much attention.

I will review the skin, release an update, and add it to SVN for quick access.

However skin directory is manually controlled and you know we do not have much admins/moderators, therefore it sometimes takes too much time before a skin gets updated even after you submit it.And you wouldnt want to bother these handful of people whom are putting all their time left from their paid work.Shortly it's a little complicated process.

By the way, the idea that started me off with the tempalte was to make a seo-friendly quick loading skin, but it turned out to be sth different.
Allthough if you turn off all the extra options, you get insane loading times as low as 0.6 seconds

Dec 29, 2010 00:37

Yeah, the advanced params is set to on but the controls don't seem to work quite right - another example is if I set the delay speed to 1000 (instead of the default 3000) it kind of freaks out... (ex: http://wccoa.org/index.php/Home/)

Dec 29, 2010 00:40

actually i had a few issues fixed that i havent updated, let me update those and upload to sourceforge svn for you to download in half an hour or sth.you are using the 0.1 initial, and there is already an unreleased 0.2, i will round it up for you.

Dec 29, 2010 02:09

okay, not much new but it should be better than what you are using now, here is the fixed version :

http://sourceforge.net/projects/b2revolution/files/Chita/0.3/chita0.3.zip/download

@sam2kb feel free to update it in the skins directory if you like, since this one sucks less than the initial version.

/* 0.3 extensions restructured (slider,inf scroll)
updated google fonts.
fixed infinite page numbers for infinite scroll//thanks to sam2kb

fyi: you can also access the individual files on svn if you have a sourceforge account [url=http://b2revolution.svn.sourceforge.net/viewvc/b2revolution/chita/]here[/url]

Dec 29, 2010 08:14

Hmm, now the slider doesn't appear to turn on at all...

Also, permalink still doesn't turn off

Those are the only two issues I've found thus far...

Dec 29, 2010 09:49

Ethan5150 wrote:

Hmm, now the slider doesn't appear to turn on at all...

Also, permalink still doesn't turn off

Those are the only two issues I've found thus far...

you need to delete and reinstall the skin, since your previous settings have been stored in db, and there are some options added& removoed.

Dec 29, 2010 20:38

Ok, reinstalled. Slider works with no adjustments, but changing to "Fade" and pause time to "1000" creates problems. Also, permalink still doesn't turn off.

Dec 30, 2010 11:49

Ethan5150 wrote:

Ok, reinstalled. Slider works with no adjustments, but changing to "Fade" and pause time to "1000" creates problems. Also, permalink still doesn't turn off.

the permalink icon on the top right wasnt turning off right ?

Both issues are fixed, please download _skin.class.php and _item_block.inc.php from here:

http://b2revolution.svn.sourceforge.net/viewvc/b2revolution/chita/

Dec 30, 2010 21:51

Excellent - works great! Another question; is there a way to utilize the Category Navigation but remove the RSS option?

Dec 30, 2010 23:08

Ethan5150 wrote:

Excellent - works great! Another question; is there a way to utilize the Category Navigation but remove the RSS option?

comment the following line at around 776

Code

//  '<a class="fadeThis" $1href="$2"><span class="entry">$3</span></a><a href="$2?tempskin=_rss2" class="rss_feed"></a>',

You might want to decrease the unnecessary extra padding too(style.css around line 150);

Code

#catnav a {
    display: block;
    padding: 5px 10px;
}

Dec 31, 2010 00:06

Perfect.

I'm confused where the cheetah logo in the upper left is being called from. I've tried replacing logo-semi.png with another image but it doesn't seem to do anything. Can you tell me what file needs to be replaced to change this image?

Another issue I found is that the background patterns aren't all working properly. For instance, the Abstract Blue doesn't appear to work at all, and the Honeycomb works but only as orange - changing colors doesn't work with it.

Dec 31, 2010 02:24

Ethan5150 wrote:

Perfect.

I'm confused where the cheetah logo in the upper left is being called from. I've tried replacing logo-semi.png with another image but it doesn't seem to do anything. Can you tell me what file needs to be replaced to change this image?

Another issue I found is that the background patterns aren't all working properly. For instance, the Abstract Blue doesn't appear to work at all, and the Honeycomb works but only as orange - changing colors doesn't work with it.

the logo comes from an awfully combined sprite image called bgz.png.
Presets are also awfully configured, just ignore them for the time being.

Jan 03, 2011 21:24

I just found a new issue. For some reason, when IE renders the page, it renders at a different width than what Chrome or Firefox render at. http://wccoa.org/index.php/BSAC/ - this page is set be 950px wide but in IE it's rendering slightly less (I know because the slider images are 950 wide). Ideas?

And actually, now that I look more closely - unless I manually set the page to 950px (instead of just selecting it from the dropdown), it renders at more like 948 in Chrome & Firefox (I can see a tiny little overlap of the slider image on the right unless I manually force to 950px).

Jan 03, 2011 23:45

Another question, probably much more difficult: I'm wondering if there's a way to make it so when a user chooses a category or page within a blog, it doesn't restart the slider. As it stands, any time someone clicks a category or page it restarts the slideshow. Any way to fix this?

Jan 04, 2011 02:15

about the width issue; i have to look into that, and i do not have much time these days.

about the slider restarting issue, this is not an issue really; i.e. every time you click a category or a page, you reload a new page, naturally the slide will restart with the newly loaded page, that's the expected behaviour.But if you must, i guess you can use cookies to store the last played slide, and start from there maybe.

Jan 04, 2011 07:59

Ok, well the slider issue isn't really a big deal but the problem with the width is definitely going to cause problems. Should I post in the regular support forum or do you think you'll be able to figure it out relatively quickly? Thanks for all your help - I really appreciate it!

Jan 05, 2011 23:58

One question - will I be able to update with your fixes without losing the work I've done to style.css?

Jan 06, 2011 01:36

Another question - how do I remove the | before the title of each post?

Jan 06, 2011 02:43

Ethan5150 wrote:

One question - will I be able to update with your fixes without losing the work I've done to style.css?

Not likely, so instead of directly editing current proerties; try to make your changes at the very end of your style.css by overriding defaults, or create a new "override.css" and make your changes there, so that you could adapt easily.

Ethan5150 wrote:

Another question - how do I remove the | before the title of each post?

that's a border

Code

.post-title {
    border-left: 5px solid;

Jan 06, 2011 20:54

Sounds good. Does this work for PHP too? To add the changes at the end to override I mean.

Jan 06, 2011 21:53

Ethan5150 wrote:

Sounds good. Does this work for PHP too? To add the changes at the end to override I mean.

unfortunately, no. you will have to note down your changes and apply them back.

This is why i am trying to make it as customizable as possible from the skin settings, as they are being saved in the db and does not require additional modification when you upgrade.

Jan 06, 2011 22:01

Ok, well I think I found all the changes I made and made copies so it should be ok. Thanks!

On a different note - a feature that would be cool for future would be a "copy skin settings" from one blog to another to save the time of setting each setting on every blog.

Jan 07, 2011 00:53

Ethan5150 wrote:

Ok, well I think I found all the changes I made and made copies so it should be ok. Thanks!

On a different note - a feature that would be cool for future would be a "copy skin settings" from one blog to another to save the time of setting each setting on every blog.

That's what i thought..
thanks to sam2kb

[url=http://forums.b2evolution.net/viewtopic.php?t=21895][Plugin] Blog settings duplicator[/url]
B)

Jan 08, 2011 20:25

Hi tilqicom, just wondering if you've had any luck fixing the IE width problem. Seems to me that's really the only deal killer, everything else can be worked around for now.

Jan 13, 2011 21:01

My b2evolution Version: 4

I'm hoping someone can help me - there's a problem with Chita (well, the problem is with IE in my opinion) where the shadowing doesn't work properly and creates a width issue. Here's the site: http://wccoa.org/index.php/Home/ - in Chrome & Firefox it's fine but in IE the width get's messed up and the shadowing gets goofy on the bottom. Can anyone help?

Jan 22, 2011 02:17

I get these messages with cheeta but also with GoodLivingBlogTheme

Warning: Missing argument 2 for load_class(), called in /www/htdocs/w00c8835/english/skins/_toolbar.inc.php on line 45 and defined in /www/htdocs/w00c8835/english/inc/_core/_class5.funcs.php on line 86

Notice: Undefined variable: classname in /www/htdocs/w00c8835/english/inc/_core/_class5.funcs.php on line 89

I found that the same message apeared if not properly upgrading from evo 2.xx to evo 3.xx so it seems skin related.

any help ver much apretiated

Jan 22, 2011 02:56

Ethan5150 wrote:

Hi tilqicom, just wondering if you've had any luck fixing the IE width problem. Seems to me that's really the only deal killer, everything else can be worked around for now.

Fixed.As i suspected, it was my bad.. and it did not even take 5 mins to fix it, sorry it took so long but believe me or not i did not have that extra 5 mins recently.

Grab the complete zip from here:
http://sourceforge.net/projects/b2revolution/files/Chita/0.3/chita0.3.1.zip/download

or just grab the 3 changed files from svn:

http://b2revolution.svn.sourceforge.net/viewvc/b2revolution/chita/

Jan 22, 2011 02:59

MariaEspana wrote:

I get these messages with cheeta but also with GoodLivingBlogTheme

Warning: Missing argument 2 for load_class(), called in /www/htdocs/w00c8835/english/skins/_toolbar.inc.php on line 45 and defined in /www/htdocs/w00c8835/english/inc/_core/_class5.funcs.php on line 86

Notice: Undefined variable: classname in /www/htdocs/w00c8835/english/inc/_core/_class5.funcs.php on line 89

I found that the same message apeared if not properly upgrading from evo 2.xx to evo 3.xx so it seems skin related.

any help ver much apretiated

the fact that error messages point to core files, and it appears in more than 1 skin, it is more likely it is not a skin issue.And just to back it up, i don't think those two skins have much in common.Are you sure you don't get the error with other skins other than these two ? please download the latest zip from above link and upgrade your skin, just to make sure.

Jan 22, 2011 03:07

FYI, the skin was developed to throw a few ideas out there and see where it goes.

But it went somewhere i did not want it to.As i have told earlier, when i started the skin i wanted to have a "lightning fast, almost zero images, seo friendly, plain, straight-forward" template, but it turned out to be more of a customizable template with configurable options.

So right now i am stuck in the middle of "high speed+no js+ no images+no dependancy" concept, and "presets + customization + images + js enhancements" concept.

I have to choose between these two for a v1.0 release that you can use on your production installations.so, let me know if you have any ideas on which side the skin should steer to.

Jan 22, 2011 12:04

I downloaded the newest Cheeta again and the blog works now with cheeta,
just get the error with my customized "goodliving"

Jan 22, 2011 12:38

MariaEspana wrote:

I downloaded the newest Cheeta again and the blog works now with cheeta,
just get the error with my customized "goodliving"

glad it's fixed for my skin.
As far as the other skin goes, it was submitted some time ago, back in the 2.4.x days, and a lot has changed since then.Assuming you are using b2 3.x and above there may be some incompatabilities, you should ask the skin author about it.

Jan 22, 2011 12:42

I looked in the B2forums / manual / wiki and found a article how to upgrade skins from 2.xx to 3.xx but what needs to be done for 4.xx ?

Jan 22, 2011 20:15

My vote is for more complex - there are already a TON of very basic, fast skins for B2. One area Wordpress has b2 beat is in the easy-to-use-but-sophisticated-and-pretty skins arena. This skin takes a serious leap forward for that cause.

Jan 22, 2011 20:37

Ethan5150 wrote:

My vote is for more complex - there are already a TON of very basic, fast skins for B2. One area Wordpress has b2 beat is in the easy-to-use-but-sophisticated-and-pretty skins arena. This skin takes a serious leap forward for that cause.

What i had in mind was "real fast".If you disable all the javascripts and images in the skin you will get insane loading times between 0.3 - 0.6 sec.

I know that many people doesn't care about "half a second", so maybe i should start making it a crowd pleaser.

The markup and the code is kind of not proper right now, i am reviewing the code to make it more semantic, understandable.i have some time in my hand this weekend, so i ll see what i can do to reorganize it and take it to one step further with some additions.

Jan 22, 2011 22:50

to me Cheeta is pretty full of features - more than I need.
Most important is it runs smooth for me.

Changing the graphics to my own ones and changing the colors
seems the only important to me.

Well it is a bit crowded,so maybe a way to leave more space between
the text makes sense....

Jan 22, 2011 23:46

MariaEspana wrote:

Well it is a bit crowded,so maybe a way to leave more space between
the text makes sense....

which text may i ask ?

Jan 23, 2011 00:24

Ethan5150 wrote:

The font size adjustments don't seem to work anymore http://wccoa.org/index.php/Home/ is currently set to Large fonts but as you can see, they're not large...

i see.. i will look into that.
i already have to review the font sizing since;
the template uses YUI grids and yui grids is based on "em"s therefore, you can not easily manipulate body font size as it effects the widths of child elements (inherits the font-size).

I will add 'containers' inside each blocks to get around the issue, but i have to re-evaluate my yui grids choice i guess.

Jan 23, 2011 00:36

Well you're WAY over my head! It's strange that it was working and now it's not though...

Jan 23, 2011 00:51

Ethan5150 wrote:

Well you're WAY over my head! It's strange that it was working and now it's not though...

fixed. please download the modified files from svn, or let me know and i'll zip it for you.

as well as the font size presets, i have added an option to define font size in pixels or percents

Jan 23, 2011 01:05

Excellent! I've made my changes and uploaded the files - can I just do a Refresh Containers to make sure it's properly implemented? Will this reset all my skin settings?

Jan 23, 2011 01:10

Ethan5150 wrote:

Excellent! I've made my changes and uploaded the files - can I just do a Refresh Containers to make sure it's properly implemented? Will this reset all my skin settings?

nope, you dont have to do anything, just upload the modified files.

just be careful overwriting your css file in order not to lose your changes.

like i mentioned earlier; create an override.css and make your changes there so that you can comfortably overwrite the style.css and update your skin later on.

Jan 23, 2011 01:19

Excellent - I just made all my CSS changes at the bottom like you suggested and copied them over to the new file. This really looks excellent! Beautiful work! Very well done indeed. Thanks so much for this!

Apr 08, 2011 04:16

I'm having a strange error: when I click on "Full Story" on a !More post, I get the full story but the title of the article is cut off. See issue here: http://wccoa.org/index.php/Home/news/ - click on the "Full Story" at the bottom then look at the title... Ideas?

Apr 08, 2011 16:57

Code

div.post-head {
    margin-top: 20px;}

you can temporarily get rid of it by adding above, however thats a weird bug, i have to look into it for a permanent fix.

Apr 14, 2011 02:29

Seems ok - got away with 16px but, as I'm sure you're aware, it gaps any single-line title which is kind of a bummer... please let me know if you find a fix - thanks


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.