Recent Topics

Impossible de publier ou sauver un texte [resolu]

started by on May 11, 2012 – Last touched: May 11, 2012

May 11, 2012 22:54    

Bonjour,

Avec b2evolution 4.1.3 installé sur un serveur MySQL 5.1.48 (avec phpMyAdmin - 2.11.9.6), lorsque j'essaie d'écrire un post (sauvegarder, publier, etc.), j'ai ce message:

Forbidden
You do not have permission to access this document.

Web Server at autologique.qc.ca

Le chemin est /blogs/admin.php

Quelle permission dois-je modifier sur mon serveur?

En passant, dans le phpMyAdmin, j'ai ce message: La version de votre bibliothèque MySQL (5.0.90) diffère de la version de votre serveur MySQL (5.1.48). Ceci peut occasionner un comportement imprévisible.

Est-ce que ça serait la cause de mon problème?

Merci!

Polaire

May 12, 2012 17:32

je ne pense pas que cela soit un probleme mysql. Je dirais plutot que ton hebergeur bloque le fichier admin.php

May 12, 2012 17:59

slamp wrote:

je ne pense pas que cela soit un probleme mysql. Je dirais plutot que ton hebergeur bloque le fichier admin.php

Merci... Je vérifie avec l'hébergeur et je redonne des news...

Polaire

May 13, 2012 16:49

slamp wrote:

je ne pense pas que cela soit un probleme mysql. Je dirais plutot que ton hebergeur bloque le fichier admin.php

Mais pourtant, je peux faire plein de modifications sur les blogs à partir du fichier admin.php, mais c'est quand je veux poster que ça ne marche plus...

Comme vous dites, quel genre d'opération commandée par admin.php serait bloquée par l'hébergeur?

Je veux simplement être plus précis lorsque je m'adresserai à l'hébergeur.

Merci

Polaire

May 22, 2012 16:57

polaire wrote:

slamp wrote:

Regarde ce sujet, cela ressemble beaucoup a ton probleme: http://forums.b2evolution.net/viewtopic.php?t=24006

Merci slamp,

Ça va me donner assez de «munitions» pour en parler à mon hébergeur!

Polaire

Bon, j'ai fait désactiver le mod_security, comme c'était mentionné dans le post en question. Ça n'a rien réglé.

Hier, je me suis loggé dans mon blog et j'ai eu le message suivant:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log."

Question: Devrais-je tout désinstaller et installer la dernière version?

Polaire

May 23, 2012 11:54

Question: Devrais-je tout désinstaller et installer la dernière version?

Ca ne donne pas l'impression que cela vient de b2evolution, mais plutot de l'hebergeur.
L'erreur "Internal server error" (code 50x) ne peut pas etre du a b2evolution, mais a la configuration de apache par l'hebergeur.

Tu peux toujours passer a la version 4.1.4 mais je n'y crois pas.

May 24, 2012 22:36

slamp wrote:

Question: Devrais-je tout désinstaller et installer la dernière version?

Ca ne donne pas l'impression que cela vient de b2evolution, mais plutot de l'hebergeur.
L'erreur "Internal server error" (code 50x) ne peut pas etre du a b2evolution, mais a la configuration de apache par l'hebergeur.

Tu peux toujours passer a la version 4.1.4 mais je n'y crois pas.

Après un courriel avec mon hébergeur, le problème de l'erreur interne du serveur est réglé.

Cependant, je ne peux toujours pas écrire quoi que ce soit (brouillon ou texte publié), ça me donne toujours ce message:

Forbidden
You do not have permission to access this document.
Web Server at autologique.qc.ca

On est donc revenu au point de départ...

Selon ce que je pouvais lire dans le post référé, le problème était le module mod_security dans Apache... C'est ce que j'avais dit à mon hébergeur, mais le problème n'était pas réglé.

Merci!

Polaire

May 24, 2012 22:53

Est-ce que peux envoyer des lignes de l'error log en MP?

Merci

Polaire

May 26, 2012 02:10

Voici le message d'erreur tiré du error_log:

[Fri May 25 20:08:34 2012] [error] [client 173.178.28.15] ModSecurity: [file "/etc/httpd/modsecurity.d/10_asl_rules.conf"] [line "680"] [id "340160"] [rev "21"] [msg "Atomicorp.com - FREE/UNSUPPORTED RULES - WAF Rules: Generic SQL Injection protection"] [severity "CRITICAL"] Access denied with code 403 (phase 2). Matched phrase "varchar" at ARGS_NAMES:item_varchar1. [hostname "www.autologique.qc.ca"] [uri "/blogs/admin.php"] [unique_id "SSb9dX8AAAEAADBJkgMAAAAe"]

Merci!

Polaire

May 31, 2012 08:53

Cela confirme que ce n'est pas un probleme de b2evolution mais de l'hebergeur:
apache tourne avec mod_security et celui-ci interdit l'acces a admin.php

A part changer d'hebergeur, je ne vois pas de solution.

May 31, 2012 16:22

slamp wrote:

Cela confirme que ce n'est pas un probleme de b2evolution mais de l'hebergeur:
apache tourne avec mod_security et celui-ci interdit l'acces a admin.php

A part changer d'hebergeur, je ne vois pas de solution.

Il a fallu que je m'impatiente un petit peu et que j'envoie une ligne du error log à l'hébergeur.

C'est finalement réglé depuis hier... Je peux publier des textes. Merci pour votre temps!

Polaire


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.