Recent Topics

Can not access b2evolution from outside of the server

Thread started by , Thu Jun 30, 2005 08:13 – Last touched: Thu Jun 30, 2005 08:13
Started by , 06/30/05

Jun 30, 2005 08:13    

Hi, I am a first time user of b2evolution.
I have managed to installed the latest version of b2evolution on a fresh installed Fedora Core 4(full installation).

Everything looks fine if I try to access my blog from the localhost. But if I try to access it from another machine, I see a broken page. Most of the links does not work since they contain the /localhost/ in the url.

Please try the following web to see yourself:

Please someone help me figure out what is wrong.


Comment from:

Yeah, you installed it while viewing it on localhost. It auto-detected the URL, and now b2evo thinks that its home is http://localhost/blogs.

Drop all the tables, and then go to (the public address) and install from that address, and it'll be fine.

Alternately, you could open up the /conf/ folder instead, and edit the files in there to make sure that they point at the right URL.

Remember to delete the install folder when you're done!

06/30/05 @ 16:02

Comment from:

Thanks for your reply.
I will give it a try.

One more question about the DB settings. When I install the b2e, I need to type the mySQL settings. One of the settings is the DB host. If I input 'localhost', I could continue to the next step. However, if I input a domain name such as, it will not connect to the db correctly. What is your suggestion on this?


06/30/05 @ 19:08

Comment from:

the address of the db is still localhost, as the DB is held locally on your machine the same as the one hosting the webserver.

06/30/05 @ 19:30

Comment from:

Yeah, the DB host answers the question:
What does the webserver call the database server?

In this case, the webserver calls the database server "localhost", because they're the same thing. In some cases, however, your website may be hosted on one machine, and the database might sit over on some other machine, so you'd need to enter something different in there.

When you install, the program sniffs the address that you're accessing, and says, "This is my public address. Links on pages go here." In that situation, you don't want "localhost", you want your actual address.

06/30/05 @ 21:12
multiblog engine – This forum is powered by b2evolution CMS, a complete engine for your website.