Recent Topics

spell checking is deader than dead

Started by on Dec 05, 2005 – Contents updated: Dec 05, 2005

Dec 05, 2005 23:43    

Hi. I'm pretty sure the spell checker died a long time ago, but I gave it a shot in the alpha release and it's gotten worse. Now when I click the spell checker link it does not launch a spell checking window that doesn't work: it just sits there and does nothing.

Not quite nothing... I use Firefox with the developers toolbar (because it makes me think I'm a developer!) and I get a little icon on the right that goes from a "i" in a bubble to an "!" in a red stop sign. The error message that leads to says "DoSpell is not defined".

Dec 14, 2005 03:21

One question: isn't is possible to steal the interface from gmail for b2evolution? I mean the WYSIWYG Editor. It rulz!

Dec 15, 2005 15:21

-MarcDK
What you could do is just type your blog in gmail, then send it to b2evo via a email to post it.
That way u get ur spellchecker and it posted on ur blog.

But to take it directly from gmail is a no no.

Apr 13, 2006 22:08

I'm just finishing up a plugin for b2evolution 1.8 that uses the Google Spell Check API. It's works about like Gmail. My plugin is not a wysiwyg editior (someone else is working on that), but it does do spell checking pretty well in 8 languages: Dansk, Deutsch, English, Español, Français, Italiano, Nederlands, Polski, Português, Suomi and Svenska.

Oh, and it adds a spell checker to comment forms, too.

If you're running a recent CVS copy I can zip it up and let you try it.

Nov 16, 2006 20:06

I have tried to use the spell checker and all I get is the following error:

Error Encountered:
Undefined

And nothing happens, just a spinning action next to the ABC next to spell check.

I installed the plugin just as indicated, but that is all I get.

Nov 16, 2006 20:11

Hmm, I'm not sure what's causing that. Now that Firefox as of version 2 has spell checking built in to every text field, we're not making this plugin a high priority. I recommend that you use Firefox.

Nov 16, 2006 20:16

I just opened firefox and I don't have the problem with that browser.

I am getting the error in IE7.

Thanks for your reply.


Form is loading...

multi-blog – This forum is powered by b2evolution CMS, a complete engine for your website.