Recent Topics

whois in Analytics is not working

Started by on Oct 19, 2018 – Contents updated: Oct 30, 2018

Oct 19, 2018 14:05    

Hello,

in 6.10.3 there is a new feature in Analytics, which should allow to look for an IP in Whois. But this feature does not really work for me and I found no information towards this feature in the manuals or demo-sites.
Is it necessary to load an additional plugin (I did not find one), or …

Here are some screenshots:

Exact b2evolution version number :6.10.3

Oct 21, 2018 00:01

I guess the whois port is blocked on your server.

You should see it working on the demo server.

Oct 22, 2018 13:36

@fplanque thx. My hoster had blocked this domain. Should have checked this before opening this thread. Sry.

Oct 25, 2018 09:37

@fplanque
We set the following domains on the whitelist:
arin.net
whois.arin.net
maxmind.com
whois.com
whois.net
geolite.maxmind.com
whois.nic.uk
whois-check.ausregistry.net.au
whois.ripe.net
whois.isoc.org.il
nominet.org.uk
whois.nic.uk
whois.apnic.net
whois.tucows.com

But the whois lookup does not work.
Does the whois lookup other ports than Port 80 oder 443?

Could you please tell me, what domains are involved for that lookup by &action=whois ?

(BTW: Markdown did not work for this post, so I could not use codespan)

Oct 30, 2018 22:30

It depends on the TLD. There are dozens of domains.

It is a 3rd party library. Look into /inc/_ext/phpwhois/.


Form is loading...

powered by b2evolution – This forum is powered by b2evolution CMS, a complete engine for your website.