Recent Topics

Big problem with upgrading!

Started by on Aug 05, 2015 – Contents updated: Aug 17, 2015

Aug 05, 2015 15:57    

[UPDATE: While I'm now having other issues, I solved this by going into the /conf directory and renaming umaintenance.html to _umaintenance.html. Rather than delete this note, I'll leave it in case it helps someone in the future. But for the wizards out there, I'd sure appreciate it if you could check out my reply below with the current problem I'm having...skin related.]

Hello all,

I tried the automated upgrade (from 5.2 to 6.6.1) and it failed. I think it was a memory error but I can't get back to the page.

Now I uploaded all the files from the new install to my server but get a 503 error when calling the script:

503 Service Unavailable

System upgrade is in progress. Please reload this page in a few minutes.

Site administrators: please view the source of this page for details.

And when I try to go to my backoffice page, I get this:

Database schema is not up to date!

The b2evolution files are present on your server, but it seems the database is not yet set up as expected.

For more information, please visit our Getting Stated / Installation Guide.

This is b2evolution version 6.6.1-stable.

You cannot use the application before you finish configuration and installation.

Database schema is not up to date!

You have schema version «11285», but we would need «11480».

Any help much appreciated!!!

Aug 05, 2015 16:20

UPDATE: I put on debug mode...if you look at http://rossputin.com the errors are there for all to see. It's so far beyond my abilities to find and fix this problem...could really use some help!

OK, now I have a very different problem:
I get this when loading main blog page:
Deprecated: Assigning the return value of new by reference is deprecated in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php on line 645 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 341 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 40 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 279 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 280 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 281 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 282

An unexpected error has occurred!

If this error persists, please report it to the administrator.

Go back to home page
Additional information about this error:
wrong $params

I get this when I go to skin page in back office:
Deprecated: Assigning the return value of new by reference is deprecated in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php on line 645 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 40 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 279 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 280 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 281 Warning: Cannot modify header information - headers already sent by (output started at /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/skins/mystique/_skin.class.php:645) in /hermes/waloraweb097/b513/pow.rosspcom/htdocs/blog/inc/_core/_template.funcs.php on line 282

Aug 05, 2015 17:16

It seems the mystique skin is not compatible with b2evo 6. We'll fix it. Until then, please use a different skin.

Aug 06, 2015 17:22

I'll download the update. Can you please tell me what I need to do to make sure that after the update is installed it has any customizations I've made (which I don't remember because it was so long ago)?

Aug 07, 2015 11:19

Well, if you customized your skin at code level and you don't remember what you did, then you should compare the entire Mystique folders (old vs new). For example, using Beyond Compare (http://www.scootersoftware.com/) you can find all the differences between both folders. This can give you an idea about what you need to change in order to restore your customizations.

Aug 15, 2015 13:58

Is there any way you can tell me what was modified in the update to Mystique to make it compatible with the current b2evolution?

Aug 17, 2015 00:04

@rosscode yes of course. If you're familiarized with GitHub, you will find all changes done in these commits: https://github.com/b2evolution/mystique_skin/commit/5b3242b7bd94f5d577bc4abb46640ae1a3b037c3 and https://github.com/b2evolution/mystique_skin/commit/ad26e6890847ddc1ed5fde304183d0858ffb3759

If not, this is a quick update: Red means deleted things (characters, lines of code or files) and green means added things. That's it, just check the name of the file at the beginning of each block and see the change applied to it.


Form is loading...

multiple blogs – This forum is powered by b2evolution CMS, a complete engine for your website.