Recent Topics

[2.4X] GoDaddy Customer Read Before Upgrading

Started by on Mar 24, 2008 – Contents updated: Mar 24, 2008

Mar 24, 2008 12:41    

My b2evolution Version: 2.4.X

If you are a GoDaddy customer, v2.4.X has issues with the stock GoDaddy configuration. So to make it work, you need to:

1). Create a php.ini (or php5.ini if your account is setup with PHP5) with the following in it:
cgi.fix_pathinfo = 1
[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimiz er-3.3.3
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Opti mizer_TS-3.3.3
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_T S.so[/code]
See http://forums.b2evolution.net/viewtopic.php?t=14612 for complete explanation

Thanks to Sathed for figuring this out.

2). Now edit your /admin.php file
Around line 180, look for:
if( ! empty( $_SERVER['PATH_INFO'] ) && $_SERVER['PATH_INFO'] != $_SERVER['PHP_SELF'] ) // the "!= PHP_SELF" check seems needed by IIS..

And change to:
if( ! empty( $_SERVER['PATH_INFO'] ) && str_replace( $_SERVER['PATH_INFO'], '', $_SERVER['PHP_SELF'] ) != '' ) // the "!= PHP_SELF" check seems needed by IIS..

Thanks to Yabba for figuring this piece of the puzzle out!

Cheers,

RocketDude

Mar 24, 2008 18:13

Afwas,

thanks for finding that link.

Adding the cgi.fix_pathinfo = 1 does solve the problem for posts, but it unfortunately kills the ability to log into the admin part of the site.

The admin links look like this:

http://www.stylefool.com/admin.php?ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&blog=2

And give the following error in FireFox:
"The page isn't redirecting correctly properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

Mar 25, 2008 07:09

Try changing this section of code inc/_core/_template.func.php approx 80

from this :

PHP

/* fp>why do we need this?
       dh>because Location: redirects are supposed to be absolute.
    if( substr($redirect_to, 0, 1) == '/' )
    { // relative URL, prepend current host:
        global $ReqHost;
 
        $redirect_to = $ReqHost.$redirect_to;
    }
    */

to this :

PHP

/* fp>why do we need this?
       dh>because Location: redirects are supposed to be absolute.
    */
    if( substr($redirect_to01) == '/' )
    { // relative URL, prepend current host:
        global $ReqHost;
 
        $redirect_to $ReqHost.$redirect_to;
    }

¥

Mar 25, 2008 07:52

Try changing this section of code inc/_core/_template.func.php approx 80

Doesn't work for me. Still can't login in admin.

Mar 25, 2008 07:53

Do you fancy pm'ing me an ftp + evo login?

¥

Mar 25, 2008 08:32

Ok, go have a play around your demo blog and see if anything's broken ( I re-enabled your fix in php.ini so the chances are your main blog admin is broken at the moment )

¥

Mar 25, 2008 08:47

Ok, I'm not gonna pretend I understand this but this is what happens :

fixing your clean urls by adding the following to php5.ini

Code

cgi.fix_pathinfo = 1

Cause $_SERVER['PHP_SELF'] to "double up" the path ( /foo/bar/admin.php becomes foo/bar/admin.php/foo/bar/admin.php ), which causes the core to redirect .... infinitely

You can "fix" it by changing this section of code in /admin.php approx line 178

PHP

// Redirect old-style URLs (e.g. /admin/plugins.php), if they come here because the webserver maps "/admin/" to "/admin.php"
// NOTE: this is just meant as a transformation from pre-1.8 to 1.8!
if( ! empty( $_SERVER['PATH_INFO'] ) && ( is_windows() && $_SERVER['PATH_INFO'] != $_SERVER['PHP_SELF'] ) ) // the "!= PHP_SELF" check seems needed by IIS..
{

v

*edit*
Slightly better fix :

PHP

if( ! empty( $_SERVER['PATH_INFO'] ) && str_replace$_SERVER['PATH_INFO'], ''$_SERVER['PHP_SELF'] ) != '' // the "!= PHP_SELF" check seems needed by IIS..
{

Mar 25, 2008 09:12

Great, I've just fixed 1.10.3 system.

Thanks

Mar 27, 2008 02:15

you guys rocked. I fixed my site too.

For the record.

Edit admin.php -- around like 180....

if( ! empty( $_SERVER['PATH_INFO'] ) && str_replace( $_SERVER['PATH_INFO'], '', $_SERVER['PHP_SELF'] ) != '' ) // the "!= PHP_SELF" check seems needed by IIS..

create/edit php5.ini (blank ) with the following:
cgi.fix_pathinfo = 1

That's it!

GoDaddy should give you free hosting for figuring this one out!

I just upgraded to the latest version and forgot about this php hack. I got this error:
admin.php?ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&ctrl=dashboard&blog=1

So I fixed it by following this solution above Line 180 or so...

Mar 31, 2008 01:37

esanchez wrote:

you guys rocked. I fixed my site too.

For the record.

Edit admin.php -- around like 180....

if( ! empty( $_SERVER['PATH_INFO'] ) && str_replace( $_SERVER['PATH_INFO'], '', $_SERVER['PHP_SELF'] ) != '' ) // the "!= PHP_SELF" check seems needed by IIS..

create/edit php5.ini (blank ) with the following:
cgi.fix_pathinfo = 1

That's it!

GoDaddy should give you free hosting for figuring this one out!

OK, so where exactly does the php5.ini file go, file name, location on server or where ever?

Mar 31, 2008 01:47

OK, so where exactly does the php5.ini file go, file name, location on server or where ever?

In root directory.

Mar 31, 2008 05:05

sam2kb,

it goes on the root of your website. login via ftp and then place it there.

Jun 18, 2008 22:38

Is this necessary to do on a NEW Install 2.4.2 on godaddy servers. And is this to fix the error of No page when you click on links / blog titles.

I got them fixed by selecting param. But if this is the real fix for that please let me know or I mis-read this.

Edit admin.php -- around like 180....

if( ! empty( $_SERVER['PATH_INFO'] ) && str_replace( $_SERVER['PATH_INFO'], '', $_SERVER['PHP_SELF'] ) != '' ) // the "!= PHP_SELF" check seems needed by IIS..

create/edit php5.ini (blank ) with the following:
cgi.fix_pathinfo = 1

And this is all we do? correct...
.. if we are to do it on a NEW (fresh) load of 2.4.2

I got my links as i stated working by ticking "Use param: post ID" but calendar still has "no page to display" and same with B log,

And I still get this:
PHP allow_url_fopen ON warning
and
PHP Magic Quotes On (magic_quotes_gpc)
and
post_max_size should be larger than upload_max_filesize

I read all the post on these matters and followed the dirctions but no go. adding the comment(s) in the php.ini to OFF.

Thanks,

Jun 19, 2008 03:58

What version of PHP are you running?

There's a bit about editing the INI file php.ini - did you also edit that file?

Jun 19, 2008 04:37

PHP 5.0

Yes i added the:
But does nothing and I have original backup
allow_url_fopen = Off
magic_quotes_gpc = Off

Jun 19, 2008 05:12

Make sure you have a php5.ini on the root of your web site. YOu may also have a php.ini but that one is not for php 5.

there should only be one line inside your php5.ini. The line is:

cgi.fix_pathinfo = 1

That's it. That's all I have inside my php5.ini. Good luck mate.

Jun 19, 2008 07:42

Thank you! :) i will make it and upload it to the root.

oh, should i take out the

allow_url_fopen = Off
magic_quotes_gpc = Off

in the normal php.ini that was already in the linux server files, i mean take out the lines i added,

allow_url_fopen = Off <---was already there
magic_quotes_gpc = Off <----- I added

and sorry for lacking knowledge on this but what is the php5.ini suppose to do anyway?

Ok uploaded and the calendar hyperlink works now. Is there other items that i am missing, as in what will funtion in the right manner now?

Also...
I had to (originally change the Use param) to get the links to work.

Oh frack, now my admin (dashboard does not show) Internet Explorer cannot display the webpage. I may have to take out the php5.ini to log in as admin, Yup when i remove the php5.ini i can login as admin again.

What where the original blog settings>url's set to, maybe if I set them back then add the php5.ini?


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.