Recent Topics

Translate b2evolution to my own language

Started by on Apr 23, 2010 – Contents updated: Apr 23, 2010

Apr 23, 2010 17:37    

My b2evolution Version: 3.3.3
Please help me to use my Vietnamese language in my blog:

I already did everything such as instructions in How to localize b2evo to your own language (b2evo manual) but nothing works i.e. visitors can't type comment in Vietnamese language .

Here are what I got :

http://4friendsonline.net/images/local_question1.jpg http://4friendsonline.net/images/local_question2.jpg http://4friendsonline.net/images/local_question3.jpg

I also make the following changes in file: /conf/_locales.php as following:

<?php

if( !defined('EVO_CONFIG_LOADED') ) die( 'Please, do not access this page directly.' );

$use_l10n = 1;

$evo_charset = '';

$force_io_charset_if_accepted = '';

$db_config['connection_charset'] = '';

$default_locale = 'vi-VN';

require_once $inc_path.'locales/_locale.funcs.php';

$locales['en-US'] = array(
'name' => NT_('English (US) latin1'),
'charset' => 'iso-8859-1',
'datefmt' => 'm/d/y',
'timefmt' => 'h:i:s a',
'startofweek' => 0,
'messages' => 'en_US',
'enabled' => false, // We need this line to prevent notices iin locales conf screen and user profile screen.
);

$locales['vi-VN'] = array(
'name' => NT_('Vietnamese (VN)'),
'charset' => 'utf-8',
'datefmt' => 'm/d/y',
'timefmt' => 'h:i:s a',
'startofweek' => 0,
'messages' => 'vi_VN',
'enabled' => false, // We need this line to prevent notices iin locales conf screen and user profile screen.

);

$allow_po_extraction = 1;

?>

What else I've to do ?

I hope I don't write too long and I'm really sorry if I bother the other members . Many thanks!

Have a nice week end to all.

Apr 23, 2010 22:13

I also make the following changes in file: /conf/_locales.php

You don't need to edit _locales.php

Make sure new locale is enabled in Global settings > Regional

Apr 23, 2010 22:20

sam2kb wrote:

Make sure new locale is enabled in Global settings > Regional

Yes, the new local (vi_VN) is already in it but all messages in my blog still in English .

Thank a lot for your advise!

abcd

Apr 23, 2010 23:04

sam2kb wrote:

You need to install b2evo with utf-8 support or convert the existing database to utf-8.

Use this script to convert the existing database http://launchpadlibrarian.net/32379853/convert_db.php
Edit this line to match your config require dirname(__FILE__).'/blogs/conf/_config.php';

Hi sam2kb,

I did as your advise and everything is converted successfully but my blog is always the same . Do you have another way ? Many thanks !

Apr 24, 2010 00:01

just pm me your admin credentials and let me see what you are missing

Apr 24, 2010 02:17

tilqicom wrote:

just pm me your admin credentials and let me see what you are missing

Please check your pm ! Thanks!

Apr 24, 2010 14:22

http://i41.tinypic.com/2vnnzw8.jpg

you got no language file there..

possible reason:

you have double extracted, you should have your _global.php under

.../locales/vi-VN/global.php

and
NOT under:

.../locales/vi-VN/vi-VN/global.php

or summat.

I guess you can handle this, if you can not, i will need an ftp account to fix it for you.

Apr 24, 2010 16:08

tilqicom wrote:


you have double extracted, you should have your _global.php under

.../locales/vi-VN/global.php

and
NOT under:

.../locales/vi-VN/vi-VN/global.php

or summat.

I've verified and I've always had my _global.php under

.../locales/vi-VN/global.php

Please check pm . Thanks !

abcd

Apr 24, 2010 17:36

just a little hypen-underscore catch there;

you typed subdirectory vi-VN where your file was under vi_VN

now it is fixed. (or broken for me P: i dont understand a thing there, hope you dont need anything else P:)

Apr 24, 2010 18:00

tilqicom wrote:

just a little hypen-underscore catch there;

you typed subdirectory vi-VN where your file was under vi_VN

now it is fixed. (or broken for me P: i dont understand a thing there, hope you dont need anything else P:)

Very fantastic, tilqicom! ! It's Ok now . But... I have a lot of things :( needing your help later in another topic.

Thank a lot.


Form is loading...

Run your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.