Recent Topics

[IN PROGRESS] [5.1.2] German Umlauts (deutsche Umlaute) in Tags

Started by on Nov 02, 2014 – Contents updated: Feb 14, 2015

Nov 02, 2014 00:57    

"The same procedure as last year, Miss Sophie?"
"The same procedure as every year, James!"

Hi,
german umlauts are the chars ä, ö, ü, Ä, Ö, Ü. Versions before, there were Problems with it. Now I have changed the DB to UTF-8 as it was offered in the installer.

And if I now uses the umlauts, there very interesting things happens.

Example: http://ednong.de/blogs/index.php/pkw-maut-kostet-nur-337-mio

If I put the tag "Milchmädchenrechnung" in it, it seems ok in the backend. And it will be visible in the frontend. And now - I edit the post. In the backend now there will be a tag "null" instead of "milchmädchenrechnung". And after the saving, in the frontend there will be nothing of this tag. No "milchmädenrechnung", no "null".

Sometimes, if I have more than 1 word/tag with umlauts, the second will not be discovered and don't change to the "tag button". It needs some times more than one edit sessions to get all words with umlauts into tags. Terrible. Like here - at the end in the tag line it don't find "milchmädchenrechnung" and don't change it into the tag button/visible tag. Searching for ever.

What is wrong with this no ASCII chars? What is wrong with b2evolution?

Nov 03, 2014 00:11

We'll check this.

It should be working. I am personally using specials chars in French tags.

One thing you should do (sooner or later anyways) is that the de-DE locale you use is iN UTF-8 also.

Nov 03, 2014 02:50

Hi fplanque,

the language pack is the latest de-de from b2evo-site. I guess, it is in UTF-8?

A second problem: sometimes I don't get "tag buttons", although there are words in the tag line under the new post. Is it possible to code this in a kind to take this tags over into the DB without searching and changing into the tag buttons? I guess, this is an AJAX request?

Nov 03, 2014 08:29

Hi @ednong,

Tags links are loaded from the database before the content of the page is presented, so they are not ajax loaded. Or at least, not in the evoPress skin that you're currently using.

Sometimes, if I have more than 1 word/tag with umlauts, the second will not be discovered and don't change to the "tag button". It needs some times more than one edit sessions to get all words with umlauts into tags. Terrible. Like here - at the end in the tag line it don't find "milchmädchenrechnung" and don't change it into the tag button/visible tag. Searching for ever.

Could you please send a link of this?

Thanks.

Nov 03, 2014 19:04

Hi mgsolipa,
I couldn't send a link about this - it happens in the backend. The box of the tags will included my typed words, but this is red framed (has a red border) and there are not any buttons.

If I click "save/publish", the post will be on the blog site but without any tags.

Nov 03, 2014 20:44

All right @ednong, I misunderstood your problem before. I am still not able to reproduce it, but the red border could be a hint.

Can you please inform us about your OS and browser? Are they also in German?

Thanks.

Nov 03, 2014 21:14

Why is the country necessary? Firefox in its last version and Kubuntu 14.04 are the details you asked for.

If I got it again, I will do a screenshot.

Nov 03, 2014 21:36

Why is the country necessary?

Actually, I was asking for the default language of your SO and browser. Just to investigate possible issues of the javascript library in environments like yours.

Nov 03, 2014 21:52

Ok - the default language is german. In b2evo I have installed the actual german language pack.

And now - there are 2 Screenshots.
The first one will be the creating time of the post. You can see the red border. I don't get a tag button for "DR" - in front of "DR" there are 2 tag buttons in the tag line.

The second screenshot will show the situation after saving (without DR) and clicking on "edit". Now I am in the edit mode of the post - and have 2 "null" tag buttons (where the german umlauts were before).

Nov 04, 2014 14:30

It looks like maybe there is an Ajax failure because maybe the server is overloaded and dropped a request or sth like that...

Nov 04, 2014 17:02

Yea, that was the thing I thought. So would it possible to take the tag over without the "tag button"? This kind of failure will be much times and its a little bit expensive to do it more than once to get all tags into the tag line.

And with the "null" tag (like milchmädchenrechnung): it will happen every time I have an umlaut in it. Really every time, if I edit the post. I guess, this is not only a server-not-reachable-error.

And as I said: the DB is converted/upgraded to UTF-8 with the installer after upgrading to 5.1.2.

Nov 10, 2014 18:18

I have now tried the "Umlaut" in the demo. I created a new post and as tag I used "Stöckchen" (in Blog B).
This was visible after saving.
Then I clicked on "Edit" in the post.
In the Backend there was only a tag button with "st" - no more (no "null" tag button).

It seems, there is an error with the tags and umlauts.
Maybe it is the web-/html-side, which is in 8859-1?

Nov 17, 2014 15:50

Hi mgsolipa,

where I can find a version of the language pack?

I have downloaded this from here
http://locales.b2evolution.net/de_de_locale#more359233
after the release of the b2evo version 5.1.2.

I guess, its the newest now. But I don't know, if this is in UTF-8. Any chance to see this information in the backend of b2evo?

Jan 24, 2015 14:47

Now in the newest version 5.2.1 of b2evo:

I want to put an "ä" in the tag word, and this will happen. Seems unsolved. The database is changed since 5.1.2 to UTF-8.

Jan 28, 2015 22:01

Oh! We'll start this all over again :(

It looks like your locale is encoded as iso-8859-1 (again). Please go to "System > Regional settings > Locales" and verify that the de-DE locale is set to utf-8 (column Charset).

Jan 28, 2015 22:52

Yes,
it is encoded as 8859-1. Can I overwrite this with "utf-8" - or do I need an other language pack for this?

Jan 28, 2015 22:58

All right, that's the problem. Let's do it this way:

1) Download the language pack from here: http://locales.b2evolution.net/de_de_locale
2) Upload the content of the package to your site (replacing the whole content of the locales/de_DE folder)
3) Go to "System > Regional settings > Locales". If your locale is still iso-8859-1 (should be), just change it to utf-8 by typing it in the field and Save changes.

Please, let us know how it is going.

Regards!

Jan 28, 2015 23:29

Okay,
now I have created a new one. I gave it a different prio, but it seems that this new one deleted the old one with 8859-1. This is strange.

But now, it works. The umlauts works as it should be.

So - why the default for this locale is 8859-1? It should be 8859-15 or better utf-8 I think.

Thanks for your help &#59;)

Jan 29, 2015 01:46

Correction:
It doesn't works correct. Now the "old" tags with umlauts are not correct. I thought, this will converted if I updated the DB to UTF-8. Now it seems this updater works correct.
*sigh*


Form is loading...

blog soft – This forum is powered by b2evolution CMS, a complete engine for your website.