Recent Topics

1 Jan 15, 2015 08:20    

I am running in to a problem when I go to the Post To Email tab. I have set all the parameters correctly. When I select save settings button at the bottom of the page it returns this error

Bad Request!

The parameters of your request are invalid.

If you have obtained this error by clicking on a link INSIDE of this site, please report the bad link to the administrator.

I have tried editing the _generalsettings.class.php

located at


with these settings

// Post by Email
'eblog_enabled' => 1,
'eblog_method' => 'pop3',
'eblog_encrypt' => 'none',
'eblog_server_port' => 110,
'eblog_default_category' => 1,
'eblog_add_imgtag' => 0,
'eblog_body_terminator' => '___',
'eblog_subject_prefix' => 'blog:',
'eblog_html_tag_limit' => 1,
'eblog_delete_emails' => 1,
'eblog_renderers' => array('default'),

// Returned Emails
'repath_enabled' => 1,
'repath_method' => 'pop3',
'repath_encrypt' => 'none',
'repath_server_port' => 110,
'repath_subject' => 'Returned mail:

as my email is a pop3 that uses port 110. I get the same error.

When I test the email server there are no errors. I can receive a test email back. However the form will not save the settings and keep returning the error above.

I am using 5.20 B2Evolution

I have used B2Evolution for years. I have never had any problems with the Post by Email function

The mail server works fine. I have the general setting configured for the email server and it works fine in B2Evolution.

Do I have to mod permissions on a file to get this to work?

I am using GoDaddy Premium hosting. I have no security issues and all the security suggestions are GREEN with no errors.

Any help would be greatly appreciated.

Thank you

4 Jan 15, 2015 08:52

I fixed the code as your link described. however the error continues. Here are some screen shots

5 Jan 15, 2015 08:58

When I send a test post I get this error

Connecting and authenticating to mail server :110
Connection failed: Can't open mailbox {:110/notls/pop3}INBOX: invalid remote specification

When I go to the email tab and do basically the same test I get this

Connecting and authenticating to mail server
Successfully connected!

I send a test email from the email tab and get this

Connecting and authenticating to mail server
Successfully connected!
Reading messages from server
Found 2 messages
Processing message #1:

MIME message decoding successful
Subject: Microsoft Office Outlook Test Message
Subject prefix is not "Returned mail:", "Mail delivery failed:", "Undelivered Mail Returned to Sender", "Delivery Status Notification (Failure)", "delayed 24 hours", "delayed 48 hours", "delayed 72 hours", "failure notice", "Undeliverable:", skip this email

6 Jan 15, 2015 20:55

@jamesblackcse ok, let's do this step by step. Did you rollback the changes introduced in the code/database and mentioned in your first post? After the fix that I linked in my previous comment, is the settings form working properly again?

I'm testing (GMail - POP3) and it works as supposed. Can you use a different email account to make your test? In theory, if the settings of Remote publising and Email > Settings are the same, and one of the features works properly, then the other should does it as well.

Besides the port number (which is irrelevant), I can see only one difference between your description and my tests, your provider does not use encryption and GMail does, so I'll try to reproduce the same scenario. In the meantime, what version of PHP are you running?

7 Jan 22, 2015 12:59

Native is 5.4
I have the option to switch to 5.3 or 5.5

After a few days the feature works on the blog? I had flushed all the cachepreviously but the error was still there is all three browsers. Chrome, Firefox and IE.

I have another blog I am working on. The same error has occurred. I am applying the fix and then flushing the cashe. Waiting to see if the error goes away.

I will keep you up to date.

Thank you for the help.

Form is loading...