Recent Topics

Comment form will not load

started by on Mar 21, 2017 – Last touched: Mar 25, 2017

Mar 21, 2017 12:24    

Hello

For some reason the comment form will not load. The little icon goes round and round but the form itself never appears.

I tried following the advice in the post at http://forums.b2evolution.net/topic-25158 which suggests unchecking Enable page cache in Blog Settings > Advanced, or disabling the ajax form -- and I've done both -- but this hasn't made any difference.

I also tried this advice here http://web-notes.wirehopper.com/2012/06/17/b2evolution-comment-forms-stalling-version

which suggests uncommenting a couple of lines in conf/_basic_config

	// Use the following if you want to use the current domain:
	if( isset($_SERVER['HTTP_HOST']) )
	{       // This only works if HOSt provided by webserver (i-e DOES NOT WORK IN PHP CLI MODE)
	        $baseurl = ( (isset($_SERVER['HTTPS']) && ( $_SERVER['HTTPS'] != 'off' ) ) ?'https://':'http://')
	                                                        .$_SERVER['HTTP_HOST'].'/';
	}

but that hasn't worked either.

Does anyone know what might be the problem?

Mar 21, 2017 22:45

Also, I have cleared all full page caches, and comment and feedback viewing option is set to any user.

Running out of ideas now! Any help would be much appreciated!

(It';s not a local machine issue -- my friend is having the same problem as me on Chrome in New York as I am having here on Firefox in Glasgow).

Mar 21, 2017 22:57

@loobyloo_2 what skin are you using?

It would be useful to know the output of your browser's console to see if there is a Javascript error avoiding the form to be displayed correctly. If you don't know how to find that console, and as you are using Firefox, these instructions may help you: https://developer.mozilla.org/en/docs/Tools/Browser_Console. Please send us screenshots of what you find.

Mar 23, 2017 13:01

(Er...not sure if this thread is moderated or not but I did post my browser console results a couple of hours ago)

I decided simply to reinstall and upgrade from 6.8.7 to 6.8.8. Fixes most things! :)

Mar 23, 2017 13:46

Well @loobyloo_2, there are no more comments, so I guess your screenshots didn't upload correctly.

Is the issue already solved after updating your site?

Mar 23, 2017 15:47

Yes thank you, it works now. I would have liked to have found out what I had done to the old installation to make it not work, but there was afternoon drinking to be done which was more important :) Thanks for your replies mgsolipa.


Form is loading...

powered by b2evolution free blog software – This forum is powered by b2evolution CMS, a complete engine for your website.