Recent Topics

From 6.7.7 to 6.8.2 on mariaDB

Started by on Dec 08, 2016 – Contents updated: Dec 18, 2016

Dec 08, 2016 10:10    

Hello,

I have tried to upgrade my b2evo installation from 6.7.7 to 6.8.2. My server runs MariaDB and I have seen a bug during database upgrade.

I have a sql dump, but it's unusable (as my backup script ran during upgrade !) and I have found that backup created by upgrade process is uncomplete (all data after january 2013 were not in dump !). I have checked all backups created by b2evolution, all are unusable as some data were not saved.

When upgrade process has crashed I have done a backup of the faulty database. Thus, I have now a backup of the database when upgrade process was halted by following error :

http://forums.b2evolution.net/media/users/drherz/comments/p361561/clean_install_error.png?mtime=1479983715

How can I complete upgrade process by hand ? Is there anywhere a sql script to finish process ?

Best regards,

JKB

Dec 09, 2016 10:28

Ok, problem solved. I have upgraded database schemas by hand.

But I think b2evolution should use a mechanism like COMMIT/ROLLBACK to keep its database usable even if upgrade hangs.

Please note also that db.zip doesn't contain all data.

Best regards,

JKB

Dec 12, 2016 02:24

Can you please tell us what data it is you are missing in the automated backups?

Thank you.

Dec 12, 2016 08:36

All data after 2013... I suppose that backups are size limited.

Dec 12, 2016 19:00

No, that doesn't make any sense. Data is not saved by date in the backups. It is saved table by table. So I would understand missing tables but not tables truncated at 2013.

Is it possible that you are looking at a backup file that fates back to 2013? (maybe file permissions have prevented saving any new file since then?)

Dec 12, 2016 19:50

All files have the same permissions www-data:www-data 644. I don't understand your question as b2evolution can access to database and can write in backup directory. Thus, all data should be in sql dump...

Dec 18, 2016 15:12

I have a similar problem. How did you upgrade the schemas by hand?
The DB upgrade process isn't very failure tollerable. If the table already exists it stops completly instead of continuing. Gives me a headache for days ! :(

Update: I see, there is already my exact problem in the forum "Broke my database: Where is my Content?" http://forums.b2evolution.net/broke-my-database-where-is-my-content


Form is loading...

blogtool – This forum is powered by b2evolution CMS, a complete engine for your website.