Recent Topics

znaki voprosov

Started by on Jun 11, 2008 – Contents updated: Jun 11, 2008

Jun 11, 2008 17:11    

Ужас. Ну не получается у меня ничего - установила русскую версию b2evolution, всё вроед нормально, все на русском... но это совершенно не относится к записям - blog a, blog b все в знаках вопросов, а когда я попробовала добавить свою запись в свой блог, то получила следующее:

"Дополнительная информация о данной ошибке:
MySQL error!

Illegal mix of collations (utf8_general_ci,COERCIBLE) and (latin1_general_ci,IMPLICIT) for operation 'like'(Errno=1267)

Your query: Check URL against antispam blacklist

SELECT aspm_string

FROM evo_antispam

WHERE 'Добро пожаловать в мой блог!' LIKE CONCAT("%",aspm_string,"%")

LIMIT 0, 1"

Помогите! Ну не специалист я, только недавно сайт создала и в mysql не разбираюсь, а свой блог хочется. :(
Спасибо!

Jun 11, 2008 19:56

Добро пожаловать на форум!

Вы перед установкой создали базу данных, правильно? После этого вы поменяли кодировку базы данных на utf8_general_ci или нет?

Если у вас есть доступ к phpMyAdmin, то проверьте значение "MySQL connection collation" на главной странице phpMyAdmin, должно тоже быть utf8_general_ci.

Ссылка на ваш блог очень помогла бы.

Jun 11, 2008 21:04

Добрый вечер, спаисбо за приветствие! :) MySQL connection collation точно такой, как вы сказали - utf8_general_ci, у меня с wordpress та же фигня была, так что я на него плюнула и решила попробовать b2evolution - так и тут тоже самое. :D А где менять кодировку базы данных на utf8_general_ci? А то я ведь и правда только сейчас со всеми этими вещами разбираться начала - жутко интересно, так мучительно сознавать собственную тупость! 8| А блог тут - http://elizabethjanedarcy.co.uk/b2evolution/blogs/ Я проверила в PhpAdmin - общие установки там именно в ютф, а если я открываю папку с блогом, то там напротив каждого файла - latin1_general_ci, это их надо менять? Но как?

Jun 11, 2008 21:19

а если я открываю папку с блогом, то там напротив каждого файла - latin1_general_ci

Это именно то что я и хотел узнать. Вы установили b2evo в базу данных с кодировкой latin1_general_ci и таким образом все таблицы получили такую же кодирвку.

Вам нужно сделать следующее:

В phpMyAdmin выберите все таблицы b2evo и удалите их (drop tables) чтобы осталась пустая база данных.
Затем нажмите Операции (Operations) и выберите кодировку базы utf8_general_ci
После этого можете установить b2evo как и в прошлый раз, все будет в правильной кодировке.

Jun 11, 2008 22:44

Спасибо огромное!!! Всё получилось! 8| А вот ещё вопрос - я там даже запись создала (http://elizabethjanedarcy.co.uk/b2evolution/blogs/blog5.php( но она так и не появилась - за што такая немилость или я опять в настройках напакостила? :D

Jun 11, 2008 22:52

Проверьте есть ли эта запись в панели управления Записи/Комментарии. Если да, то какой у нее статус (опубликовано, черновик, отклонено)

Запись должна быть опубликована чтобы вы смогли видеть ее в блоге.

Jun 11, 2008 23:44

В том и дело, что "Видимость: Опубликовано Приоритет: 3" *озадаченно*

Jun 12, 2008 00:09

Идиотизм! 8| Я когда создала запись - изменила время с 15:37 на своё, лондонское - 21:34. Сейчас поменяла обратно и запись появилась! А... как это? А как можно моё время настроить?

Jun 12, 2008 00:13

Это удобно когда нужно опубликовать запись например через некоторое время, по наступлении этой даты запись автоматически будет опубликована.

Общие настройки -> Региональные поставьте там разницу во времени.

Jun 12, 2008 08:49

Рад был помочь, удачи!

Jan 11, 2009 01:32

Пожалуйста, помогите, ибо уже третий день бьюсь.
Проблема: когда залогинен как админ, то всё нормально (даже с других компов при заходе на главную и страницу регистрации нормально), стоит только разлогиниться — сразу вопросительные знаки вместо русских букв. Что только уже не пробовал: менять в УТФ8 вручную каждую таблицу, меня вручную в скл-базе кодировки на нужные, на хостинге ставить в базах правильную кодировку — всё зря. Проект уже надо запускать, а я не могу добиться работоспособности.
Вот, для примера ссылка: http://blogoport.com.ua/htsrv/register.php
Пожалуйста, прошу помощи!
Спасибо!!!

Jan 11, 2009 04:17

Добро пожаловать на форум.

Я не вижу вопросительных знаков, все в правильной кодировке. Похоже что вы уже все исправили :)

Jan 11, 2009 10:10

Да, действительно: я убил все таблицы, а потом зашёл на сайт, который стоит в Вашей подписи и скачал оттуда русифицированную версию, переустановил — и всё ОК!
Спасибо, сорри за беспокойство, просто реально не понимал, в чём там дело (до этого Вашего ресурса не видел).


Form is loading...

powered by b2evolution – This forum is powered by b2evolution CMS, a complete engine for your website.