Recent Topics

0.9.0.11 - urls in comments are not transformed into links

started by on Jan 03, 2006 – Last touched: Jan 03, 2006

Jan 03, 2006 20:51    

I have a problem with urls which are posted in my comments: they are not tranformed into real hyperlinks with a tag. The remain as plain text without <a>-Tags. Perhaps I switched this off by accident. =/ Any ideas?

Jan 03, 2006 22:20

Ok, I will do that. Can I just copy the files from the dawn release onto my server or is this more complicated to upgrade?

Jan 03, 2006 22:23

Make a backup of your current files and your database if you can. You shouldn't have any problems with the upgrade, but if you do you don't want to lose the data forever. Then upload the new files and when you try to log in it will tell you that the configuration hasn't been run yet. That's fine. Let it run. Feed it the info for your database and tell it to do an upgrade installation. Then you'll be able to log in with your normal username and password.

Jan 03, 2006 22:29

so I can just replace all the files and copy my old changed ones over again?

And to come back to the topic: The user ARE able to post links and <a href tags into their comments put urls like http://www.google.com are not automatically changed to

Code

<a href="http://www.google.com">http://www.google.com</a>

Jan 03, 2006 22:40

After you've run the installation script to upgrade the database you can merge your changes back in. Depending on what type of changes you've made, you can copy entire files or remake your changes by hand. Once you're done with the upgrade we can revisit the comment problem.

Jan 05, 2006 15:18

I finally understand what you're talking about. The autolink renderer plugin is not being applied to comments. Here's a fix. Open /b2evocore/_class_comment.php and find this part:

Code

function content( $format = 'htmlbody' )
        {
                $comment = $this->content;
                $comment = str_replace('<trackback />', '', $comment);
                $comment = str_replace('<pingback />', '', $comment);
                $comment = format_to_output( $comment, $format );
                echo $comment;

and make it look like this:

Code

function content( $format = 'htmlbody' )
        {
                $comment = $this->content;
                $comment = str_replace('<trackback />', '', $comment);
                $comment = str_replace('<pingback />', '', $comment);
                $comment = format_to_output( $comment, $format );
                // YaBBa's hack to use renderer in comments
                global $Renderer;
                $renderers = explode( ".","b2evALnk" );
                $post_renderers = $Renderer->validate_list( $renderers );
                $comment = $Renderer->render( $comment, $post_renderers, $format );
                // end hack
                echo $comment;

I tested that on my blog and it worked fine for me. Be warned that this will make your blog a more attractive target for spammers. That's why I'm going to remove this hack from my blog right now. That's also why this isn't really a bug. autolinks are disabled in comments on purpose. Once you confirm that this fix works for you, I'm going to move this thread to another forum. Credit for [url=http://forums.b2evolution.net/viewtopic.php?t=2700]the hack[/url] goes to ¥åßßå.


Form is loading...

blogging tool – This forum is powered by b2evolution CMS, a complete engine for your website.