Recent Topics

406 Not acceptable error when saving my Sharaholic info

Started by on Feb 13, 2019 – Contents updated: Mar 05, 2019

Feb 13, 2019 06:07    

I loaded the Shareaholic Widget and was setting up the ID information in the collection.
Got done and hit save and got the following error

Not Acceptable
An appropriate representation of the requested resource /admin.php could not be found on this server.
Additionally, a 406 Not Acceptable error was encountered while trying to use an ErrorDocument to handle the request.

Sorry I can't figure out how to screenshot here...but I'm going to the collections --> Settings --> Plugins and down to Shareaholic (which I just installed) I click enable, then I fill in the 2 IDs needed. and click Save that's when the error above comes.

Any ideas? where is this /admin.php supposed to be?

Feb 13, 2019 10:36

On the screenshot issue. If you have windows 10 or the like there is an app called Snipping Tool. Look for it in the main menu under Windows Accessories. I have mine on the toolbar for easy access. On clicking then click on New in menu, then drag around the area ans save etc.

It's the icon with the scissors :)

I'm not sure the 406 is a b2evo error see
https://webhostingmedia.net/http-error-406-not-acceptable/

the cause is usually one of the following two: a content type negotiation problem or misunderstanding or a mod_security rule setting problem, the latter being the most common of the two.

So a screen shot of the page before you enter the change and the one after would be good as by seeing the whole page including the url people here can see more clearly where the problem originates

Feb 13, 2019 10:47

See also http://www.hostingflow.com/http-error-406-not-acceptable/

Why Did You Get the HTTP Error 406?

When the browser send a request, it will dispatch an Accept header. The browser client will specify the characteristics of the data that it accepts. There are many types of accept headers including accept-charset, accept-encoding and accept-ranges. The Accept header informs the server about the format in which the browser want to accept the data. The server will return the HTTP error 406 not acceptable if it is unable to send data in the requested format.

406-not-acceptable

It means that the file exists but the client system did not understand the requested file format. This is because the MIME type specified in the Accept header fails to match with the MIME type specified in the requested file name extension. The browser can only accept data that it knows how to process such as HTML and GIF files. If it is a file that it cannot process such as multimedia file, it will return the 406 error message.

So if you any media files being transferred in the process it may be an unrecognised format

Feb 14, 2019 00:46

Thanks for the info. This is what I am doing immediately before the error. I fill this info in and then hit save
I don't understand why my changing the settings would cause a server error like that, because I'm not sending ...but perhaps it is.

Feb 14, 2019 11:33

Thanks for the screenshot

Hi I just had a similar problem with twitter on a new install. I don't use any social media but they come installed, plugins and links on the admin profile in the default install.

My problem arose since I change my host as they have a security module which poorly interpreted my attempt to change any default admin profile detail as an attempt to hack.

So whereas I'm not in a position to help you with this at the moment you may want to consider my post as the twitter plugin was trying to or appeared to send unwarranted info. https://forums.b2evolution.net/editing-demo-user-profile

Later I will try and emulate your problem

Feb 28, 2019 12:40

Hi. How are you with this issue. I've not got any further as I'm not sure hot to get the shareaholic widget/plugin working as you are trying.

If still a problem and you would like me to look into it would you please tell me what you downloaded and installed to get where you are? :)

Mar 05, 2019 12:01

@momwantsbalance I note your site is using Wordpress so I'm not sure if you have given up on b2evoluiton or are in the process of migrating. If the later please consider my previous post. I don't use social media so I would have to emulate your process to see the problem you have, so all steps and detail are important.


Form is loading...

Content Mangement System – This forum is powered by b2evolution CMS, a complete engine for your website.