Recent Topics

1 Jun 29, 2020 07:56    

Clean install, No demo choosen.
Starting with "manually create a new collection." Selecting "Minisite".

In the back end:
"Edit widget "Content Block" in container "Help""

Item Slug: help-content
Next to the field shows: "Item is not found"
http://demo2.b2evolution.net/stable/evoadm.php?ctrl=widgets&action=edit&wi_ID=78

But it should show the option edit "Help content" as link.

This behavior can be reproduced.

BTW.
In "Minisite" mode, many widgets settings "item slug" are not able to get edited. The link to that page is simply missing.

Am I missing something?

2 Jun 29, 2020 17:12

This seems fine on my 7.1.5
I Created a Minisite with Jarad skin and no content.

Clicking on the link gives the following, but I note the date. It seems this help page was generated on 19 June 2018.By the way I never use any demo content so this must have been available with the default download then.

I will check the files in some versions of the download next :)

3 Jun 29, 2020 17:20

@amoun wrote earlier:

Created Minisite with Jarad skin and no content.

Yes, no content. And the skin should not have any effect on this bug.

But how come, that you have "help" content in your "empty/no content" install?

4 Jun 29, 2020 17:23

Hi @northlight

That wasn't a query I meant I have just created a new collection as you did to test Minisite using Jarad. Apologies if that wasn't clear. Upadated the last post with second image. I tend to edit posts as I go.

5 Jun 29, 2020 21:08

Hi @northlight Have you tried [https://domain.xyz/index.php?disp=help that goes to the same page as the link in the widget. That accesses the file [/skins_fallbackv5/_help.disp.php] or [/skins_fallbackv6/_help.disp.php] You should have both.

if you do then maybe there is something amiss with the instance of the widget you are using ~ I suppose you could reinstall it ?

6 Jun 30, 2020 06:32

@amoun wrote earlier:

Hi @northlight Have you tried [https://domain.xyz/index.php?disp=help that goes to the same page as the link in the widget.[/quote]


The problem is not the front end. Attached a snapshot.
Problem is the backend where the "edit link" is missing.


I think the problem is in the documentation of b2e.
I believe that there is no edit link, as there is no content (blank/clean install w/o any demo data) and the backend doesn't know where to link to.


The documentation of b2e always "plays" with the demo content but it isn't explaining how to work with a clean install.


Meanwhile I think that the b2e promotion "installed in 3 minutes" should be expanded with "and set up in another month".


Since years I am "playing" with B2E and still I am stumbling from one problem into another.

7 Jun 30, 2020 07:26

I will answer myself.
My earlier post is giving the answer to this bug report.

Basically it is no bug. It is a illogicality. (hope this is the right term).

The empty clean install comes with a skin/template which is linking to a "help" page.
But this help page does not exist.
Therefore you can not access it in the backend and therefore you can not edit it.
And the user believes that it exist, since the frontend is linking to it.

So, the user/website owner/blogger is wasting time, searching within the documentation for something that is not existing. The "Help content".
https://b2evolution.net/man/?s=%22Help+content%22&submit=Search&search_author=&search_content_age=&search_type=&disp=search

Instead, the user should search for "help-content" - because that's what he is looking for.
https://b2evolution.net/man/?s=%22help-content%22&submit=Search&search_author=&search_content_age=&search_type=&disp=search

In this case an explanation is required, for the blogger/user/website owner, to create such content block with the slug "help-content".

No offence:
If the b2e project wants to attract more users, then it would be a good start to remove these illogicallities.
They cost days of delays, frustration and - when it comes to money - thousands of Euros.

I am positive that other newcomers do not bother, diggin' like I did - in order to get b2e running.
Internet users/website owners are today more stupid than ever. Or you may call it pampered - because they do not want to think - or educated not to think anymore.
They are consumers. Used to get everything infront of their nose and surf through the applications by just wiping or clicking.

I hope I can share my frustration and it will be picked up as constructive criticism.


Form is loading...

Content Mangement System – This forum is powered by b2evolution CMS, a complete engine for your website.