Recent Topics

1 Aug 14, 2014 17:58    

In we use 2 skins: our own, to access via PC, and touch, to access via mobile. The thing is that sometimes when you access via PC it appears the touch skin instead of our own, and the same occur sometimes if you access via mobile: it appears the PC skin instead of touch.

I wonder if the reason could be that b2evo uses always the last cached page, so if you access via PC and the previous access was via mobile, the system displays the mobile skin.

2 Aug 15, 2014 15:37

Hello @fede,

I couldn't reproduce this issue. I used three different devices: desktop PC, mobile phone and tablet, with different skins for each one of them. The result is a single cache file for each skin, so they never got mixed. Of course, these are local test, so maybe they are not 100% conclusive.

Maybe you should disable the default cache system ( ) for a while and look if the error disappear. How often do you notice it?

Do you use any other cache system besides the provided by b2evolution?


3 Aug 16, 2014 19:04

Hello @mgsolipa

Thanks for your answer. I don't know what happens. I tried in local too:

1. In one browser, I log in and clear the full page caches in Maintenance
2. In another browser, without login in, I enter the home page, to create a cache file. Look in /cache/c1: it's there.
3. I modify function is_mobile_session() in _session.class.php. Before return, I put $this->sess_device = 'iphone';, so the system believes I am accessing from a mobile phone.
4. I enter home page in the first browser, where I am logged in, and I see touch skin, which is correct.
5. I enter home page again in the second browser, where I am NOT logged in, and I see the asevo skin: it means that the system is reading the old cache file, didn't notice the connection is coming from iphone now.

The other way around produces the same result: If I create a cache file with touch skin, then when I go back to asevo, the second browser still shows touch skin.

Of course, if I disable the default cache system,everything works alright, so the parameters seems to be ok. I use the standard cache system, no modifications.


4 Aug 17, 2014 13:15

@fede thanks for the detailed steps, but I'm still unable to reproduce the issue. Please check the video:

What browsers are you using to perform your tests?

5 Aug 18, 2014 14:51

Firefox & Chrome, last version.

6 Aug 18, 2014 17:57

I am very sorry, but this was my fault: I have modified function get_af_filecache_path() some time ago, making other tests, and I forgot to put it back in the original state. Now it's working perfectly. Thanks for your patience.

7 Aug 19, 2014 06:26

Good news @fede, nice to know your site is behaving as supposed again.


Form is loading...