Recent Topics

1 Apr 25, 2016 18:53    

Hey all. Long post here. We tried to reach out to a "Hire a Pro" person (three of them), but never heard back, so we're hoping someone here can help us. Check out to see our problem.

Anyway, I am the editor of an academic journal called Xchanges, which has its home at a large university but that I run independently. We are currently having a major crisis resulting from trying to replace our old site with a new one that a group of my students built using b2evo, over the last year. My husband is a software engineer, so he has helped me to trouble-shoot as much as he could, and has helped me describe the problems we're having in this post, but we're really at a loss as to how to proceed and are hoping you can help.

Originally, was built as a pure html site. Over the last year, we piloted a move to B2Ev as our CMS. Our hosting is at Bluehost. Our main site is: = root of public_html/
B2ev site is: = public_html/new/
If you go to either now, you can see that is up, but that is clearly really broken.

The problems we're having stem from our desire to have our new content moved to root, so would be served by b2ev. That is still the goal, but a working would be a workable intermediate goal. I can go into what happened to cause this meltdown of the b2evo site, but suffice to say, when I called Bluehost support to walk me through the process of moving the existing files into an "old" folder and then to move the "new" folder files into the primary public html, all these problems emerged, and we were never able to get the b2evo site back up in such a way that I could even log in, much less get to the collection dashboard so I could see any of the articles we're in the process of editing to release in our next journal issue.

Anyway, our migration failed. The symptoms/problems are:
-- Database calls failed, and now php code displayed, b2ev functionality not working (as I said, I can’t log in to b2ev).
-- Can ftp, and have backups of public_html, and bluehost does too.
-- Restores of public_html haven’t succeeded from local, or from bluehost initiated.

My husband believes the problem is a configuration issue of some type – missing files/structure, or conflicting additional files. Or bad config htaccess. He's been helping me as much as he can, since as the editor of the journal the technology side isn't my focus, but I don't have a student working as the technical editor or site admin right now, so we're really stuck. We're not sure what to look for to sort out the problems that are facing us. We desperately need to get access again to the b2evo site, to have it back up, to make sure all the articles we're trying to publish are there, and then if all of that is retrieved, then we can go about trying again to replace the old site with the new b2evo site.

We think:
Things someone needs to know to figure out – execution order of files in call to (to tell where things break down and either replace files, or ?)
Where does the article content live/stored (in db, or in files, or?)?
Could reinstalling b2ev database or php/js solve this?
How do I tell what version of b2evo I am using, from a nonworking installation?


2 Apr 26, 2016 01:08


The article content is stored in the DB. Make sure you keep one or more backups of the DB at all times.

You can tell which version you are running from the file /conf/_application.php --

What I would do in your case is install a fresh b2evolution in something like . You will get demo content on that site. As long as that fresh site doesn't work, your problem is with bluehost.

After that, you should edit the file conf/_basic_config.php ( ) to paste in the $db_config from the same file on . At that time, 'clean' will start displaying the articles that are supposed to be on new. (Also your admin accoutn will have the password of the admin accoutn from new. basically every piece of data from 'new' will now be on 'clean').

3 Apr 29, 2016 06:02

Thank you so much, Francois. My husband (my resident software engineer) followed your directions and so we have working for the most part. There are still some things that seem to refer to If you go to and then scroll over the items in the right-hand sidebar under Current Issue Contents, those items still refer to "" What do we do to fix this?

The biggest question is: how do we move to the root of public.html or have it behave that way, so that a user visiting would go where we want them to, and see the content built on b2evo? This was the whole problem that set off all of these crises (which bluehost tried to walk me through but ended up breaking everything).

4 May 07, 2016 11:59

@xchangesjournal I have seen that you also created a new post with your latest questions, I understand that because we haven't answered before, so I'm closing that post just to keep the whole solution in this one and give you (and further readers) the opportunity to read all in a single view.

Regarding the right sidebar, you are using the Simple Sidebar Link list widget. All those links are posts which type is Sidebar link, so you need to find them out in the backend and change the URL that they are linking to (check the screenshot below to see how to list posts of this type). Once you have find them, all you need to do is replace the content of Link to url with the correct URL.

Regarding the location change, please follow these steps (which are almost the same you mentioned in the other post, but including an additional step):

  1. Create a new folder at the root directory or your web server, as you mentioned, it should be "public.html". Let's name the new folder "old".
  2. Move all your files and folders but "clean" to "old".
  3. Move all the content of "clean" one step above. Now all the b2evolution's files must be at the same level of "old" and "clean".
  4. Open the file conf/_basic_conf.php and replace the value of $baseurl with

That must be enough.

5 May 10, 2016 06:20

Thank you so much, Manuel. We did the migration and fixed the right sidebar links.

Now, we've found another problem where the content of a number of posts refer a to /blog1.php/xxxx (where xxxx is a post), and the correct link should be /xxxx. We can fix that manually by going through all the posts, or would be very interested in figuring out how to globally search and replace the 'blog1.php/' with '' (nothing) in the article texts - which we learned are in the database, but not exactly where in the database.

Can you tell what columns in what tables contain the text for the posts, and if that is a datatype where replace() works? Or feel free to suggest any alternate method, or let us know that we should just proceed with the manual fix (editing each post).

Form is loading...