Recent Topics

6.10.7 PHP Fatal error : geoip_plugin

Started by on Mar 19, 2019 – Contents updated: Sep 24, 2019

Mar 19, 2019 03:58    

Hello,

after update to 6.10.7-stable I see this error :

Stack trace:
#0 /.../plugins/geoip_plugin/geoip2/src/Database/Reader.php(242): MaxMind\Db\Reader->get('')
#1 /.../plugins/geoip_plugin/geoip2/src/Database/Reader.php(215): GeoIp2\Database\Reader->getRecord('Country', 'Country', '')
#2 /.../plugins/geoip_plugin/geoip2/src/Database/Reader.php(88): GeoIp2\Database\Reader->modelFor('Country', 'Country', '')
#3 /.../plugins/geoip_plugin/_geoip.plugin.php(257): GeoIp2\Database\Reader->country('')
#4 /.../plugins/geoip_plugin/_geoip.plugin.php(714): geoip_plugin->get_country_by_IP('')
#5 /.../plugins/model/_plugins.class.php(1273): geoip_plugin->BeforeBlockableAction(Array)
#6 /.../plugins/m in /.../plugins/geoip_plugin/maxmind/src/MaxMind/Db/Reader.php on line 104

[18-Mar-2019 21:30:02 Europe/Paris] PHP Fatal error:  Uncaught InvalidArgumentException: The value "" is not a valid IP address. in /.../plugins/geoip_plugin/maxmind/src/MaxMind/Db/Reader.php:104

Mar 21, 2019 20:47

If you cannot even log in, delete the GeoIP plugin and reinstall it after yo can log in.

Sep 24, 2019 01:32

Thank you very much, it's resolved with 6.11.3


Form is loading...

CMS – This forum is powered by b2evolution CMS, a complete engine for your website.