Recent Topics

1 Sep 13, 2016 23:20    


I just upgrades my php to 5.6. I run three sites from the same HTDOCs folder using subdomains. My blog is a subdomain. In order to use 5.6, I have added the php.ini provided by my hosting service to the root folder. The blog works fine until I try to log in. Then I get a redirect ( - very long).

Is there a solution to this. Adding the php.ini to my other sites works just fine. B2E is the only one that does not.



2 Sep 14, 2016 03:01

What version of b2evolution are you running?

What is your $baseurl configured to in b2evolution's base config file?

3 Sep 14, 2016 04:06


My version is at least 6.6.5 but I may have a later version. I cannot log in to find out.

The base url is

The front end works fine. But, if you click on log in, you will see the problem.

Thanks for your help!

5 Sep 14, 2016 18:39

Also when trying to log in on your site, I see:

No input file specified.

I don't know why you call that a redirect.

No input file specified. is NOT a message generated by b2evolution. It is generated by your web server.

  1. Check that the /htsrv/login.php file exists and is readable by PHP.
  2. Ask your webhost what that message means.
  3. If available, check the error log provided by your web host.

6 Sep 14, 2016 22:43

Hi, thanks for your response.

Here is the line from the basic-config: $baseurl = '';

The message "no input file specified " means that the file called by the link does not exist.

The /htsrv/login.php file does exist and is readable (644).

I call it a redirect because the address provided by the link has the word 'redirect' in the link: "

It must have something to do with the php.ini. It was working fine. When I upgraded the php from 5.3 to 5.6, I had to then add a separate php.ini file to each of my root folders, all of which are in the htdocs folder on my webhost. The other two work fine, but B2E is having this problem.

Any ideas?


7 Sep 14, 2016 22:50

You really need to ask your webhost on this one.

You say the file exists but the webserver says it doesn't exist. In between is the configuration specific to your webhost.

8 Sep 14, 2016 23:01

PS - I checked my error logs but nothing showed about this issue.

9 Sep 16, 2016 05:29


I checked with the host and they said they could see nothing that relates to the problem. As far as I can tell from Google, there is an issue with the rewrite in the .htaccess file.

10 Sep 18, 2016 10:41


I have checked everything and then went back to my web host. They claim that B2E does not support PHP 5.6. They do offer B2E on their install service.

I tried to set the PHP to 5.3 through the htaccess file, but since this is a subdomain on my main HTdocs root folder, I cannot have two different php versions.

Do you have anymore ideas about this?



11 Sep 19, 2016 04:48

b2evolution 6.7.6 supports all version of PHP between 5.2 and 7.0. That includes 5.6.

It might be there is an issue with the rewrites in the .htaccess file but there has to be a log file somewhere on your hosting environment, that actually allows to see those errors as they happen. Perhaps an apache error.log file?

12 Sep 19, 2016 05:04

I have been checking the logs and nothing shows up there. I had the webhost check them as well and they found no errors listed there. That is why they think there is an issue with the blog site.

I was using 5.3 and the site works perfectly well. When I switch back to test, it works properly. The problem was that my Joomla site won't update anymore without 5.6 so I upgraded through the webhost functionality, and then this issue happened with the B2E. both the Joomla site and the B2E site are situated within the same htdocs root folder.

I have copied the PHP.ini file from the webhost server and placed a copy in my root folder for b2E. Does that make any difference?

I wonder if since I was using 5.3 which I installed the updated blog software to 6.6.5, it saved the PHP configuration somewhere because it was reading the PHP as 5.3. Now that I have upgraded, maybe there is a line of code somewhere that still refers in some manner to 5.3 or 5.3 level language??

Thanks so much for your time to solve this. I have been using b2E since 2006 ( and have been very happy with it!

13 Sep 20, 2016 01:46

I think you should try to install a fresh copy of b2evolution in a sperate folder where you can test it without interference from Joomla. Once that works it will be easier to find the source of the issue.

14 Sep 20, 2016 14:12


I have uploaded the filed for 6.7.6 and tried to do a completely new install. I get the same error message when I try to access the install/index.php. "No input file specified". I created a back up of my existing site and tried to upgrade that. Same thing. I then tried to use the MOJO Marketplace free installer provided by the webhost and that failed as well.

The host claims that the site works perfectly on PHP5.3, and I have tried and verified that. It does not work on 5.6. Do you have any other solutions? I have ensured that he PHP.ini is in the root folder. I have checked everything I can think of for the base url, etc.

Any help would be great. I really want to get this working.

15 Sep 21, 2016 00:30

My understanding is that fro you to upgrade from PHP 5.3 to PHP 5.6, you place a file called php.ini in your webroot and that breaks the site.

I also think I understand you have no idea what is in that php.ini file and have never cared to look.

My guess is that there is something in that file that does break your site and that something is NOT "PHP 5.6". It's most likely soemthign else, maybe somethign related to mod_rewrite indeed.

Who is your web host?

Ask them to give you the deafult php.ini they use for PHP 5.3 and compare it, line by line, to the one they gave you for PHP 5.6. You will find differences. You need to test which one of them breaks your site.

16 Sep 21, 2016 00:37

Hi - Actually, I did care to look as I care very much about my work and my site. I have ten years of posts invested in this software.

I have gone over the file line by line and edited it very carefully. I had to or the other sites (subdomains) would not work. I did get the file from my webhost - Powweb - and have had them check everything at least four times and have yet another ticket in this morning about it. B2E is the only one with this problem.

I'll let you know what they find. In the meantime, I am not trying to be rude and I hope you didn't get that from my last post.

17 Sep 21, 2016 03:43

No worries, I'm just a bit pissed at POWWEB because they have the full power to investigate where that message comes from. We don't.

Again, the error is not printed out by b2evolution.

At this point I think you should try commenting out everything about mod rewrite from the .htaccess file and see if it makes a difference.

18 Sep 24, 2016 04:54

Hi - Good news. I finally convinced Powweb that the error was on their end. I installed a new version of another blog software that they offer through their in-house installation in my htdocs folder as a subdomain, just as I have the B2E installation. That site had the exact same error. So, they finally believed me.

The response from the technician was that since I had three subdomains running in the root folder, some of the modules in the php.ini file had to be disabled, and some had to be enabled to manage all three sites (b2e, Piwigo, Joomla). The php.ini file has to be the same in all three subdomains, with the exception of the paths to the web root.

Now all are working. If you would like a copy of the php.ini file for your reference, I am happy to send it to you.

Thanks for your efforts and help.

19 Sep 24, 2016 11:10

Can you please attach the php.ini file here for the next user running on Powweb?


20 Sep 26, 2016 14:09

Hi Powweb users:

In my case, I have three subdomains running from root folders all located in the htdocs folder. Originally Powweb told me I needed to have a separate php.ini file in each root folder with the web root set to each folder. However, this apparently is not true.

Attached is a php.ini txt file that the powweb guys set up for me. I have not compared it to the standard one that is provided through the control panel. I did however notice that although they state on the cgi-script page to set the webroot path and they even give you the path to set, this is not actually needed.

They did say that they set, or turned on, several of the modules and turned off others to make the file compatible with 5.6. If you upgrade from a lower version of PHP and then get a "No input file specified" error, then it is quitre possibly Powweb! Check the php.ini and send them this one to compare. Also, the technician that actually solved this problem is Ravi B. Ask for him.

Any other questions? You can contact me through this form and message.


Form is loading...