Recent Topics

JAPANESE POSTS - Garbage when using BROWSE/EDIT

Started by on Jun 14, 2004 – Contents updated: Jun 14, 2004

Jun 14, 2004 22:08    

I am noticing that when I go into the BROWSE/EDIT tab in the admin portion of b2evolution, all my JP posts are showing up as garbage.

When I go into an individual post by clicking on the EDIT button, the text comes up fine in the textarea, but the title comes out as garbage

Jun 15, 2004 07:37

Is this a bug in 0.9.0.8???

Jun 15, 2004 15:16

You must use the same charset for you user locale as for the blog you want to edit.

In this case, you must set your user locale to japanese.

Feb 14, 2005 08:03

Changing the charset for the blog and local user doesn't work.

When editing a previous contents (no problem to create it), it shows up as garbage, which seems to be same for other non European languages such as Korean or Chinese.

When trying to edit the text from my MySQL database, I have the same problem.... not being able to edit the text is quite an issue.

Where is the bug ?
Thank you for your help.

Feb 14, 2005 19:41

do you use php5 or php4 ?

is it because of php5 ?

Feb 15, 2005 00:38

no, I'm using php 4.3.10

Feb 15, 2005 19:41

I made some changes as follows so that i can use multi-languages i.e. Chinese, English, Latin characters, Japanese characters etc in my posts, while maintaining my blog interface in English.
I do not have any problems for posting or editing old posts in multi-language.

1. Open "_locales.php" file under the "config" folder.

2. Make changes:-
Line 26: change to utf-8
$dbcharset = 'utf-8'; // If you don't know, don't change this setting.

Line 33: check if it's en-EU
$default_locale = 'en-EU';

Line 72: under en-EU, change again to utf-8
'charset' = > 'utf-8',

3. After login, under Settings-->Regional-->en-EU-->Edit, make sure the Charset is utf-8.

Of course, the whole blog's default locale will be UTF-8 in this case.

Please take note, this is only for those who would like to have en-EU interface for the whole blog yet still can post/edit at multi-language without changing the locale of each post.

May 04, 2005 17:44

I have the same problem. I want to do my blog in Japanese, but when I edit the posts it is garbage. The last suggestion will not work for me because, I do not want an english blog with Japanese content inplaces, I want a Japanese blog.

LoKa320, did you figure it out? Let me know.

Any suggestions are welcome. Thanks

May 09, 2005 16:21

I have the same problem. I want to keep the admin interface in English but the site I am looking after for my wife is entirely in Japanese. So, when I am on the admin pages and any of the Japanese content is displayed it is all moji-bake (garbled).

I checked the localisation settings an noticed that the charset defined there for the Japanese locale is utf-8.

I am rather surprised that the site shows up at all because if anything, double byte languages should be using utf-16, not utf-8. However, the character sets for Japanese are

- iso-2022-jp (JIS)
- shift-jis (Shift-JIS)
- x-euc (legacy EUC)

However, you cannot just change the character set there because it has to match the encoding of the translated strings in the language file.

I am not sure what encoding the Japanese translator used for those translations, but I tried all the standard encodings and it turns up garbled. I suspect that the translation will have to be entirely re-encoded in one of the standard encodings and then the locale should be set to the appropriate encoding. Preferably, this should be done for ISO-2022-JP, which is the official Japanese government standard, ratified by ISO.

With that it should then be possible to mix English and Japanese on the same page, but the HTML will have to tell the browser which text is UTF-8 (for European languages) and which text is ISO-2022-JP. However, with the current state where the Japanese is strangely using UTF-8, I have my doubts this can work.

It also seems to me that there is some embedded JavaScript which does not get passed the information about the character encoding used.

Anyway, if somebody can pass me the contact details for the Japanese translator, I will give them a call and see if we can sort this out.

rgds
benjk

May 26, 2005 09:08

benjk wrote:

I am rather surprised that the site shows up at all because if anything, double byte languages should be using utf-16, not utf-8. However, the character sets for Japanese are

- iso-2022-jp (JIS)
- shift-jis (Shift-JIS)
- x-euc (legacy EUC)

benjk,

It is not correct.
Double byte languages can be using utf-8.

The character sets for Japanese are

- utf-8
- utf-16
- iso-2022-jp (JIS)
- shift_jis (Shift-JIS) (sould be underbar, not hyphen)
- euc-jp (legacy EUC)

May 26, 2005 09:32

If you'd like to use Japanese, you should change your locale to "Japanese (JP)".

When you install b2evolution, click a "Japanese (JP)" link to change the locale before start install.

If you did not set the locale during install, you should change the locale for a blog and a user before you input a post.

The settings are both "User management" and "Blog".

To use admin pages with a correct charset, a user setting that you'd like to use Japanese should be change to Japanese at "User -> admin (or the user) -> Preferred locale."

To display a blog with a correct charset, the blog setting that you'd like to use Japanese should be change to Japanese at "Blog -> Blog A (or the blog) -> Main Locale."

May 26, 2005 13:52

As bebe says, it can possible to use Japanese by changing a charset of English locale to utf-8.

But sometimes IE does not recognize utf-8 English locale if the webpage does not include utf-8 characters.
Then IE user should check that IE's encode menu (View -> Encode) is utf-8 whenever post a entry or a comment.

Aug 22, 2005 11:45

I also have a problem with Japanese, but it's rather weird:
I make a new blog, choose Japanese (JP) as Main Locale and every time I finish inputting something in Japanese, part of it gets turned into gibberish.
For example, I input 可愛い写真 and it will show up on the page as 可愛い写#1346#3646 or something like that.

It doesn't just happen with posts but also with the title of my blog. I have to add that I've put up 2 blogs, one in English and one in Japanese, and then a 3rd one that gathers the posts of the 2 previous ones.

When I check view->encoding, it's never set to UTF-8. Any idea how to solve this? I've tried it with an English and with a Japanese version of IE, but the result remains the same :'(

Dec 26, 2005 08:32

The following solution worked in a site with both Japanese and English (US) pages. Thanks bebe!

bebe wrote:

I made some changes as follows so that i can use multi-languages i.e. Chinese, English, Latin characters, Japanese characters etc in my posts, while maintaining my blog interface in English.
I do not have any problems for posting or editing old posts in multi-language.

1. Open "_locales.php" file under the "config" folder.

2. Make changes:-
Line 26: change to utf-8
$dbcharset = 'utf-8'; // If you don't know, don't change this setting.

Line 33: check if it's en-EU
$default_locale = 'en-EU';

Line 72: under en-EU, change again to utf-8
'charset' = > 'utf-8',

3. After login, under Settings-->Regional-->en-EU-->Edit, make sure the Charset is utf-8.

Of course, the whole blog's default locale will be UTF-8 in this case.

Please take note, this is only for those who would like to have en-EU interface for the whole blog yet still can post/edit at multi-language without changing the locale of each post.

:D :D :D :D


Form is loading...

Build your own site! – This forum is powered by b2evolution CMS, a complete engine for your website.