Recent Topics

TinyMCE disappeared!!!

Started by on May 16, 2008 – Contents updated: May 16, 2008

May 16, 2008 12:49    

Hi!

First of all, thanks to the authors of b2evolution blogtool.

I have a problem with TinyMCE plugin. Some days it disappears. So, I reinstall it again and seems to be fine. But, next week disappears again.

Doo you any reason to happen this?

(Sorry for my english)

Ion

Jun 09, 2008 14:36

i installed it this morning and have the same problem... it worked at 10 o'clock and it doesn't appear now when i'm on IE. But it still working with Firefox! I'm installing it one time more, but i have no idea how many time it's going to work (appear)...

I have no idea where the problem come from... If someone have the same problem on IE and a solution, i'm listening :D

Nov 26, 2008 04:39

I have the same problem but is is only with particular users. For some reason, the one user that needs it the most cannot have it. I am using firefox and 2.41.

Nov 26, 2008 09:52

Hi fugfuggy,
you should use the fckeditor... it works!
the tiny editor is not finish and present some bugs,
have a nice day ;)

Nov 26, 2008 20:55

ha ha..... I took your advice. Uninstalled Tiny and installed FCK. Not only did the FCK editor not show up but it made my dashboard disappear!

Oh well, back to tiny for those that CAN see it.

Nov 28, 2008 10:32

You can modify the file _tinymce.plugin.php
On line 278,replace the PHP code as following:

'<?php if ($this->UserSettings->get('tmce_theme')){ echo 'advanced';}else{echo 'simple';}?>',

On line 322
'<?php if ($this->UserSettings->get('tmce_theme')){ echo 'advanced';}else{echo 'simple';}?>',

Nov 28, 2008 12:45

Thank you for you message.

But in that file in the line 278 I get "disk_cache : true,"

I suposse, in my file, the line has to be change is a different one.
Can you tell me pleas what is the code text I should change?

Jan 31, 2009 16:12

I just had this same problem.

I had to update the profile for one of my users from Level 1 to Level 10 and then the plugin stopped showing up on the "edit" post.

Internet Explorer Reported "javascript error"

Delta_width or something... (sorry forgot to type it).

Anyway, I uninstalled the plugin and re-installed it. That worked.

Jan 31, 2009 18:26

Everytime I create a new user.

Jan 31, 2009 22:19

Sounds like TinyMCE should be updated to say "stable until it vanishes" :D

Jan 31, 2009 23:56

jandy, what version are you referring to?
Please add the line you've changed, so it's not only dependend on the line number(s).

I'm planning to update the plugin in the next days, so it would be great if this could get fixed there, too.

Jan 31, 2010 01:21

TinyMCE just suddenly stopped working for me, too. Would adding APC caching cause a problem with this?

In FireFox, I got a "check tinymce url error" before it stopped working, and now in IE, I get the following



Message: Could not complete the operation due to error 80020101.
Line: 136
Char: 4
Code: 0
URI: http://blogs.mydomain.com/plugins/tinymce_plugin/tiny_mce/tiny_mce_gzip.js?v=3.3.0

I've uninstalled and re-installed with no improvement.

Nothing else has changed on my install other than APC caching being installed.

Thoughts?

Jan 31, 2010 20:28

chashock, try disabling APC then again - does it fix it?

Also, which b2evo version are you using? (Please try with the latest release)

Jan 31, 2010 21:16

I'm using 3.3.3.

What I did was replaced the tinyMCE folder from a full 3.3.3 download and the problem went away. tinyMCE has been working just fine since then.

Thanks for the reply. If I have the issue again, I'll try disabling APC, but if I recall my troubleshooting correctly, I tried disabling cache without any success.

Mar 12, 2010 00:26

did a replace of the tinymce folder that did not help... same error still there....
only have this pro since up to 333... grrr


Form is loading...

Run your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.