Recent Topics

1 Nov 14, 2009 06:00    

I just set up a new MySQL 5.0 database on a 1and1 developer's account. I uploaded the full 3.3.2 release files to the server. I then went to the installation script using FireFox 3.5 browser and ran the script putting in the information about my database connection. When I told it to "GO" to create the tables, I got an error about checking my database configuration. I decided to redo the install and deleted the config file without looking at the contents. I ran the install script again and got the same error about check my configuration. I knew the configuration I entered was correct and I copied an paste the name and server to be sure I did not make a typing error and double check my password to the server. Clicking on blog I received a database connection error.

At this point I decided to check the actual contents of the config file that was created and I noticed that my password that was stored was incorrect. The install script did not copy all of the password to the config file it created, leaving out three of the characters in the middle of the password. I edited the config file and entered the missing characters and then uploaded the config file back to the server and simply reloaded the page to finish the installation.

Evidently, it had stored an incorrect password twice, so there must be something about the installation script that is excluding characters for some reason.


2 Nov 14, 2009 06:07

It just occurred to me that my password included a $ and that a $ is used in declaring variables in PHP. Could this have caused the problem with the script not writing out all the characters in my password?


3 Nov 27, 2009 22:04

I cannot reproduce this with the current development version of the 3.3.x series and I doubt there is a bug in 3.3.2.

4 Dec 07, 2009 04:30

Thanks. I am planning on waiting until the 3.3.3 stable release to do any new installations and if this problem shows up again I will do a better case of documenting.

5 Mar 05, 2010 21:35

I just did a fresh install, no _basic_config.php file and no database tables, with version 3.3.3 and the problem occurred again. This may just be limited to but it definitely happens with my host. The password contained a $ followed by two numerals (it may be the $ and numerals point to some PHP variable?)


Form is loading...