Recent Topics

[4.1.1] Comment form in English

Started by on Oct 09, 2011 – Contents updated: Oct 09, 2011

Oct 09, 2011 16:13    

My b2evolution Version: 4.1.1

I have set the global blog setting into Finnish for my site.

Everything else is displayed in Finnish in back office and in the public part except the comment form which is completely in English.

What could be the reason for this?

I checked the and it seems that it's using .T_() for all the texts but still they are in English.

Edit: it seems it's only English for guests. If I login, the text changes into Finnish.

Oct 09, 2011 20:54

Make sure you changed General, Blog, Post and User locales

Oct 10, 2011 09:28

Yes, they are all set to Finnish.

And everything else on the page (all links, texts etc. are in Finnish) except for the comment form text.

See here:

For example the sentence Kommenttisyöte tälle kirjoitukselle is in Finnish but the comment form below is in English.

Oct 10, 2011 19:42

Try to disable AJAX forms on Blog settings > Advanced tab.

Oct 11, 2011 07:35

That fixed it.

Any other way to fix it and still use Ajax forms?

Oct 11, 2011 07:46

It's a bug then. Let me check for solution.

Oct 12, 2011 02:37

Maybe we need to pass the desired locale in the AJAX request that loads the form.

Oct 12, 2011 03:03

Maybe we need to pass the desired locale in the AJAX request that loads the form.

Why can't we detect it from post, blog, user etc. ?

Nov 08, 2011 21:52

This problem seems to be still with 4.1.2 and there is a new bug related to this.

I upgraded my blog to 4.1.2 and after the upgrade I cannot uncheck the Ajax form in the dashboard. After unchecking the checkbox and saving changes, I get the message that the settings are saved but the checkbox remains checked.

The problem seems to be only with the Ajax checkbox. All the other checkboxes on the page work.

Nov 25, 2011 08:46

I had to disable the Ajax form from the database to get this to work.

Also I noticed that the reCAPTCHA plugin only works with the normal comment form and not with the Ajax form.

EDIT: Just noticed that there is a 2.0 version of the plugin.

Nov 25, 2011 17:09

v2.0 will not display captcha in AJAX forms. It's not possible by design, and it's a huge overhead anyway.

Form is loading...

Run your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.