Recent Topics

1 Nov 06, 2011 02:01    

My b2evolution Version: 4.1.1

I'm upgraded from 4.0.5 to 4.1.2. but /index.php and admin.php displayed an empty page (nothing in html). I reused my config, quite sure my baseurl is good.
I tried before on my machine (localhost), without any problem. But it doesn't work on server. I see install script, succeed to run it but can't see anything after that. I tried to refresh browser cache, tried Chrome and Firefox, still nothing.
Have a question: is it normal, in Filezilla, the file's bytes varies subtily? Like for index.php 3925 octets (computer) 3805 (server)

Someone have idea of what I should do? Could give more detail as needed.

EDIT: found some errors in log file, in hoping it could help someone to debug my problem. Thanks again.

[Sun Nov 06 15:37:03 2011] [error] PHP Warning: Wrong parameter count for substr_count() in .../inc/_core/model/db/_upgrade.funcs.php on line 1321 
[Sun Nov 06 15:37:17 2011] [error] PHP Fatal error: Call to undefined function: array_combine() in .../inc/locales/_locale.funcs.php on line 663 

2 Nov 15, 2011 22:45


if that's an error because of your server not supporting php5 try adding these 2 lines

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 -php

in your htaccess file. That will fix it.


3 Nov 16, 2011 05:09

This is a bug
b2evolution v4 and older should support PHP 4.3

4 Nov 20, 2011 03:30

I have the same problem as mel_t, upgrading from 4.05 to 4.1.2

my server runs php 4.4.9 and the .htaccess-fix as suggested by jensscholz doesn't do the job.

what do i have to do? downgrade again? if so, how would i do that?

by the way, @jensscholz: for parsing in php5, 1&1 suggests more or less the same fix as you do, with the little difference in the second line (don't know, if this is relevant). it reads:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

5 Nov 20, 2011 14:54

Talk to your hosting support. PHP4 is very old and obsolete for long time already.

6 Nov 20, 2011 16:43

Will be fixed in 4.1.3

7 Nov 20, 2011 19:15

nice idea to 'talk' to one of the biggest hosting companies in Germany about their outdated php-version.

wanted close this here from my side, confirming that in the end the .htaccess-fix worked. earlier it tried in the wrong directory

now i successfully upgraded to 4.1.2 - thanks

8 Dec 03, 2011 11:53

I am having the same problem, only my web host is using 5.3.8 php.

My error log shows:
Fatal error: Class 'Messages' not found in /home/etc/install/index.php on line 43

I'm trying to upgrade from 3.3.2 to the latest version 4.1.2

I added the above x-map stuff to htaccess, but am getting an awful lot of errors on my install page:

Can someone please help?


9 Dec 03, 2011 15:34

Your error is different. Just make sure you uploaded ALL files. Also check FTP transfer mode, should be [u]binary[/u]

10 Dec 03, 2011 16:24

Thanks Sam2kb! I recently updated my FTP program and didn't realise it changed the settings. Once I made it use binary, and re-uploaded the files, it worked fine.

11 Dec 14, 2011 09:00

Fatal error: Call to undefined function: array_combine() in /****/public_html/blogs/inc/locales/_locale.funcs.php on line 663

Did we lose the compatibility with PHP 4? From what I can tell from looking up array_combine it's only on PHP 5. I'm running PHP 4.3.8.



12 Dec 14, 2011 16:33

It's already fixed in 4.1.3

Add this to the end of /inc/_core/_misc.funcs.php

if( ! function_exists('array_combine') )
	// Floats are casted to strings to avoid overwriting
	function array_combine( $arr1, $arr2 )
		$out = array();

		$arr1 = array_values($arr1);
		$arr2 = array_values($arr2);

		foreach( $arr1 as $key1 => $value1 )
			$out[(string)$value1] = $arr2[$key1];

		return $out;

13 Dec 18, 2011 06:51

Thanks sam2kb. That fixed that problem but it's crashing in another unrelated area. I've taken the blog down for now and I'll wait for the next version or another viable alternative.


14 Dec 18, 2011 07:27

Replace the function at line 1313 in /inc/_core/db/_upgrade.funcs.php with this

function is_in_quote( $subject, $needle )
	$length = strpos( $subject, $needle );
	if( $length === false )
	{ // needle is not in the subject
		return false;

	$quote_count = substr_count( substr($subject, 0, $length), "'" );
	if( $quote_count > 0 )
		$quote_count = $quote_count - substr_count( substr($subject, 0, $length), "\'" );
	return ( $quote_count % 2 );

Please post the errors you get here

Form is loading...