Recent Topics

Disappearing Styles and Formatting

Started by on Mar 11, 2005 – Contents updated: Mar 11, 2005

Mar 11, 2005 05:24    

I'm not sure if this is a bug or not, but I couldn't find anything on the forums about the particular error I'm having.

Some background: I'm running 0.9.0.10 on a Linux server. My root folder (/www/ or /public_html/ as they both point to the same thing) is where my blog is also installed. My main blog is set up to be accessed via a stub file, named "index.php"

http://www.lexnaturalis.net/index.php (or http://www.lexnaturalis.net/) will let you access my blog. I have it embedded into my main site, so the code is embedded within my site content. I'm using the code from the a_noskin.php file that was shipped with the b2 package, because I made the blog conform to my site's pre-existing CSS and layout. It looks great on the main site (Unless you're using IE, but then why would you do that?) but as soon as I click anything on the calendar I get directed to a site like [url=http://lexnaturalis.net/index.php/2005/03/09/]this. [/url]

Suddenly all formatting is gone, yet when I view the source, it's still supposedly calling my CSS, and all the code is there. I think it has to do with how the blog is accessing the information at "2005/03/09" which is obviously not a real folder, but somehow it's being parsed as a folder, so "style.css" doesn't exist according to the serve. (Note: That's my take on it, but I could be wrong).

I'm not sure if it's a bug or some silly erorr I've made, but it has me stymied.

Note: If I remove "extra path information" then everything works fine. Before, when I used normal skins, "extra path information" didn't mess anything up. The glitch only appeared after I embedded everything into my site and started using "noskin"

Mar 11, 2005 05:50

That's because I unchecked "Extra Path Information" for now. I can turn it back on if you want to see the error. Go ahead and try it now.

Mar 11, 2005 15:09

I have an idea that might work. Instead of just importing style.css, why not link to the full url for style.css. Maybe that will allow your archive pages to read the right css file regardless of the directory structure.

Mar 11, 2005 17:54

Well, what did work was this:

@import "/style/style.css"

I just uploaded style.css to a new folder (stlye) along with the images that were in root, and it works fine. I have no idea why it works now, but it does. Thanks, Nate. I'd not have thought of doing that without your suggestion. :D

Note: I didn't try <link rel=...> because I had troubles getting it to validate XHTML 1.0 Strict, so I just stuck with importing. Your idea would probably work too, if I used the linking method.


Form is loading...

b2evolution CCMS – This forum is powered by b2evolution CMS, a complete engine for your website.