Recent Topics

_global.php "is not writable" when trying to extra

Started by on Dec 17, 2005 – Contents updated: Dec 17, 2005

Dec 17, 2005 13:01    

[SOLVED]

hi,

i tried to localize into arabic, but i get the following error message when i try to extract:

The file «/blogs/admin/../locales/ar_SA/_global.php» is not writable.

what does it mean?

btw, i gave the folder LC_Messages all the nine permissions.

thanks,

Dec 17, 2005 14:07

I'm guessing its a permissions problem, try this:
Open up your ftp program
Right click on your blog folder
Go to 'CHMOD' or 'Permissions' or 'Attributes'
And set the permissions to '777' ('7777' if u can) and apply to all files and folders.
If '777' means nothing to you, just check enable all permissions to every type of user.

Not sure wether that will work, but its my best guess.

Note:
Sometimes theres a option saying 'Sepprately Set File and Folder Attributes' do the above with that checked and without it checked.

PS:
I recomend FlashFXP for a ftp client.

EDIT:
Just read your last line of your post (amazing how i miss things like that).
Try what i said above, if where you set everything to full permissions.
And i have come accross problems with certain ftp clients or http permissions setters, but try that with flashfxp if u can.

Dec 17, 2005 14:15

i'm using i.FTP. it's free, small, no extra fuss, and seems very reliable.

is there another way to (may be manually) test if the permission settings were successful?

thanks,

Dec 17, 2005 14:22

Which version of b2evo you running?
I can provide a hack that mite work if its pheonix (1.6)

Dec 17, 2005 14:33

Try this

On line 184 of 'root/admin/locales.php' replace:

if( !is_writable($outfile) )


With:

chmod($outfile,7777); if( !is_writable($outfile) )

It works by php setting the permissions instead, i've only seen/used chmod on the rare occasion so i'm not sure wether it will work, if it does itll be cool ;)

But your permissions are definitly not set.

Dec 17, 2005 14:48

Yikes sorry my bad!
the actual file is: root/admin/locales.php

I've corrected my original post.

Dec 17, 2005 14:57

ok, i replaced the line. tried to extract again, and still got the same error message. then i confirmed that the line was changed, just to make sure. unfortunately, it didn't work. :(

Dec 17, 2005 15:03

Try:


if (!chmod($filename, 7777))
$Messages->add( sprintf( 'The file «%s» could not have its permissions set.', $outfile ) );
else
if( !is_writable($outfile) )

See if u get "could not have its permissions set" instead.

But it is a permissions problem, try setting permissions with flashfxp and if that doesnt work its out of my league.

I just tried changing my default locale and it worked fine, so it isnt a problem with b2evo just to double confirm.

Dec 17, 2005 15:33

alright, i got "could not have its permissions set"

so i installed flashfxp and found the permissions of LC_MESSAGES to be 777. i changed it to 7777, and removed the php test code that we added to locale.php, and it worked!! it doesn't work with the test code in file.

great work balupton,

thanks for helping me out :)

i'm disappointed at my i.ftp :( :P

Dec 17, 2005 15:37

Hehe, wasnt that what i said in my first post ;)


Form is loading...

Build your own site! – This forum is powered by b2evolution CMS, a complete engine for your website.