Recent Topics

Bad Request - Illegal value received for parameter «content_scroll»!

Started by on Nov 30, 2016 – Contents updated: Jan 13, 2017

Nov 30, 2016 08:54    

Getting a weird error sometimes when trying to "save & edit" a blog post.

This is the debug output


Bad Request!
The parameters of your request are invalid.
If you have obtained this error by clicking on a link INSIDE of this site, please report the bad link to the administrator.

Additional information about this error:
Illegal value received for parameter «content_scroll»!

Backtrace:

bad_request_die( "Illegal value received for parameter «content_scroll»!" )
File: /home/XXX/public_html/inc/_core/_param.funcs.php on line 456
param( "content_scroll", "integer", 0 )
File: /home/XXX/public_html/inc/items/items.ctrl.php on line 158
require( "/home/XXX/public_html/inc/items/items.ctrl.php" )
File: /home/XXX/public_html/admin.php on line 224
Ignored last: 1

If I hit the back button and click save again, it'd work.
Is this a hosting issue or a bug in the forum software? My host provider (HostPapa) checked and said it's not a mod_security issue.

Using 6.8.2-stable released on 11/17/16.

Nov 30, 2016 08:57

Attached screencap which is probably easier to see.

Dec 15, 2016 02:42

Do you know a view to reproduce this 100% of the time?

Thanks.

Dec 15, 2016 03:15

@fplanque wrote earlier:

Do you know a view to reproduce this 100% of the time?

Thanks.


No. It only happened some of the time when I first reported this. And I just tried to do the same to the post that triggered it and can't get the same thing again.

To be honest I'm not sure if this is a b2evolution issue, or my provider. I did a support ticket with them on this and they checked and said it didn't trip anything.

I'd let you know once I find a way to do this 100% of the time. Thanks for looking into this.

Dec 20, 2016 09:40

Been trying to find a way to do this but unfortunately can't.

Here are some more information which may help (or more likely send you down some wild goose chase)

Strangely this only happen to posts I'm drafting. Editing and saving published posts so far don't trigger this error. Not sure if the text itself is an issue, but in general the posts I'm working on are usually around 2000 words or more.

Also only started to have this issue in 6.8.1 and 6.8.2.

Dec 23, 2016 05:43

So, I've modified the code in question slightly and print out the contents when it's content_scroll, the code is

bad_request_die( sprintf( T_('Illegal value %s (%d) (%d) (%s) (%s)'), 
                                    $var, 
                                    !is_scalar( $GLOBALS[$var] ), 
                                    !preg_match( $regexp, $GLOBALS[$var] ),
                                    $GLOBALS[$var],$regexp ));

And I get the following output. So on appearance the problem is the contents of "content_scroll" is a floating number, but the type says it's of integer. And hence the error.

I'm not familiar enough with the code yet to know if there is some deeper issues at work here. And odds are there are deeper issues at play, because this failure doesn't happen 100% of the time.

Dec 26, 2016 07:55

Ok thanks, we think we have identified this and fixed it. It should be working in the next release (coming soon).

Jan 13, 2017 03:07

Just a quick follow, am on 6.8.3-stable for a couple days now, and AFAICT this issue is gone. Pretty confident this is fixed now.

Thanks again to the b2 team for the great software that is b2evolution!

Jan 13, 2017 17:13

Thanks for the confirmation.


Form is loading...

CMS software – This forum is powered by b2evolution CMS, a complete engine for your website.