Recent Topics

Error after installing blog to my website - help!

started by on Sep 13, 2016 – Last touched: Sep 15, 2016

Sep 13, 2016 17:39    

My hosting plan had b2evolution blog for an open source app, so I installed it that way and once it was fully installed, I clicked the button to go to my blog login page and received this error:

Warning: require_once(/data/18/4/113/133/4602133/user/5450005/htdocs/blog/inc/_core/_class7.funcs.php): failed to open stream: No such file or directory in /data/18/4/113/133/4602133/user/5450005/htdocs/blog/inc/_init_base.inc.php on line 113

Fatal error: require_once(): Failed opening required '/data/18/4/113/133/4602133/user/5450005/htdocs/blog/inc/_core/_class7.funcs.php' (include_path='.:/usr/share/php:/usr/services/vux/lib/php') in /data/18/4/113/133/4602133/user/5450005/htdocs/blog/inc/_init_base.inc.php on line 113

I looked into the paths and noticed that the _class7.funcs is missing which is why I'm getting the error, but I've tried repairing it multiple times and downloading the blog manually from my computer and noticed that the functions were missing there as well, so it wasn't much help.

I'm just wondering and hoping someone has encountered the same problem or knows a way to fix it. Thank you!!

Sep 13, 2016 22:33

Your web host seems to be installing an old version of b2evolution that is not compatible with PHP7. More recent versions of b2evolution are compatible with PHP7 and don't have this bug.

Please replace the b2evolution files on your hosting plan with the latest version that you can download here: http://b2evolution.net/downloads/ . This way it will work with PHP 7.

Basically, you need to follow the manual upgrade procedure described here: http://b2evolution.net/man/upgrade-instructions (you might start at step 3, since you don't have anything precious to backup yet).

Sep 13, 2016 23:52

Ooh okay, so I did that, and it shows a working page now, but it won't let me pass the install menu. Does that mean I did the basic config wrong? The install menu only shows the language options and nothing that I can continue on..

Sep 14, 2016 02:58

Oh my... I thought you'd be at least able to use the the DB set up by your web host but it seems that may be wrongly installed too :/

Before I continue, I'm curious: what happens if you click on "my site" in the top right?

Anyways, I'd recommend you make a clean b2evolution from scratch so you don't have to suffer from what your webhost may or may not have been doing correctly/incorrectly behind the scenes.

Here is a step by step guide for making a complete clean install: http://b2evolution.net/man/installation-guide

Also, can you tell us who your webhost is for our records? Thanks.

Sep 14, 2016 04:55

Depending on provider, you may find that the current PHP version assigned may either too old or too new.
Many problems may arise when your PHP version is not properly assigned, so much so that many providers do not know how to properly deal with them.
Ideally you would see deprecated warnings (when too new), but old(er) PHP versions may just simply fail.
I suggest you check the assigned PHP version in C-Panel and report back.

Sep 14, 2016 16:11

I'm running my website through Register.com and they currently support PHP 5.3.x.

The install I did yesterday was pretty much entirely a clean install except for the edits I did in the config file which can be easily changed back to the default settings.

When I click "Your site" it brings me to this page: (which again is why maybe my config file is wrong?) I tried to match the information from my SQL Database to the config file but maybe I did it wrong?

It's also weird because both b2evolution AND LifeType didn't install properly on my domain which are the only 2 open source applications for blogs that I have available on Register.com as a quick app install (besides Wordpress which worked like a charm when I tried installing that)

Sep 14, 2016 18:23

Did you edit the file _basic_config.php manually or did b2evolution's installer create the file for you?

Can you post the contents of your _basic_config.php file here? (just replace your DB password with *****)

Also please check you have:


/**
 * Once you have edited this file to your settings, set the following to 1 (one):
 */
$config_is_done = 1;

At the end of the file.

Also please check the file permissions to make sur the file is readable by PHP.

Sep 14, 2016 18:45

Okay I definitely didn't do the config_is_done = 1 - but I just changed it and now I get a new error message.

I have a feeling I didn't set the config file up correctly because I have no idea what I am doing lol.

I didn't originally have the basic config file so I copied it from the template file and created a new file.

I want the blog to be displayed on www.left-tees.com/blogger and I attached a file of my database info for b2evolution

My config file:

<?php
/**
 * This is b2evolution's basic config file.
 *
 * You do NOT need to edit this file. In most situations, the installer will do it for you.
 * If however you are doing a MANUAL install, make sure you do NOT edit _basic_config.template.php !
 * You should edit _basic_config.php instead. If _basic_config.php doesn't exist yet, then
 * open _basic_config.template.php and SAVE it AS _basic_config.php.
 *
 * Reminder: every line starting with # or // is a comment, multiline comments are
 *           surrounded by '/*' and '* /' (without space).
 *
 * IMPORTANT: Take special care not to erase quotes (') around text parameters
 * and semicolums (;) at the end of the lines. Otherwise you'll get some
 * "unexpected T_STRING" parse errors!
 *
 * Contributors: you should override this file by creating a file named _config_TEST.php
 * (see end of this file).
 *
 * @package conf
 */
if( !defined('EVO_CONFIG_LOADED') ) die( 'Please, do not access this page directly.' );


// TODO: dh> this file was meant to be used for things where you only need the basic config..
// fp> also:
// - At least _admin.php should only be called when in the backoffice.
// - Also we should probably start by moving as many conf options to the backoffice as possible and see how much stuff is left in conf files
//    Note: some stuff does not make sense in the back-office (for example stuff that depends on the physical path where the files are installed)
// - In view of reorganization, please list (all or examples) of situations where only a subset of the conf should be loaded.


/**
 * Maintenance mode. Set this to 1 in order to temporarily disable access to the application.
 *
 * Note: it is still possible to access the install script during maintenance mode.
 */
$maintenance_mode = 0;


// Below is an alternative hardcore version of maintenance mode.
// This one will block the install script too.
// Remove /* and */ to activate.
/*
header('HTTP/1.0 503 Service Unavailable');
echo '<h1>503 Service Unavailable</h1>';
die( 'The site is temporarily down for maintenance. Please reload this page in a few minutes.' );
*/


/**
 * MySQL DB settings.
 * Fill in your database details (check carefully or nothing will work!)
 */
$db_config = array(
	'user'          => 'lefttees',     // your MySQL username
	'password'      => '**********',     // ...and password
	'name'          => 'b2evolution2',  // the name of the database
	'host'          => 'localhost',    // MySQL Server (typically 'localhost')
);


/**
 * the tables prefix (gets placed before each b2evo table name),
 * use this to have multiple installations in one DB.
 *
 * @global string $tableprefix
 */
$tableprefix = 'evo_';


/**
 * If you want to be able to reset your existing b2evolution tables and start anew,
 * set $allow_evodb_reset to 1 or 2.
 *
 * $allow_evodb_reset = 1; will give you an option to delete the DB in the install menu.
 * $allow_evodb_reset = 2; will allow you do auto-delete if you try to install again.
 * Use option 2 only on developer installs where there is no chance to lose important data,
 * not even important test data.
 *
 * NEVER LEAVE THIS SETTING ON ANYTHING ELSE THAN 0 (ZERO) ON A PRODUCTION SERVER.
 * IF THIS IS ON (1 or 2) AND YOU FORGET TO DELETE THE INSTALL FOLDER, ANYONE WOULD BE ABLE
 * TO ERASE YOUR B2EVOLUTION TABLES AND DATA BY A SINGLE CLICK!
 */
$allow_evodb_reset = 0;	// Set to 1 or 2 to enable. LEAVE this at 0 on production servers!


/**
 * If you are a developer and you are making repeated installs of b2evolution, you might want to
 * automatically set a very easy password for the admin.
 *
 * DO THIS ON DEVELOPMENT MACHINES ONLY! NEVER USE THIS SETTING ON A PRODUCTION SERVER!
 */
// $install_password = 'easy';


/**
 * If you are a developer and you are making repeated installs of b2evolution, you might want to
 * automatically force the install of the .htaccess file that matches the current version without
 * requiring an extra confirmation.
 *
 * DO THIS ON DEVELOPMENT MACHINES ONLY! MAY BE DANGEROUS ON A PRODUCTION SERVER!
 */
// $htaccess = 'force';


/**
 * $baseurl is where your blogs reside by default. CHECK THIS CAREFULLY or nothing will work.
 * It should be set to the URL where you can find the blog templates and/or the blog stub files,
 * that means index.php, blog1.php, blog2.php, etc. as well as admin.php.
 * Note: Blogs can be in subdirectories of the baseurl. However, no blog should be outside
 * of there, or some tricky things may fail (including intempestive logouts)
 *
 * IMPORTANT: If you want to test b2evolution on your local machine, do NOT use that machine's
 * name in the $baseurl!
 * For example, if your machine is called HOMER, do not use http://homer/b2evolution/blogs/ !
 * Use http://localhost/b2evolution/blogs/ instead. And log in on localhost too, not homer!
 * If you don't, login cookies will not hold.
 *
 * @global string $baseurl
 */
$baseurl = 'http://localhost/b2evolution/blogs/';
// Use the following if you want to use the current domain:
/*
if( isset($_SERVER['HTTP_HOST']) )
{	// This only works if HOST is provided by webserver (i-e DOES NOT WORK IN PHP CLI MODE)
	$baseurl = ( (isset($_SERVER['HTTPS']) && ( $_SERVER['HTTPS'] != 'off' ) ) ?'https://':'http://')
							.$_SERVER['HTTP_HOST'].'/';
}
*/


/**
 * $assets_baseurl could be used to load assets from a different domain, like a cookie-less domain or a CDN.
 * Assets can be all kinds of static contents: CSS, JS, media images, skin specific CSS, etc.
 *
 * @global string $assets_baseurl
 */
$assets_baseurl = $baseurl;


/**
 * This is used to create the Admin and the demo accounts at install time (not used after install).
 * @todo move to installer.
 */
$admin_email = 'postmaster@localhost';


/**
 * Once you have edited this file to your settings, set the following to 1 (one):
 */
$config_is_done = 1;


/*
 * IMPORTANT: you will find more parameters in the other files of the /conf folder.
 * IT IS RECOMMENDED YOU DO NOT TOUCH THOSE SETTINGS
 * UNTIL YOU ARE FAMILIAR WITH THE DEFAULT INSTALLATION.
 */
?>

Sep 14, 2016 20:50

Just a quick note:
On some providers - like Godaddy, for example - the DB name and the DB user name must be the same.
Maybe that's got nothing to do with nothing, but I thought I mention it, just in case.

Sep 14, 2016 22:30

If that was an issue, wouldn't my Wordpress not be working then?

Sep 14, 2016 22:56

First, if you would post a screenshot of the exact error message it would help. Because if you say "a different error message", how are we supposed to guess??

Anyways, in your config file, I see:

	'host'          => 'localhost',    // MySQL Server (typically 'localhost')

But on your DB screenshot I see that the DB sevrer name is supposed to be mysqlcluser13.

So your config should probably be:

	'host'          => 'mysqlcluser13',    // MySQL Server (typically 'localhost')

PLease try and let us know.

Also, please tell us who your web host is, for our records.

Sep 14, 2016 23:56

Sorry, I sent a link to where the blog is going with the error but I guess I should have made that more clear!

I changed the server name and it didn't do anything. The error is still there.

I'm hosted from register.com

Sep 15, 2016 03:19

Thanks fir the screenshot. I confirm that the problem is the Mysql hostname.

Note that I made a typo earlier when copying from your screenshot.

I wrote:

	'host'          => 'mysqlcluser13',    // MySQL Server (typically 'localhost')

But it should be:

	'host'          => 'mysqlcluster13',    // MySQL Server (typically 'localhost')

with an added t.

Please double check that the name is exactly as on your DB settings screen. You can copy/paste it.

Sep 15, 2016 16:10

Oh good call!! That helped. Now onto another issue :(

"Installer" still leaves an empty page with just the language to choose from, and "Your Site" looks like this:

Is this something with my database?

Sep 15, 2016 22:34

Ok, this is weird, I have never seen this before.

Can you unzip and upload the attached files into your install folder? (the attached files should replace the ones on the server).

This will print some debug info on screen in an attempt to figure out what is happening on your server.

Thank you.


Attachments:

Sep 15, 2016 23:45

Ah, the new file shows the issue!! See below.

You need to ask your webhost for more RAM to run B2evolution.


Form is loading...

powered by b2evolution – This forum is powered by b2evolution CMS, a complete engine for your website.