Recent Topics

comments won't allow image?

Started by on Jun 10, 2004 – Contents updated: Jun 10, 2004

Jun 10, 2004 08:35    

I posted image files to new-post. it is fine. when I want to post comments with a picture, the same method won't work. the image won't show, even the html tags. anyone knows why? can I post image as comments? thank you.

Jun 10, 2004 12:37

the tags allowed in the comments are displayed in the comment window.

IMG is not implemented there.

Jun 10, 2004 17:12

You can enable this in .../blogs/conf/_formatting.php.

Look for this bit:

Code

// DEFINITION of allowed XHTML code for COMMENTS (posted from the public blog pages)
Add "<img>" to the list of $comment_allowed_tags.

IMG tags are not allowed in comments because it allows strangers to link to big files and whatnot. File uploading is not implemented in comments like it is in posts, because it would be insanely insecure. (Someone could use your site to host their own porn gallery!)

Jun 10, 2004 21:16

isaac wrote:

You can enable this in .../blogs/conf/_formatting.php.

Look for this bit:

Code

// DEFINITION of allowed XHTML code for COMMENTS (posted from the public blog pages)
Add "<img>" to the list of $comment_allowed_tags.

IMG tags are not allowed in comments because it allows strangers to link to big files and whatnot. File uploading is not implemented in comments like it is in posts, because it would be insanely insecure. (Someone could use your site to host their own porn gallery!)

Ok. I see the point. Thank you very much!
One question for advice. my personal blog posts photos. If there are too many in one new post, that will be too long. that is why I like to post some photos in comment. is there any better way to post pictures/photos? or is there an addon to serve as a photo album for b2e? like phpnuke? just want to explore some options. thanks again!

Jun 10, 2004 21:46

There's several ways you can split up a post. Using <!--more--> will put any text after it only on the permalink page (text before is shown on both the main list page and permalink page).

You could also use the multipage posts option by using <!--nextpage--> whenever you want a new page. This is all shown in the posts of demo blog b when you first install b2evolution.

Jun 10, 2004 21:51

Have you tried multipaged posts with the <!-- nextpage --> tag ?

Jun 10, 2004 22:09

That tag didn't work for me... Nothing showed up, not even a post (although it did ping the various sites...)

Jun 11, 2004 00:05

Thank you, Guys. I tried <!--more--> and <!--nextpage-->. they work well. <!--page--> won't work.
thanks again.

Jun 11, 2004 15:35

okay nextpage, not page. My mistake.

Post above edited.

Feb 28, 2005 15:22

What if I cannot add images even after adding the <img> at the end of the allowed XHTML-Tags? If I edit the comment in the admin backoffice, it works, but as a non registered user, I always get the message <img> ist not allowed.

Can anyone help me?

Mar 04, 2005 11:56

Seems as if noone else has this problem.

Mar 04, 2005 23:43

kding,

If you like to post a lot of messages in your blog, have a look [url=http://www.randsco.com/index.php/2005/01/31/css_photo_caption_zoom]at this method[/url].

It keeps the images quite small, allowing room for more text and or images in a smaller space. When the visitor puts their mouse over the image, it zooms to full size.

Have a look.

-Scott

Silencer - I think, for security reasons, it's not a good idea to allow images in the comments ... so you're correct ... not so many people have that problem.

Apr 19, 2005 22:18

I have the same problem as silencer. I've added <img> to the list, but it still says 'illegal tag' when I try to post a comment with an image. I understand the risk and I know I can always disable it if I get abused. Is there some other code that I need to change?

Aug 09, 2005 13:57

.

How to enable <img>-tag in comments of a b2evolution-blog:

  1. open file: conf/_formatting.php in your b2evolution installation
  2. change line

    Code

    $comment_allowed_tags = '<p><ul><ol><li><dl><dt><dd><address><blockquote><ins><del><a><span><bdo><br><em><strong><dfn><code><samp><kdb><var><cite><abbr><acronym><q><sub><sup><tt><i><b><big><small>';
    to:

    Code

    $comment_allowed_tags = '<p><ul><ol><li><dl><dt><dd><address><blockquote><ins><del><a><span><bdo><br><em><strong><dfn><code><samp><kdb><var><cite><abbr><acronym><q><sub><sup><tt><i><b><big><small><img>';
  3. change line
  4. Code

    'small' => C_E_Iinline
    to:

    Code

    'small' => C_E_Iinline,'img' => C_E_Iinline
  5. change line
  6. Code

    'small' => C_A_attrs
    to:

    Code

    'small' => C_A_attrs,'img' => C_A_attrs.' src alt',
  7. save the file on your server[/list:o]
  8. Now your visitors can post images in the comments of your weblog by using the img-tag:

    Code

    Some comment blabla.. here is the image: <img src="http://some.image.com/photo.jpg" /> bla..

    Hope that helps - at least it worked for me in b2evo v 0.9.0.11 ...

    cu, holger

Aug 09, 2005 14:34

Awesome. That worked for me in version 0.9.0.12 as well. Thanks, holger.

Apr 16, 2006 06:54

While we're on this subject, is there any special reason why the "pre" tag is excluded by default? Somebody was trying to post an ASCII picture and it wouldn't work, so I'm turning "pre" on. Hopefully this won't mung something up?

PS Hey, ASCII-art fans are just the kind of folks my blog is destined to attract! Particularly when I give a good review to a Linux distro that has lots of ASCII-art generating utilities.

Jul 11, 2006 19:23

hmmm i also want to allow images in my comments, i'm using phoenix, tried a lot with _formatting.php but in the end it didn't work. what do i have to change? :)


Form is loading...

multi-blog – This forum is powered by b2evolution CMS, a complete engine for your website.