Recent Topics

problem with l33t_gray skin?

Started by on Sep 05, 2004 – Contents updated: Sep 05, 2004

Sep 05, 2004 06:06    

I am thinking about turning on skin options in my blog. I figured since I've hack the snot out of my installation I should make a shiny bright blog and slowly dial it and some skins to the way my blog is. That way I would be able to turn on skins that I knew worked the way I want them to. I started with nescafe and l33t_gray. nescafe had some issues on the skins site I didn't like so I tweaked them out. l33t_gray seemed okay so I didn't do anything to it. I uploaded them to http://www.wonderwinds.com/skintest/ and l33t_gray doesn't work. I get the header and the first post, then this:

Code

Parse error: parse error, unexpected '}' in /home/wonderw/public_html/skintest/skins/l33t_gray/_feedback.php on line 1

So what's the deal? Do I have to exercise my constitutional right to bear arms against my host? Oh by the way I have not done the fix regarding the missing stats dealie thing in l33t_gray - just downloaded, unzipped, and uploaded. Any help will be greatly appreciated.

Sep 05, 2004 20:03

*blink* What the... ? Line one?

I have NO idea what's up with that, but I'll look into it as best I can. I've been thinking of putting a test install on one of my web site's databases. It would only be the basic install of b2evo so that I can unzip skins there and test them. I've hacked SO many files in my current installation that I want to be sure the skins I make work in a standard install.

But I haven't done that just yet. And I'm baffled as to why line one would give such an error. Hmm... *pad off to have a look*

Sep 05, 2004 20:13

I confess that I altered _feedback.php but it was for style purposes. Mostly I only changed a few divs. Mostly.

I didn't touch line one though. I looked and the first line reads:

Code

if(substr(basename($_SERVER['SCRIPT_FILENAME']),0,1)=='_') die("Please, do not access this page directly.");

I think that's code from v0.9.0.8. I didn't change that bit because it seemed to work fine. What seems odd is that the portion of code doesn't contain a single {

The _feedback.php in my v0.9.0.10 /blogs/skins folder (not in /blogs/skins/l33t_gray) reads:

Code

if( !defined('DB_USER') ) die( 'Please, do not access this page directly.' );

It doesn't contain a { either.

Perhaps the difference is playing havoc? If all else fails, try backing up /blogs/skins/l33t_gray/_feedback.php and then replacing it with a copy of /blogs/skins/_feedback.php to see if that makes a difference.

I'm afraid those are my only guesses at this point.

Sep 05, 2004 20:15

I've tested this skin with 0.9.0.9, 0.9.0.10 and the current CVS version, and it seems to work fine.

Instead of testing things online, it's much quicker to do it locally. If you're a windows user, just install yellowtip webserve, linux usually has apache installed by default, and I'm sure there much be some sort of web server for osx...

Sep 05, 2004 20:19

*smack self in forehead* You're right Graham. It IS a lot easier to do locally. Yes, I can easily set up and Apache server locally on my iMac running OS X. I also have Yellow Dog Linux on my iBook, which I adore. I may do that instead. Thank you for the suggestion.

As to the error mentioned above, I noticed that this bit is commented on l33t_gray/_feedback.php:

Code

/**
   * This is the template that displays the feedback for a post
   * (comments, trackbak, pingback...)
   *
   * This file is not meant to be called directly.
   * It is meant to be called by an include in the _main.php template.
   * To display a feedback, you should call a stub AND pass the right parameters
   * For example: /blogs/index.php?p=1&more=1&c=1&tb=1&pb=1
   * Note: don't code this URL by hand, use the template functions to generate it!
   *
   * b2evolution - {@link http://b2evolution.net/}
   * Released under GNU GPL License - {@link http://b2evolution.net/about/license.html}
   * @copyright (c)2003-2004 by Francois PLANQUE - {@link http://fplanque.net/}
   *
   * @package evoskins
   */

That bit DOES have a few {'s. But... they're commented out. They shouldn't matter, right? Perhaps deleting the comment will help?

Sep 05, 2004 21:00

I once thought about testing locally but I couldn't see the point. It's taken a couple of hours, but I now have a standard-compliant ality (which was murder), basic (in html 4), bluesky (which can't really be xhtml compliant) & clean (which was reasonably quick). I haven't gone near the gray one yet because (a) I'm not alphabetically there and (b) I was concerned that perhaps there is a server-specific issue with it. It seemed odd that the skin obviously works on two other sites but didn't from my installation. This comes back to testing locally: what if it works locally but not from my server? Ultimately it has to work from servers serving up webpages, and in my case it's my faux-Texan server that really lives in Florida.

I've been noticing some of the differences in the "DIE" statement from skin to skin but haven't changed any of them...yet. Most of what I've been doing has been in the main and the css - the support files are getting a mild cleanup.

So here's what I'll do: I'll finish up making a happy version of clean then violate my alphabetical nature and take a spin through the feedback file in gray.

Oh and I noticed the lack of a curly brace on line one also. I wonder if it's a carry-over issue from the preceding content calling the file? In other words my server expects a { or was it a } right away and therefore kicks up an error when it ain't there. Dunno. Dunno nuthin bout it to tell ya the truth!

Sep 05, 2004 21:51

Okay so this is way cool. Way super cool. Totally awesomely spectactularly way super cool. Or not.

I unzipped the gray skin on my desktop to be sure of what I was looking at. I downloaded the version from my server to compare. It seems I have the version that belongs in skins in my zip. Clearly that's not right. One would want a version for skins/skinname that will make a call to the one in skins. I then opened the file from custom (in an unadulterated .9.0.10 unzip that I keep for special occasions) and verified beyond any doubt that I had the wrong file. I copied the contents from skins/custom to skins/late_gray and uploaded. Reloading the page got me a bit further - it choked for a } missing on line 1 again.

Same routine: different results. Downloading and opening the file from my server showed it to be totally corrupted - the entire contents of the file strung out on one line. The zip showed a normal file so I simply uploaded leet_gray's proper bloglist file to the server and took anothe reload. This time I got stuck for an extra $ on line 1 of linkblog. Again downloading showed me a corrupted file, only this time everything EXCEPT the commented out block at the beginning was strung out on line 1. I mean the commented text just wasn't there. Again the desktop unzip appeared normal so I shot it over to the server and managed to get to the actual factual end of the file.

I could tell it was the end because I saw the awesome badge of greatness linked to the amazing site of wondrous bloganalia. I clicked the link and here I am! (And that just goes to show you how important it is to have that blogger badge of courage.) Somewhere along the line either the zip or my upload (or both?) went belly up. On principal I just downloaded earl_gray and unzipped it. _feedback is definately the one that normally lives in the skins folder, but the other two are normal files. Hey it's all better now so live is good!

Sep 05, 2004 21:59

NS? That's very odd. I used [URL=http://www.maczipit.com/]ZipIt[/URL] to make the file, which normally makes very good cross platform zips. If it was my zip file then I apologize. If anyone else has this problem please post here and I'll see what I can do about it... perhaps try a different zip utility or what not.

In the meantime, I'm glad to hear that the skin now works for you Ed.

^_^

Sep 06, 2004 06:36

One last question on this thread, please. I see your next skin, the MT knock-off, also has the skins-level version of _feedback.php in it. Is this intentional? See I haven't noticed what's not right because once the page loaded I moved on to older and duller projects. I'm wondering if I need to take the _feedback you provided - the one that I started with and somehow seems wrong to me - and put it back in now that my corrupted files have been saved. Oh and I was using Mozilla172. I haven't opened Netscape71 since the last time.

Sep 06, 2004 16:38

*nod* It's intentional. Because of the three tiered layout it had to be formatted in a manner that was at least slightly different from the original. Was the MT_dot_org _feedback.php corrupt too?

Sep 06, 2004 17:25

ALL the php files in MT dot were shot in the "no line break" manner. It doesn't all go on one line by the way. Apparently there is a limit to the length my editor will tolerate before it forces a line break. The css file was the same way. but the HTC was okay. Funny part ahead: please put down any beverages. The unzip on my desktop is clean but the re-download of files from my uploaded files are corrupt.

In other words I unzipped to my desktop and uploaded from there to my server and downloaded from my server to my web folder. I then opened all the files in my web folder and saw them be yucked. So I opened all files from my desktop and saw them to be clean. Copy from desktop version to web folder version and save, then re-upload from web folder and all is well.

All the other skins I have downloaded from the skins pile does not require this hoopulation. Very strange...

Sep 06, 2004 18:30

I used a different zip utility (unix zip from the command line) to create the MT_dot_org zip. I know the zip is good this time. But you mentioned line breaks. That may be the key.

I've heard that some servers running Plesk 7 are very picky when it comes to line breaks within cgi files... that people uploading files with line breaks from a windows app like Notepad found their files didn't work but people uploading files with line breaks in a unix style from apps like Kate didn't have the same problem. Perhaps this is something similar. Maybe the line breaks from Mac OS X's text editor is causing problems?

Regardless, I've decided that from now on I'll edit and package my skins from my Linux machine. That way if there are *nix servers out there that are so picky about line breaks the line breaks in my files will be standard unix so it won't matter.

Thank you for posting reports of your problems Ed. I'm grateful.

Dec 28, 2004 06:40

I know this thread's pretty old, but when I tried to use l33t_gray, I got the old:

Code

Parse error: parse error, unexpected '}' in /home/wonderw/public_html/skintest/skins/l33t_gray/_feedback.php on line 1

That happened when I used WS-FTP 9.x.

But when I used Coffee Cup's Direct FTP 6.2, everything went just fine.

Just a tidbit someone may find interesting.

Dec 28, 2004 06:54

Really? That is interesting. Thanks tnt. I may include that in the next readme file.

Dec 28, 2004 17:52

Just for fun, I tried l33t_gray with a new blog. I can't say I was as rigorous as I've been known to be, but I was able to replicate the problem

Again, using WS-FTP, l33t_gray failed with the parse error. After deleting the skin and using Coffee Cup Direct FTP, it worked.

Dec 28, 2004 19:26

Schweet. Thanks for the testing tnt. :)

Jan 12, 2006 21:22

Reviving this thread yet again... trying to make some changes to MT_dot_org... specifically, trying to move "left column" over so I can have the main content column, then two side columns next to each other on the right... having the "no line breaks" problem... when the skin is first loaded, no errors, but then making any change... including just deleting a blank line... gives me that line 1 error... also got it with line 2...

Any thoughts on how to fix this?


Form is loading...

multiblog engine – This forum is powered by b2evolution CMS, a complete engine for your website.