Constantly being required to give login/password [Solved]

« URL validation fails when there's "=" before &quot :: arcdir and post_nav_links »
Author Message
cchris
Posted: Tue Dec 6, 2005 13:46     Topic subject: Constantly being required to give login/password [Solved]

I just installed 1.6-alpha the other day and it seems to require a login/password way too often.

When I save a blog entry, I'll find I've been logged out and have to log in again to do any editing

To get around being logged out when I clicked Save, I tried clicking "Exit to blogs", thinking that would leave me logged in. It does, but when I edit an entry and try to save the changes, if there's an error in the HTML that requires me to go back to the post to fix it, I get caught in a loop:

The Login window appears, then when I've logged back in, I can't use the browser's Back button or the [Back to post editing] link to return to the post to edit the code because the login window keep appearing. I then have to start over and lose the changes. Each time this happens (three times this morning!), the follow-on attempt to edit a post succeeds.

Is there a setting I can adjust to limit how often the Login window appears? And what's causing the loop problem?

Thanks,
Chris

Back to top
 
personman
Posted: Tue Dec 6, 2005 14:31

Does the url you've typed into your browser match the baseurl you set when you installed? If one has www. and the other doesn't, the cookie won't work and you'll have to login over and over.

Back to top
 
cchris
Posted: Tue Dec 6, 2005 16:55

Hi personman,

Thanks for your reply. I think I'm using the same www.toptechwriter.us URL, what should I check to verify it? If they're the same, should I delete the browser's cookies anyway?

--Chris

Back to top
 
personman
Posted: Tue Dec 6, 2005 17:13

I checked and your baseurl is set as www.toptechwriter.us/weblog so if you're using that url to login, then that should be right. Yes, delete your cookies and see if that helps.

Back to top
 
cchris
Posted: Fri Dec 9, 2005 05:22

I deleted the cookies but that didn't fix the problem. Then I noticed that the problem seemed to occur only when I accessed my blog from the Safari bookmark. I checked the bookmark's URL and sure enough, it was missing the www! I've fixed them all and the problem hasn't happened again.

Thanks everybody for your help on this one!

Back to top