Recent Topics

[not a real bug] upload file is permission 600 i.s.o. 644

started by on Jan 12, 2006 – Last touched: Jan 12, 2006

Jan 12, 2006 23:33    

I just noticed that since dawn, my uploaded files have the permission 600 in stead of 644 like before.
That is a problem, because my own backup (ftp) is not working anymore.

Where can I change those settings ?
Anybody else noticed this ?

Jan 13, 2006 15:27

The 'umask setting on my server' ??
Now you are talking chinese to me.

Do you mean, my hosting provider had changed somothing on the server ?
And I have to ask them to do 'something' ?
Or is it something I can do in my cpanel ?

Jan 13, 2006 15:34

I'm not sure. Here's the [url=http://us2.php.net/umask]php page for umask()[/url]. It's something that can be done is a script, but I think your server also has a default setting. I would ask them what it is and see how they suggest you change it.

Jan 13, 2006 17:10

In /admin/b2upload.php there are always to lines where chmod() gets used to set the perms to 644.

But they have been commented out before the Dawn release.

The solution would be to just remove those comment chars (lines 118, 123, 155 and 160).


Form is loading...

blogging software – This forum is powered by b2evolution CMS, a complete engine for your website.