Recent Topics

1 Feb 17, 2015 02:35    

I like this problems. Every time interesting. And I would happy, it would work as it should do ...

My situation:
b2evo in the newest version 5.2.1
locale de in UTF-8
no TinyMCE editor in usage

the database char is UTF-8 Unicode (utf8)
and the database connection is utf8_general_ci

I write a new post, in it some of the signs of this wikipedia site:

My Post:

I mark a part of the table of the wikipedia side in my browser firefox 35-0-1 under kubuntu. Then I paste it into the "edit post" side in b2evo in the expert mode. It works like it should - I can see the signs.

In the preview I see it too.

After saving and make it public there will be this you can see on the side now:

I put the copy in blockquote and code too, same result. Next time I copied it in Firefox with a plugin only as text - nothing changes, all is as described.

Curious. And I hope for a solution to public the icons, not this small error.
It would great, if you have an idea.

2 17 Feb 2015 22:01

Hi @ednong,

It's pretty intersting indeed, however, I'm afraid this is a very complex "issue", limited even by the minimun MySQL version supported by b2evo. As far as I could read, the "Miscellaneous Symbols and Pictographs" ( characters are above the range that utf8 fields are able to store, so it would be necesary to use a different collation in the database and a lot of more techy stuff in order to properly support them.

I'm not even close to be an expert on this, but the support of those characters is poor in general, actually, in my browsers, I can see only four figures from the whole table. In addition to that, none of the most important CMSs supports them either (or at least those that I tested in default instances).

Let's see the opinion of the developers about this.


3 17 Feb 2015 23:46

I also run the latest version of FF and the image above shows what I see when go to the page you linked before. I think this is a little sample of the lack of support for that set of characters.

The preview is an on-fly version of the post that isn't already saved into the database, so the "miscellaneous" symbols hasn't been trimmed from the content yet, I think it's the same case for the emails (I must confirm). So, that's the reason why you see them in some cases.

If you try to edit the post again after having saved it, do the symbols remain in the content (I bet they don't)?

4 18 Feb 2015 00:01

All right, I finally managed to get the symbols ( I was forced to install a new font, which is not an ideal situation :S ). However, the database problem is still the same I mentioned before. So, let's see what options do we have.

5 18 Feb 2015 00:36

I'm curious and so I installed WP here (need it for support and tests for clients also). And I create the same kind of posts.

And - surprise: it works like in b2evo! :P

Means: in the editor (TinyMCE, I guess, this works here and not in my b2evo) creates a table, if I copy and paste it. If i mark it only and paste it or mark it and copy only text (with the plugin of FF), it put text in the editor. Symbols are seen all over. And if I save it - the post are empty like mine in my blog - only the text "U+1F446 (128070)" will be seen.

Really crazy this thing.

6 20 Feb 2015 17:10

Hi mgsolipa,

it is interesting. In my browser - FF newest - I can see all of them (on the german wikipedia side). And it is unbelievable - in the preview after creating the post I can see all of them. See the screenshot.

And the coolest - if I click on "Save and edit" in b2evo, I get an email. And in this email all of them are visible. And if I go to my blog page, I see nothing but this

It is absolutely crazy, I think.

Here there is a edited screenshot of it.

Form is loading...