Recent Topics

1 Apr 13, 2015 04:13    

using 5.2.2 - new install

Entered twitter Login and password on auth page

Get Error:

bad_request_die( "Missing target params!" )
File: /home/********************/blogz/plugins/twitter_plugin/_twitter.plugin.php on line 340
twitter_plugin->htsrv_twitter_callback( false )
File: /home/********************/blogz/inc/plugins/model/_plugins.class.php on line 1218
Plugins->call_method( "25", "htsrv_twitter_callback", false )
File: /home/********************/blogz/htsrv/call_plugin.php on line 90
Ignored last: 1

B2evo twitter plugin not showing up in list of apps on twitter.

Anyone know the cause?

2 Apr 13, 2015 08:35

Hi @sunder,

Linking new accounts using the Twitter account is broken right now. So, there is a patch that may work but please tell how used are you to hack the code (detailed instructions will be provided).


3 Apr 14, 2015 00:50

I can edit the php, if that is what you are asking.

4 Apr 15, 2015 07:45

Is it broken in all versions? I thought I used the stable release 5.22.

I was using an 0.91, but it would not upgrade so I installed 5.2.2 from scratch. Is there any other known help sites for this?

I cant get any info on my other external feed burner problem post. Cant get to feedburner.

here are the url's I entered in the advance tab.

I can add a url link to the side bar and feedburner loads, why does it not load when I click the post link under rss.

I guess if you are not a serious php coder you are not going to find a way to fix stuff.

I spent 4 hours messing with the twitter plugin only to find out it was broken and not me that messed it up.

Did I miss the post or sticky that said that, not likely, it was just not there.

5 Apr 15, 2015 08:57

@sunder let's keep this post only for the Twitter plugin issue.

I will share a personal solution that I applied to deal with it, so it's not official, maybe not elegant, but it works. Note: all the references to files and line numbers are based on version 5.2.2.

1. Go to inc/plugins/_plugin.class.php, find the function get_htsrv_url and replace all its code (lines 2766 to 2785) with this new one:

	function get_htsrv_url( $method, $params = array(), $glue = '&', $abs = false, $sess_params = false )
		global $htsrv_url, $htsrv_url_sensitive;
		global $ReqHost, $Blog;

		$base = substr($ReqHost, 0, 6) == 'https:' ? $htsrv_url_sensitive : $htsrv_url;

		if( ! $abs && strpos( $base, $ReqHost ) === 0 )
		{ // cut off $ReqHost if the resulting URL starts with it:
			$base = substr($base, strlen($ReqHost));

		$r = $base.'call_plugin.php?plugin_ID='.$this->ID.$glue.'method='.$method;
		if( !empty( $params ) )
			if ( $sess_params )
				global $Session;
				$Session->delete( 'params' );
				$Session->set( 'params', serialize( $params ) );
				$r .= $glue.'params='.rawurlencode(serialize( $params ));

		return $r;

2. Go to htsrv/call_plugin.php and replace all the content of lines 52 to 59 with this code:

if( is_null($params) && ! $Session->get('params') )
{ // Default:
	$params = array();
{ // params given. This may result in "false", but this means that unserializing failed.
	if( is_null($params) ) 
		$params = $Session->get('params');
	$params = @unserialize($params);

3. Go to plugins/twitter_plugin/_twitter.plugin.php and replace the line 255 with this:

$callback = $this->get_htsrv_url( 'twitter_callback', array( 'target_type' => $target_type, 'target_id' => $target_id ), '&', true, true );

4. Go to the plugins settings page in the backend and link your twitter account as usual.

I recommend to make a backup of each one of the files that you will modify, that way you can easily roll-back these changes any time you want. Actually, you can roll them back after having connected all the twitter accounts to your users/blogs, because the issue doesn't affect posting to twitter once the account is properly linked.

I guess this issue will be solved soon and included in a future release, so at that moment, these instructions won't be necessary anymore.


6 Apr 15, 2015 23:24

Thank you worked great. I am now linked

8 Jul 13, 2015 13:24

I'm glad I found this post, as I've just discovered the same issue myself with linking to Twitter. I need to move to 6.5.0, but need to do a few things first before I go there. Perhaps the hack might be an option on the meantime - I'm currently running 5.2.2 on my live site..

9 Jul 14, 2015 19:01

@chris_of_arabia: give the hack a try and tell us how is it going.

As I said before, this issue is already fixed in version 6.5.0, so you won't need to do anything else after upgrading.

Form is loading...