Recent Topics

param(-): params is not array!

Started by on Jun 24, 2015 – Contents updated: Jun 25, 2015

Jun 24, 2015 16:54    

Hello,

While trying to detect problems with bootstrap (another thread) I found this error message in the error log of my server:

[Wed Jun 24 08:49:35 2015] [error] [client 171.215.44.38] b2evolution error: param(-): params is not array! in /home/.sites/xx/sitexxx/web/blogs/inc/_core/_param.funcs.php at line 247 / REQUEST_URI: /blogs/htsrv/anon_async.php / HTTP_REFERER: http://www.npo-consulting.net/blogs/notepad.php/2010/03/29/book-on-demand-eine-geniale-alternative-zu-ebook-und-print/, referer: http://www.npo-consulting.net/blogs/notepad.php/2010/03/29/book-on-demand-eine-geniale-alternative-zu-ebook-und-print/

This error happened after updating to 6.4.4

Another Error that may be connected to b2e:
[Wed Jun 24 12:33:51 2015] [error] [client 85.219.187.254] client denied by server configuration: /home/.sites/xxx/sitexxx/web/xmlrpc.php

Could it be that an instance in b2e adresses xmlrpc.php not in the root of b2e (/blogs/ - where a xmlrpc.php is located) but in the root of the webspace (/)

How can I manage this?

Thanks and regards, will

Jun 25, 2015 23:41

@saunders in the first case, is this error constantly repeated in your logs or just a one time thing?

In the second case, unless you have modified the variable $xmlsrv_subdir at the conf/_advanced.php file, I think that error has nothing to do with b2evolution. I knew about an issue related with that file in wordpress, so maybe there is a robot trying to find a hole in your site.


Form is loading...

Content Mangement System – This forum is powered by b2evolution CMS, a complete engine for your website.