Recent Topics

Photo thumbnail not working

Started by on Oct 22, 2017 – Contents updated: Dec 13, 2017

Oct 22, 2017 02:44    


I'm using b2evo version 6.9.3 with Apache 2.6.4 on a Centos 7 dedicated server. It's a new installation, with b2evolution in its own directory and the doc_root set to /var/www/html/b2evolution. I haven't yet deleted any of the default blogs or photos, since I'm trying to make sure I understand how everything works first.

The problem: none of the photo thumbnails are showing. If I click on their links (e.g. monument valley), the photo appears just fine. But the thumbnails just show the spinning wheel of death. PHP is running as the apache user, apache owns the media directory, and I've set media and its subdirectories with 774 permissions, per the online documentation. SELinux hasn't given any complaints about directory permissions. I'm also not getting any pictures showing for user profiles. They're uploaded; they just don't show in the profile as shown in the manual.

I'm still very new at this, so I'm pretty sure I've just missed something obvious. But, after two days troubleshooting, I'm out of ideas.

Any ideas what I might be missing? Or what other information would be helpful for troubleshooting?



Oct 24, 2017 18:59

I've got the exact same issue, however I'm running v6.8.3 (yes, outdated I know, but it should still work at the very least). The admin's icon shows up fine, but literally every single other image just shows the spinning wheel of doom. I've checked in the cPanel File Manager, and the images are all there. They'll show up in a little popup if I click on them. But that loading bar just persists... I'm running it on a free web host, just for tinkering purposes, but I want to make sure this is an easily resolved issue before I install b2evo on my real host.

Kind of sad, because I'm really loving this software so far. It seems to provide everything we could possibly need.

The website where this is occurring can be accessed from my profile.

Dec 02, 2017 01:24

I've looked through the debug info, and can't find anything obviously wrong. (Of course, I'm not quite sure what I'm looking for.) I've also tried easing the permissions on the media/shared directory, but no change.

I also tried changing the location in admin from /index.php/photos to use an extension off my base url. I thought it should be /media/shared/global/photos, but that threw an error saying the folder already exists. Which it should, so why would that cause an error?



Dec 13, 2017 04:31

SOLVED: I had a feeling all along that there was a simple problem/fix. Turns out it was completely simple. I had not installed the gd2 library, yum install php-gd. I noticed this in Site...System...Status. Big yellow notice, along with advisories about opcode caching, imap extensions, etc.

Installed the gd2 library, rebooted the machine, and thumbnails are now working. Sheesh.

On the brighter side, I know a bit more about b2evo...

Form is loading...

CMS + user community – This forum is powered by b2evolution CMS, a complete engine for your website.