Recent Topics

1 Jul 13, 2016 11:20    

I am now using b2e 6.7.4.
Trying to embed in my site the plug-in ShareThis, although files are properly uploaded in the relative folder “b2evo/plugins/sharethis” in the File Manager of my hosting account with Webhost4life, I cannot find this plugin in the b2evo / System / Plugins / Rendering

Checking the “Available plugins for Installation” clicking on the "Install new" button, I am finding the following message:

“Warning: require_once(addons/pluginaddon.class.php): failed to open stream: No such file or directory in /hermes/bosnaweb06a/b1536/whl.athineoscom/b2evo/plugins/sharethis_plugin/_sharethis.plugin.php on line 37 Fatal error: require_once(): Failed opening required 'addons/pluginaddon.class.php' (include_path='.:/usr/local/lib/php-5.5.22-amd64/lib/php') in /hermes/bosnaweb06a/b1536/whl.athineoscom/b2evo/plugins/sharethis_plugin/_sharethis.plugin.php on line 37”

I have also embedded the Shareaholic” plugin in the same folder (plugins) which also I cannot find in among the plugins

What am I doing wrong?
Can anybody help me with this?

2 Jul 13, 2016 11:28

Atthaching screen shot

3 Jul 13, 2016 21:29

Hi @athineos,
I double-checked those plugins and they work properly.

Can you please make sure that the folder [b]addons[/b] is correctly uploaded toplugins/sharethis_plugin/` as displayed in the screenshot below?

Thank you.

5 Jul 14, 2016 09:00

Hi! @fplanque
Thank you for your answer.
I tried to install b2evolution through MOJO marketplace but I could not because I was receiving various error messages.
I asked the help of support team of Webhost4life and they installed it for me in a domain that I am not using a long time ago just for experimenting purposes with the tool.
I don't konw which installer they used.
As regards the installation of Share & Shareaholic plugins, I have downloaded the plugin and copied all folders and files in the plugin folder of b2evo
Should I reinstall b2evolution again?
Is there a version of b2evolution that includes those plugins or at least one of them?

6 Jul 14, 2016 09:14


If this might help, here is the conversation i have had yesterday with support team of Webhost4lif

Vijaya K

I am sorry. Please provide me the steps to duplicate your issue.

3:00:16 PM
Alexandros Athineos

In the File Manager you open the folder b2evolution and then the folder plugins - sharethis - addons . In the column Action, click on the magingying glass icon - Then you will receive the message I told you

3:02:17 PM

In the files I have downloaded there were no index pages

3:07:40 PM
Vijaya K

On our server, the default page is the index page. If your pulgin has any other page as the default page, then please set that as your folder index page.

Alexandros Athineos

Normally, having uploaded the plugin files, I should find the plugin in my b2evolution tool but I don't. That means that something is going wrong with the server. I have already uploaded a skin which works properly

3:04:04 PM
Vijaya K

Yes, it is loading the error because you are trying to access the folder 'sharethis' which is inside /b2evo/plugins/sharethis_plugin/addons

3:04:23 PM
Vijaya K

However, there are no index pages inside this folder. This is the reason you are getting the error message.

3:04:35 PM
Vijaya K

There must be an index page inside the folder to get it working.

3:05:29 PM
Vijaya K

I can see the pages sharethis.class.php and sharethis_colorbox.js inside that folder.

3:09:21 PM
Alexandros Athineos

I am not so experienced to do that. Can you do it for me?

3:11:05 PM
Vijaya K

Yes, I can set the default page. Please provide me the index page name.

3:12:23 PM
Alexandros Athineos

What do you meen the index page name? Where can I find it?

3:13:17 PM
Vijaya K

Index page will be the main page that will load when the website URL is accessed. If you access the URL,, then the index page inside the folder 'addons' will load.

3:13:38 PM
Vijaya K

If you access the URL,, then the index page inside the folder 'sharethis' will load.

3:14:50 PM
Vijaya K

You can also try contacting any web developer for more help with this.

3:15:15 PM
Alexandros Athineos

OK - Thank you for the help.

3:15:33 PM

7 Jul 14, 2016 09:21

Thank you for your answer
I have checked again the folders and files and as I see they are properly installed
The point is that I cannot find both plugins (ShareThis & Shareaholic) in the Installed plugins but only for the one of these I am receiving the error message I have atthached in my first post

8 Jul 15, 2016 03:00

1) That support chat is a joke. The guy has no clue. Ignore it.

2) Again you should check the unix file permissions of the plugin files you uploaded. The files you uploaded must be readable by PHP.

Here is info about file permissions:

You may ask support to your webhosts specifically for verifying that the file permissions are correct (but you can probably figure it out yourself; just compare the file permissions of the plugin files with the ones of the rest of b2evolution).

9 Jul 15, 2016 14:21


Re: 1) That support chat is a joke. The guy has no clue. Ignore it.
That is what I thought too, so I thanked the guy and closed ticket

Re: 2) Again you should check the unix file permissions of the plugin files you uploaded. The files you uploaded must be readable by PHP.

In the File Manager I have changed all folders and files permissions to 777
After that, from the System / Plugin tab I clicked on reload plugins button
In the list of Installed plugins,nothing changed. There was no new plugin installed
Clicking on the "Install new" tab, I am finding the same message, screenshot of which I have attached in my first submission
Do you thing I should delete completely previous installation and try a new installation from scratch?

10 Jul 16, 2016 02:15

@mgsolipa Please double check the require_once() statement in question because I think it lacks an absolute path. Requires should NEVER use a relative path. (Not trustable from host to host)

@athineos In the meantime, can you try to delete that plugin you seem to have that is called widgetmanager_plugin or do you really need it. It hurts my eyes to see the mess it displays on your screen.

11 Jul 16, 2016 06:28

I thought it would be useful for something in the future and I installed it but If that makes you happy I have already deleted it
As regards "require_once()" ,the error message insists that something in the path is missing
But I have another question: What about the Sareaholic plugin which also it is not displayed among the "available plugins for installation"

12 Jul 16, 2016 11:55

@fplanque @mgsolipa

After having fixed a problem with the hosting server, when trying to preview the scripts for ShareThis and Shareaholic plugins, I am receiving following error messages:

Fatal error: Class 'Plugin' not found in /hermes/bosnaweb06a/b1536/whl.athineoscom/b2evo/plugins/sharethis_plugin/_sharethis.plugin.php on line 4

Fatal error: Class 'sharethis_pluginAddOn' not found in /hermes/bosnaweb06a/b1536/whl.athineoscom/b2evo/plugins/sharethis_plugin/addons/sharethis/sharethis.class.php on line 4

Fatal error: Class 'Plugin' not found in /hermes/bosnaweb06a/b1536/whl.athineoscom/b2evo/plugins/shareaholic_plugin/_shareaholic.plugin.php on line 4

Fatal error: Class 'shareaholic_pluginAddOn' not found in /hermes/bosnaweb06a/b1536/whl.athineoscom/b2evo/plugins/shareaholic_plugin/addons/shareaholic/shareaholic.class.php on line 4

13 Jul 18, 2016 03:01

Sharethis and Shareaholic where both last touched by @mgsolipa . They probably both have the same path bug.

16 Jul 20, 2016 23:32

I have uploaded and installed ShareThis plugin but I have not checked if this works properly in the blog pages and the posts.
AddThis and Shareaholic could not be installed. As I have noticed, in the Zip file there were not included the folders "addons" and "rsc" and of course the relative files (see attachement). The same happens with Shareaholic.
I tried - unsuccesfully - to use the "addons" and "rsc" of previous downloads.
So please check again the Zip files of AddThis and Shareaholic and the folders "addons" and "rsc"
Meanwhile I will check if the ShareThis plugin works properly and i will keep you informed
Best regards

17 Jul 21, 2016 00:35

@athineos quick notes regarding any of the sharing plugins:

  1. The code is now simplified, so the extra folders addons and src are not needed anymore.
  2. Note that sometimes the folder of the uncompressed file may include its version number, so as seen in your screenshot, you need to upload the folder removing this version number. i.e.: addthis_plugin-1.6 must be uploaded as addthis_plugin.


18 Jul 21, 2016 17:13

Sharethis & Shareaholic plugins have been properly uploaded and I cna see them in the list of "Installed Plugins"
AddThis appears at the end of subject list as "unclassified" with an error sign
In the edit mode I am receiving following error message: "Plugin class file [plugins/_addthis.plugin.php] is not readable!"
See attachement

19 Jul 21, 2016 17:18

Find also the screen shot from the unclassified items of the "Installed plugins"

20 Jul 21, 2016 17:44

@athineos did you delete the AddThis plugin before to try a new install?

Please, check the following video and make sure to repeat each step (

Thank you.

21 Jul 24, 2016 13:29

Hi again!
I have deleted all files from my computer and from the File Manager in my host
I have repeated the procedure step by step
Nothing has changed
addthis_plugin remains in the section "unclassified" and wehn I open it I am receiving the same message
"Plugin class file [plugins/_addthis.plugin.php] is not readable!"
I am telling you all this just for your information because I am already covered by the use of the two other plugins "Shareaholic" and "ShareThis" but if you want me to try anything else I will do it with pleasure
Thank you for your assistance
Best regards

Form is loading...