Recent Topics

[Plugin] AstonishMe Digg plugin

Started by on Feb 08, 2007 – Contents updated: Feb 08, 2007

Feb 08, 2007 00:38    

Update: [url=http://b2evo.astonishme.co.uk/index.php/2007/02/09/astonishme_digg_plugin]This plugin has been released at AstonishMe[/url]

Digg.com is a social bookmarking and news site. Users submit stories, then vote on which stories make it to the front page. This plugin makes it easier for you and your readers to submit your blog posts to Digg. Once a post is submitted, there will be a button on your blog showing how many Diggs the story has received.

This is a prerelease. I would love to have some people test this out and let me know if it works and if they have any ideas for me. Then I'll make a real release on AstonishMe.co.uk and plugins.b2evolution.net

I have not tested this on version 1.8.x. Please let me know whether it works for that version. This plugin takes advantage of the brand new [url=http://digg.com/tools/integrate]Digg This Integration[/url] that was just announced yesterday. It acts as a submit button and a badge reporting how many links you have and a way for users to digg your post right from your blog. The placement and size of the button are customizable in the plugin settings. Set the renderer to 'Always' to instantly put digg buttons on all of your posts.

Note: If you start submitting a lot of blog posts to Digg, be prepared to be berated by Digg users (unless you post some good, original content to your blog). That's why the renderer is set to opt-in by default. Ideally you'll only add the button for really good posts.

Note #2: When I was almost finished with my plugin I ran accross [url=http://forums.b2evolution.net/viewtopic.php?t=10635]balupton's digg plugin[/url]. I tried it out and I changed my plugin name and code so as not to collide with his. Give them both a try if you like. I think mine is a bit easier to use, but don't take my word for it.

Feb 08, 2007 06:12

Haven't taken a look at it yet, but how come you are not using 'lazy' rendering? And I guess that the plugins blog or whatever it is that topanga is working will stop this conflict from happening again?

I'll take a look at it later and maybe we can just merge the best of both into one?

Feb 08, 2007 12:54

Try mine out and you'll see why it doesn't use lazy. It's because there's nothing to add to the post. If you check the box it adds your post permalink url automatically. So, mine doesn't allow you to specify some other url like yours does. But I don't think it's meant to be used like that. It's meant to refer to the page where it's placed.

Feb 08, 2007 19:25

Update. I tested this out on 1.8 and it works fine. I did have to fix a couple of bugs affecting all versions. If you have trouble, grab the latest copy of the zip file.

Feb 09, 2007 00:09

Danny, can the DIGG iframe have it's padding reduced/edited or is that entirely driven by Digg and fixed?

Feb 09, 2007 14:08

John,
I haven't figured out a way to change the padding inside the iframe. I'm not even sure there is any padding inside the iframe. It seems to have it's width manually set.

Feb 10, 2007 09:34

The digg.js sets the height/width. For the small one it's app 18 x 110 .
It's a shame because it can't be aligned left due to the extreme "waste of space" :)
I guess they build on room for really big Dugg numbers!

Feb 26, 2007 01:29

Hi,

I'm trying your Plugin and it works fine except for something I don't know how to handle.
I want it to be rendered as always, but then the Linkblog Links at the sidebar get each a Digg It button too.
So, how can I enable it as always rendered for the main posts but disble it absolutely for the linkblog or even a SideBlog?

Best Regards

Feb 26, 2007 01:37

Good question. I don't know of a way to do that, but I'll think about it. Anyone else have ideas?

Feb 26, 2007 01:54

I've just discovered that at the Back Office in Examine Blog - Full Post I get this error:

Code

Name of Post
 
Fatal error: Call to a member function on a non-object in /home/content/x/x/x/xxxxxxxxxxx/html/plugins/am_digg_plugin/_am_digg.plugin.php on line 112

Even so the Digg It button is where it should be and works fine. This is something that happens at the back Office and that truncates the rest of the Posts List.

Feb 26, 2007 02:13

When did you download the plugin? That was a bug that was fixed about a week or two ago. If your copy of the plugin is older than that, grab the latest version. If not, it may be a different bug and we'll need some info about what version of b2evolution you're using.

Feb 26, 2007 02:42

Version is 1.8.2 and the plugin was downloaded today.

Feb 26, 2007 02:56

This plugin has been tested more with version 1.9.2. It's the newest and best version of b2evolution. Upgrading to that will probably fix your problem. I can try to correct the problem on the older version, but I'm not sure when I'll get to that.

Feb 27, 2007 23:57

personman, no need to work on a fix for the 1.8.2 version, I decided to upgrade to 1.9.2 and it works just fine.

May 07, 2007 05:28

Hi, when I tested it out, it is producing JS errors when viewed under IE7 (haven't tested with IE6).

I temporarily turned it off on my blog, I'll turn it back on if there's a need to check.

Jun 01, 2007 19:17

Hi all,

When I try to download the plugin the target site does not work [there is some sort of database error]. Could someone post the plugin on this forum/thread please?

Thanks in advance.

Jun 01, 2007 19:51

Hmmm, you're the second person to mention that, can you tell me what the error is ?

If you pm me with your email address I'll send you a copy of the plugin.

¥

Jun 06, 2007 14:47

All4Data,
Go to the plugin settings (App Settings > Plugins > AstonishMe Digg) and change the Digg button size setting to Compact.

Danny

Jun 06, 2007 14:59

thanks personman, will try that

edit: as there anything else I need to do to change the cache or nything, please?

Sep 28, 2007 05:42

Hi.

Great plugin. My only issue is that on my "main" page, it does not generate a direct link to the article if someone clicks digg this, it just creates a link to http://elitenick.com/blog. It only works correctly if someone clicks permalink first and THEN clicks the digg this button. How can I get it to work both ways?

Nov 30, 2007 18:32

I'm having quite a few problems simply downloading the AstonishMe Digg plugin. I've attempted it on several machines and consistantly get the message that its an invalid zip file.

Does anyone have another link to it by any chance?

Nov 30, 2007 18:50

Ooops, sorry, that'll be my fault, we've just migrated servers and I haven't ironed out all the kinks.

I'll link it the moment I find it ;)

¥

Nov 30, 2007 18:58

Thanks Yabba! I know that its exactly what I've been looking for and I'm very anxious to put it to work! :)

Sorry I got your name wrong -- I can't read on Fridays ;)

Nov 30, 2007 19:01

And... thank you so much! Now I just have to get it installed! :)


Form is loading...

Build your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.