Recent Topics

1 Feb 26, 2007 03:05    

My b2evolution Version: 1.9.x


I'm testing a fresh installation of b2evolution. It uses PHP5 and is located under the directory "blogs" of my home account.

After this fresh install I went to "App Settings" and enabled the option "Use extra-path info". I'm glad to say that this works; I can visit all sample blogs (All, A, B, linkblog) with URLs of the form That's good (i'll see how to get rid of the "index.php" later on).

Now, I added my first own blog, blog C. Execept for the name, it has the same options as blogs A and B. When visiting my site I can see now the C tab at the top. Unfortunately, when I click on it I get:

404 Not Found
b2evolution cannot resolve the requested URL.

I renamed the sample.htaccess file to .htaccess but nothing changed. However, there are no problems if I uncheck the "Use extra-path info" option. My new blog C shows up well.

I've been through the forum messages but the picture seems to be complicated. Stub files and .htaccess recipies get badly mangled for someone taking a first test drive of b2evolution.

What do I need to do with blog C to get it to work with "Use extra-path info"?

Do I really need to create a stub file for it? And the same for every new blog that is created (what a pain this would be!)?

Why can't the nice URLs "just work"? I'm testing Wordpress in parallel since I'm trying to decide between these two. On this from is Wordpress +1, b2evolution -1. With wordpress getting nice URLs to work was a simple click away.

I would appreciate any suggestions. Thank you.

2 Feb 26, 2007 15:29

You probably need to find out what it is about your host that's stopping that feature from working. That's what the little disclaimer is all about - it works if your server supports it. Truth be known I've no idea what your server needs to support the feature since all the hosting accounts I've used have an do. I think if I ever hit on a host that doesn't let me use b2evolution with extra path turned on I'd switch.

BTW there's no way C can have the same settings as blogs A and B. Like what's in your url blog name and stub name field? You don't have to use stub files, and you don't have to create them, but if you use them you have to create them. It's possible that your server configuration is such that it can't do pretty urls without an existing stub (even if you don't use it), or that you have to have the URL blog name field filled in. I don't know what happens if you don't fill it in because I always use stubs and always have something in that field so this isn't a for-sure this-will-fix-it answer - just some stuff to think about.

Listen don't bother to keep a score. Decide what you want your blog app to do for you, then pick the app that meets your needs. No matter what you choose you'll find yourself dealing with the limitations and embracing the features.

3 Feb 27, 2007 04:24

I found it!

1. Both "Stub name" and "URL Blog name" have to have the same value.

2. "Preferred access type" should be "Automatic detection by index.php".

This last part was what got me confused. My selection for Blog C was "Automatic detection by index.php", just like Blogs A and B; so initially I didn't bothered filling in the "Stub name". And when I finally tried something there its value happened to be different from the value I was testing in "URL Blog name".

Why the "Stub name" is important when the preferred access type is not "Explicit reference to stub file (Advanced)", I've no idea. But for the posterity, just follow the two rules above and everything should just work.


4 Feb 27, 2007 14:53

Cool. Thanks for the followup. BTW the URL blog name is what your media folder will be called if you use blog-based directories when uploading media.

Form is loading...