Recent Topics

1 Mar 08, 2007 11:48    

When using the file manager to archive a series of files in a number of directories, the generated zip file is not correct. It seems that the archive/zip routine does not not accurately represent folders/directories correctly.

When I try to unzip the archive the directory name is shown as a file and not a directory. Hence when a file within a sub directory is then unarchived, the directory it should reside in can not be found.

I have tested the archive routine separately, I believe that the fault is in that routine, but I do not have enough knowledge to rectify the problem.

I have attached a zip file that was generated by b2evolution and it should have a file in a directory level 2, but it will not unzip correctly.


Chris A Harris

2 Mar 26, 2007 04:17

Has anyone else noticed this problem and found a solution?


3 Mar 26, 2007 16:01

I've never used the file manager to archive a file. I'll give it a go and see what there is to see though.

4 Mar 30, 2007 03:30

Did you manage to confirm this?


5 Mar 30, 2007 06:05

I forgot to get back to you on this - sorry!

Here's what I came up with: first I needed to tell it the file extension, otherwise all I got was what I put in. Either way it made a .zip file because I could rename "file" to "" and it would then unzip properly. The only drawback I had was that it zips them as loose files instead of files in a folder. I did not see any way to download a backup of anything more than the files in any given folder, meaning I couldn't backup my entire media directory in one shot - I had to backup each media/folder independently.

Also my "check all the boxes" button seems broken. v1.9.3

6 Mar 30, 2007 06:22


You have confirmed that there is a problem with the zipping of folders and nested folders. As mentioned in my first post, this does seem to be a problem with the archive routine.

I am not sure where I go from here as I do not have enough expertise to fix the problem!


7 Mar 30, 2007 07:06

How are you zipping sub-folders? I saw no way to try that.

8 Mar 30, 2007 07:10

Okay confirmed. Sub folders will not properly archived. Previously all I confirmed was that archiving files worked fine, so I added a folder and it won't zip it. Then again I added a folder that *I* added, so perhaps I should add a folder that b2evolution generates?

9 Mar 30, 2007 07:17

I added a folder then uploaded a file and had the same problem: it doesn't zip folders nicely. Interestingly enough, when I tried to unzip it using WinXP's "here I can own that zip" feature it asked me for the password for the only file in the subfolder. I took a guess that my password for logging in was my password for the file, and it then told me it was a read-only or system or hidden file and asked me if I wanted to replace it. Hmmm... yeah sure. I then got in a loop where it kept asking me for my password.

I suppose it's possible it's asking for my webspace password, but I don't know what that is so I can't supply it. That's the only reason I don't upgrade my FileZilla: I don't know the passwords it remembered for me.

Form is loading...