Recent Topics

1 Jul 07, 2007 19:24    

My b2evolution Version: 1.10.2


I downloaded and installed version 1.10.2 and at the top of the pages I get the following characters: 

Any idea how to remove them?

Also when I click on the RSS link I get the following error: 'XML Parsing Error: not well-formed.... <?xml version="1.0" encoding="iso-8859-1"?><!-- generator="b2evolution/1.10.2" -->
-^' I'm not sure if these characters again is the issue

Thanks for any help.

2 Sep 27, 2011 16:06

Apologies for resurrecting this very old topic, but I am having the same problem with Version 4.0.5

The characters  are being inserted in the header of every blog

	<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
	<base href="http://.../blogs/skins/photoblog/" />
				<meta name="generator" content="b2evolution 4.0.5" /> <!-- Please leave this for stats -->

Even worse! these characters or something is being output when selecting Dashboard > Photoblog > Global settings ? > Plugin configuration which causes a number of warning messages to be displayed:
Warning: Cannot modify header information - headers already sent by (output started at /.../blogs/plugins/_sorted_bloglist.plugin.php:1) in /homepages/3/d108046940/htdocs/lush/blogs/inc/_core/_template.funcs.php on line 243

3 Sep 27, 2011 17:07

Check any file that you have edited yourself on this installation and ensure that you have saved "Without BOM". The characters are a BOM (Byte order mark) which is added when saving in utf8.

It's probably going to be your config file.

4 Sep 27, 2011 17:51

Thanks but I'm not sure where that would have come in.

I am very new to b2evolution. This is a clean install with one additional plugin added (Amazing Discoveries sortable bloglist plugin) to order the public blogs.

None of the files have been edited, though haapy in PHP I'm a real novice here and have not had time to look round yet. I usually use Bluefish as an editor and have never come accross it on other php files edited.

Form is loading...