Recent Topics

adding custome smilies -again

Started by on Jul 16, 2007 – Contents updated: Jul 16, 2007

Jul 16, 2007 16:53    

I updated both of my blogs and I can't figure out how to reactivate my custom smilies. I uploaded the image files to the rsc folder. I edited the smilies plugin file to add the code for the smilies. I have the smilies plug in activated.

What am I missing?

Blog Version 1.10.2

Jul 21, 2007 16:41

bump for weekend people :D

Jul 21, 2007 17:59

Sorry, you picked a crap week to have a problem, because I missed this.

Just to be sure, the images need to be uploaded to /rsc/smilies/ ( or /skins/<skin name>/smilies/ if you want to customise them on a per skin level ).

Then you need to wander over to admin > app settings > plugins and click the "edit" icon for the smilies plugin, and you should be taken to a page where you can add/edit/remove smilies from a list ( in the format smiley_shortcut<space>smiley_image.gif ( ie ":-| blonde_bimbo.gif" ), hit save and see what happens

¥

Jul 24, 2007 02:53

I also am having a problem with smilies for some reason in v 1.10.12 - the smilies are displayed in my comments form, yet you can't click them so they won't enter their code... even after I've uninstalled and reinstalled the plugin. IE7 tells me there is an error on the page when I click it, it says

Line: 110
Char: 1
Error: Object Expected
Code:0
Url: http://www.navarinounincorporated.com/rants/index.php?title=my_ipod_flew_4800_miles_at_510_mph&more=1&c=1&tb=1&pb=1

Jul 24, 2007 04:56

I am expreiencing similar problems after upgrading from 1.9.3 to 2.0.a. This is probably the same plugin as in 1.10.
I tried uploading new smilies both ways, bot they don't render and they don't show up in the toolbar.

Jul 24, 2007 05:31

While I cannot tell you exactly what the problem is with the 1.1.10 and later smiley plugin, I can tell you that uninstalling the plugin that came with 1.10.2 (the version I am running) and using the 1.9.2 smiley plugin solved the problem. There's probably a typo in the later versions somewhere.

Jul 24, 2007 06:50

I didn't try uploading them to the skin/img directory , so I did that and still no go. I had => in my smilie codes for some reason but I fixed that and still no go.

where did you find the 1.9.2 version?

Jul 24, 2007 08:07

Daethian2 wrote:

where did you find the 1.9.2 version?

If it is not in the Plugin section, download the 1.9.2 complete package and take only the smilies plugin.

Jul 24, 2007 08:17

Pretty sure I know what the problem is, the 1.10 version uses textarea_wrap_selection, and that is not avaliable outside the admin area (i'm guessing), so it requires a js include to use that.

I've moved this to the 1.10 bug reports.

Jul 24, 2007 09:00

balupton wrote:

Pretty sure I know what the problem is, the 1.10 version uses textarea_wrap_selection, and that is not avaliable outside the admin area (i'm guessing), so it requires a js include to use that.

Still, hardcoded new smilies don't work either (mind this, perhaps in an hour if there is a chache blocking fresh view).
Found this out: all smilies are in database (Plugin setting -> smiley_list) so:

PHP

$this->Settings->get'smiley_list' )

returns the full list and displays them in the textarea.
Is there a comma after greyyes.gif or did I accedentally put it there. If not so: remove it.

Jul 24, 2007 09:15

Solved,

It is about the space to disable it. If you add a smiley, you tend to do it at the bottom of the list. Here are some smilies disabled through a starting space. So it seems logical to start with a space yourself. If you remove the space, the smiley comes to life.

Jul 24, 2007 09:31

I am sorry. I made a mistake so stupid, I can't mention it in public. At least the plugin works. Mind the space before the code in the list.

Edit: delete stupid remark after resolving stupid error

Jul 24, 2007 10:47

I've just had a play with the 1.10.x smilies and have no problems adding custom ones?

To make the smiley toolbar work for comments you need to add the following function to the plugin :

PHP

function SkinBeginHtmlHead()
    {
        global $rsc_url;
        if( $this->Settings->get'render_comments' )
        && ( ( is_logged_in() && $this->UserSettings->get'use_toolbar' ) )
            || ( !is_logged_in() && $this->Settings->get'use_toolbar_default' ) ) ) )
        {
            echo '<script type="text/javascript" src="'.$rsc_url.'js/functions.js"></script>';
        }
 
    }

Hit save, upload it then meander over to admin > app settings > plugins and click "reload events"

¥

*edit*
Also had no problems adding them to 2.0 ;)

Jul 26, 2007 17:27

Okay the 1.92 plugin isn't working for me either.
There has to be something I've done wrong because they have always worked before. I thought there was some php file where I had to change a 0 to a 1 or from false to true?

Jul 26, 2007 17:46

The smiley plugin has been recoded to work from admin ( ..... admittedly it was recoded by a blonde so it may have some quirks ;) ), so you shouldn't need to edit any files.

What's the exact problem that you currently have?

If you feel the trusting urge then pm me login details to your blog ( as an admin user ) and your ftp and I'll take a look?

¥

Jul 26, 2007 17:51

You brag about being blonde too much ;) Or is it simply used as an excuse to cover your mishaps :P

Jul 26, 2007 17:53

¥åßßå wrote:

Sorry, you picked a crap week to have a problem, because I missed this.

Just to be sure, the images need to be uploaded to /rsc/smilies/ ( or /skins/<skin name>/smilies/ if you want to customise them on a per skin level ).

Then you need to wander over to admin > app settings > plugins and click the "edit" icon for the smilies plugin, and you should be taken to a page where you can add/edit/remove smilies from a list ( in the format smiley_shortcut<space>smiley_image.gif ( ie ":-| blonde_bimbo.gif" ), hit save and see what happens

¥

Can you see what I've done wrong?

I renamed this one to preserve it when I reverted to the 1.9.2 version
http://foreverpurple.com/images/_smilies.plugin10.php
1.9.2 file
http://foreverpurple.com/images/_smilies.plugin.php

Jul 26, 2007 18:41

1) In the skins folder the smilies should be one directory higher, so not under ./purple_???/img/smilies/ but under ./purple_???/smilies/

2) A lot of images (1.gif through 7.gif and 9.gif through 12.gif and 14.gif through 17.gif) are not in the folder. Put them in the ../blog/rsc/smilies/ folder and/or in the smilies folder of your skin.

3) your backoffice smiley edit settings look fine.

Good luck

Jul 27, 2007 01:28

yeah I caught the missing ones and fixed them before I posted but didn't update the screenshots but that should have just displayed the dreaded red X right?

Jul 27, 2007 02:26

But did it solve your problem adding smilies to the backoffice and using them? Both ¥åßßå and I report no problems.

Jul 27, 2007 09:27

balupton wrote:

You brag about being blonde too much ;) Or is it simply used as an excuse to cover your mishaps :P

It's called "fair warning" ;)

Daethian2 :
Your problem was that you had a comma after each of your custom smilies, I removed it and now they appear to work ;)

¥

Jul 30, 2007 20:27

¥åßßå wrote:

balupton wrote:

You brag about being blonde too much ;) Or is it simply used as an excuse to cover your mishaps :P

It's called "fair warning" ;)

Daethian2 :
Your problem was that you had a comma after each of your custom smilies, I removed it and now they appear to work ;)

¥

THANK YOU THANK YOU THANK YOU!!!!


Form is loading...

Build your own website! – This forum is powered by b2evolution CMS, a complete engine for your website.