Recent Topics

1 Jul 19, 2007 10:29    

My b2evolution Version: 1.10.x

I've been having this problem from the start.
At first it was ok, but now I have problems with saving a post when I use the expert mode.
If I use the Simple mode, it works ok.
What happens?
- Create a post in expert tab
- Save post in expert tab
- does not get saved :-/
- create a post in simple mode
- try to save the post
- it's saved... :roll:
Sometimes I can save in expert mode, but out of the blue, after saving some posts, it doesn't work anymore...I realy have no clue what to do.

Things I tried:
- I've changed my my memorylimit already (, but that did not work.
- After reading this post ( I changed the settings and also asked my provider, but there does not seem to be the problem. All my other databases work fine.
- I uploaded the files from /inc/ folder again

Does anybody have a idea?

2 Jul 19, 2007 11:37

Number 3 is the only trick I know enough about to suggest, but I do know what type of info might help smart people figure this one out.

What's your php and mysql versions? Smart people like to know more than that, but that sounds like a good beginning. They like stuff like libraries and magics and stuff that has it's own little version number inside php, and they like to know weird little details about database configurations, but all I know is to ask the version of the big-ticket items.

3 Jul 19, 2007 12:35

Here is all the techstuff I can find :roll:
PHP5/ PHP 2.64-pl2
Apache 2.0.x
MySQL 5.0.38
And see attachment!
HOpe it is enough, because my knowledge stops here... :lol:

4 Jul 19, 2007 19:53

Hi Erica,

You did a good job by excluding some of the trivial errors. Let's dug a little deeper.
I have this funny feeling something went wrong during the database setup. Was your 1.10 version setup from scratch or an upgrade?
Try looking for the MySQL error logs. I found:

By default, all log files are created in the mysqld data directory.

You can try the following:
1) make a backup from the database (through cPanel or phpMyAdmin or IIS)
2) run blogs/install/install.php and choose the upgrade option. I am not sure what it does now. It checks a database version number. This will be the same as the one it is trying to install. Hopefully it now checks the database itself, if not it skips this step and you have not gained anything. If so (and you feel confident) you could delete the database, create a new one and restore the backup.

Good luck

5 Jul 19, 2007 20:21

This is tricky stuff!
I have never made a backup of my sql database and all the other stuff you ask me to do... :-/
I hope my hard work filling my blog won't be for nothing... :roll:
I will ask my provider how to do this. After that I will get back to you.
By the way, I found an error message. It says:
Extra options for working with linked tables are disabled, read here why:
PMA Database ... Not good
Basic relation options disabled.

$cfg['Servers'][$i]['pmadb'] string
The name of the database containing the linked-tables infrastructure.

See the Linked-tables infrastructure section in this document to see the benefits of this infrastructure, and for a quick way of creating this database and the needed tables.

If you are the only user of this phpMyAdmin installation, you can use your current database to store those special tables; in this case, just put your current database name in $cfg['Servers'][$i]['pmadb']. For a multi-user installation, set this parameter to the name of your central database containing the linked-tables infrastructure.

Really beats me what to do next!! 8|

6 Jul 19, 2007 20:22

I have a new idea. It might be a plugin and perhaps a plugin calling the database. You might check this by disabling all plugins and do some random posts in expert mode. Try to generate the error. If you do not get the error, try enabling the plugins one by one etc.

Good luck

7 Jul 19, 2007 20:27

When I choose the plugin screen...
It's blank?! :?:
Should I download the directory again?
I see via my ftp de directory is full of nice stuff...but I can't see it in backoffice...

And the same with the tab files...nothing there..

8 Jul 19, 2007 20:49

Now were getting somewhere.

Try a new upload of a fresh download for all the files. Take the first few steps from until running install.php
It's just like what you did for the /blogs/inc/ folder, but now for the complete setup.
Remember: there is information about your setup in /blogs/conf/_basic_conf.php and you probably have edited skins you want to keep. You can safely upload these old files after your done with the new ones.

Good luck

9 Jul 19, 2007 20:53

You just won't believe it!
I downloaded the Dutch translation and installed it a few days ago.
So I disabled it and tried to save an expert made post...en guess what!?
I can save in expert mode again :D .
I tried it a few times and it still works. Let's hope it stays that way.
I keep you all posted.

For now thanks voor all you input!! ;D

10 Jul 19, 2007 20:58

Hm, I wouldn't have come up with this solution ;)
Old translations are supposed to be compatible with newer versions of B2evo.

11 Jul 19, 2007 21:01

Do I report this as a bug, or is it ok like this?

12 Jul 19, 2007 21:52

(Cool - a smart person came along so I'm off the hook ;) )

13 Jul 19, 2007 21:54

Don't worry about the bug report: you're covered on that one. I've no idea how or when it'll be fixed, but someone will.

14 Jul 19, 2007 22:01

One more thing, if you don't mind: would you be willing to download a couple of different languages and see if you have a problem with expert mode using them? The idea here is we would know if it's the Dutch translation or translating in general that is causing this.

Also I'm confused by you seeing a blank plugins tab. That is a symptom of the memory limit problem so I would have to ask if you know that your memory limit went up when you told it to. It could be that host doesn't allow that to happen and that really "translations make things weird when the memory limit issue is present" is the problem eh?

15 Jul 19, 2007 22:05

I am not confident that the translation is the cause of the problem. Perhaps something like: with the translation enabled there is a memory shortage.

16 Jul 19, 2007 22:50

I've tried the German and French pack. Same problems there.
About the can I check this?

18 Jul 19, 2007 23:24

Ok, I've changed the following files to 24:
(did them al, wanted to be sure :lol:)
Activated dutch language

it works like a charm!


I even have the hope I can change to my favorite skin!

19 Jul 20, 2007 00:34

Glad it works! :)

Which PHP version are you using?
With PHP newer than 5.2.1, the default is 128M already (the memory management/reporting is different).
So when changing to PHP 5.2.1 you probably need to bump/uncomment this change again and therefor it would be better to have it only in one place.. :)

20 Jul 20, 2007 02:31

PHP5/ PHP 2.64-pl2
Which document is best to change?
Than I can change the other ones back to 16m, or is it 8?

21 Jul 21, 2007 21:42

2.64-pl2 is probably the version of phpMyAdmin, not PHP.
I would only change it in .htaccess - but it makes no sense to change it in _advanced.php to 8/16, because it will overwrite it: you should rather uncomment/remove it there.

Form is loading...